Needs Help to STOP Car Dock from Reading txt MessagesSupport


Last Updated: 2013-10-18 15:54:52
  1. gjd5150

    gjd5150 New Member

    This Announcement of txt message received while in the car dock is killing me...is there any way to stop it. even if the car dock app is not running but the phone is in the dock it still announces if i want to have the txt read to me...i cant find anywhere where to remove this.. totally frustrated!!

    Advertisement
  2. redsox985

    redsox985 Well-Known Member

    I think I fixed this at one time. I honestly can't remember though. I use Google Car Dock now as I like it better. You can change the home panel layout and have 6 icons to the Blur dock's 4. It's not on the market though, but you can side load the app.
  3. gjd5150

    gjd5150 New Member


    Tried that no go with that program either...once a txt message comes in it still has a pop up screen that says "text message from xxxxxx say listen to hear message" .....i just want it to do nothing..car dock doesnt have to be running. it just has to be plugged into the doc and it happens. example txt comes in while on home screen but plugged into dock. it pops up every time..
  4. gjd5150

    gjd5150 New Member

    so after searching everywhere no1 has an answer to my problem. so last night i decided to root my phone and get titanium backup to freeze the problem app...well it kinda works. now when a txt comes in while car docked its force closes the car dock program but it does not announce the arrival of a txt message. i froze tts service 2.3.4 i tried freezing pico but that did nothing. I even took the dock apart last night to see if there was a "magnet" or something that makes the phone sense its in the car dock vs the home dock. to my surprise there is not just a small circuit board between the 2 usb plugs. i guess if i remove the board and rewire it. it might work too. but there has to be an easier way...
  5. redsox985

    redsox985 Well-Known Member

    Freeze SmartCarDock.apk and then replace it with the app I'll attach here shortly. It's Google Car Dock, and looks similar to the Blur dock, but it's better IMO.

    EDIT: File attached. You may also have to freeze SmartDock.apk. This, once installed, should enable was soon as placed into the dock.

    Attached Files:

  6. gjd5150

    gjd5150 New Member

  7. redsox985

    redsox985 Well-Known Member

    Damn, sorry. I have multiple .apk files for it. I'll dig them up and attach them.

    EDIT: Here's everything I've found in my many folders...

    I think I've already given your CarHomeGoogle.apk, I'm not sure what Dock.apk is, but I found it in a flashable .zip somewhere, GoogleCarDock.apk seems to be the same as the first, but oh well, and the last two, when installed together, got the dock working for me on an ICS build.

    Attached Files:

  8. Lars

    Lars Well-Known Member

    If you are rooted, permissions denied is a great app too if you still want to use an app but want to revoke some of it's permissions.
  9. LZeitgeist

    LZeitgeist Well-Known Member

    I'm having this problem too - my car dock app of choice is Car Home Ultra, and every time a text message is received, C/H/U force closes. Talked with the developer, sent him an event log and he traced the problem to the native Motorola SmartDock app.

    How do I get SmartDock either A - disabled completely, B - off my phone or C - to stop responding to text messages and crashing the Car Home app?

    I don't want to root, I just want to keep it simple because I know just enough to brick anything I try to fix as far as computer software goes.

    Thank you for whatever help you can offer...
  10. doogald

    doogald Guides Guide

    Well, what you can *try* is to go into (from home)

    settings->applications->manage applications
    Tap the "All" button
    Look for "Car Dock" and tap it
    See if there is a button "clear defaults" and select it.

    If you can do that, the next time that you dock the phone it should ask which app that you want to use as the default car dock, and you can choose the Car Home app.

    If that doesn't work, you may have to root the phone. The good news is that it is a fairly easy process and you wil be able to disable the Motorola smart dock app as well. Reply if you want to go that route...
  11. LZeitgeist

    LZeitgeist Well-Known Member

    I'm familiar with that much of it, and all that Clearing and Setting the Default does is tell the phone which app to choose when docked. Car Home Ultra is already the default app, and SmartDock shouldn't be responding since it's not supposed to be running.

    I followed your suggestion but it still acts as it always has - receiving a text message force closes Car Home Ultra and it has to be restarted.

    I'm not interested in rooting. I know from experience that digging into programming stuff to that point always leads me right into FUBARing what I'm trying to fix.
  12. ffeatccn

    ffeatccn Member

    This worked for me just today- go into your app manager and reset defaults for the stock car mode app so that the next time you dock or connect with your car device via bluetooth, it will ask you which program you want to use to run car mode. Select the stock mode (not CHU) and in the bottom right of the screen is the settings gear. Go into it and select the option for "Silence TTS." I don't remember if you have to check the box or uncheck the box but it will disable the text-to-speech function while you are driving. It has been silent for me the rest of the day after receiving multiple text messages in car mode while running CHU. You don't need root, replacing apps, or disabling anything. I hope this isn't coming too late to help.
  13. LZeitgeist

    LZeitgeist Well-Known Member

    Wow, that's great - I'll try it when I get in the car tomorrow morning. Thanks for the thought!
  14. LZeitgeist

    LZeitgeist Well-Known Member

    OK, followed your instructions to the letter, except that in my case, there is no Settings 'gear' anywhere to be found. Bringing up the Options menu does not list an option regarding text messages as you describe.

    I'm using a stock Motorola Droid 3 and an original Motorola Droid 3 Car Dock.

    Are you using the same? If so, I'm unsure why you have different software with different options to choose from.
  15. ffeatccn

    ffeatccn Member

    What version of Android does your Droid 3 run? I'm on 4.1.2 on a Razr; perhaps that accounts for the difference? I've included my screen shots of the process. The app is simply called "vehicle mode" and the option is "disable tts." Let me know if this helps. If you're on a different version of Android then I'm not sure what else to do. I only stumbled upon this myself. Good luck and let me know if it works.

    [​IMG]
    [​IMG]
  16. ffeatccn

    ffeatccn Member

    I had no idea they would be so huge. I'd edit them down now but I'm old and it is bed time.
  17. LZeitgeist

    LZeitgeist Well-Known Member

    The Droid 3 only received stock updates to Android 2.3.4.

    I appreciate your trying to help, but giving advice on a Droid 3 issue using Droid Razr experience doesn't work - the various software releases are much too different.

    The screenshots you show are similar to what comes up for the Droid 3, but the Droid 3 menu does not offer all the options your Droid Razr does, and is missing the crucial item to apply your solution.

    Thank you for trying to help. It might be exactly because of this seemingly unsolvable problem in version 2.3.4 that your level of software contains that feature. I don't think they bothered to fix it for the Droid 3.
  18. doogald

    doogald Guides Guide

    I have an old Droid 3 and the old dock in a drawer, though the phone isn't active, so I can't test text messaging.

    If I can find a similar setting that ffeatccn describes, I'll see what I can see. It might be tucked away someplace weird.

    Have you looked into other Car Home apps in the Play Store? Perhaps there is one that will not FC when you get a text message.
  19. LZeitgeist

    LZeitgeist Well-Known Member

    Yes, I've tried other Car Home apps besides the one I use - they act the same because the issue is basically hardwired into the Droid 3/Dock interface. It runs in the background, apparently, even if another Car Home app is currently in use.

Share This Page