1. In regards to recently combined carrier specific root forums, if your device forum was affected, please see this poll/thread!

Netflix . . .General


  1. Lennatron

    Lennatron Well-Known Member

    Hi, does anyone know if the official Netflix app or the XDA version will work on this tablet?

    Thanks,
    Lennatron

    Advertisement
  2. AQAA

    AQAA Well-Known Member

    Installs, but fails to play with the message:cannot connect to Netflix servers
    Lennatron likes this.
  3. fonewiz

    fonewiz Well-Known Member

    ***USE THIS AT YOUR OWN RISK***
    ***Worked for me but I can't say if it will work and/or cause problems on your device***

    The info, methods and files for this post was found at:
    [DEV] Netflix patch for Asus Transformer - xda-developers

    UPDATE: I just updated/changed these instructions a bit on a how-to I posted here: http://androidforums.com/acer-iconia-tab-a100/401328-how-netflix-a100.html#post3113033

    I didn't want to have to keep making changes to this reply and to the how-to I posted.

    Here is what I did:

    1- You will need to have root access to your A100 Rooting Iconia A100 Made Easy
    2- Install Netflix from the market, the app will work to browse movies etc but will fail when you try to play video.
    3- Download the Netflix patch zip file to your computer or Tablet and extract it
    4- Find the file libnvomx.so from the extracted zip files and replace the same file on your A100. The file is located in /system/lib/. Would be a good idea to rename the original first.
    5- Reboot your A100
    6- Enjoy Netflix video

    Attached Files:

    Lennatron likes this.
  4. Lennatron

    Lennatron Well-Known Member

    Hello,

    Thanks very much much for posting this. I have rooted my phone before but it was running Android 2.1 so it was as simple as downloading Z4Root from the Market. I have never used the terminal to root before. I was wondering if running the commands is risky and if copying libnvomx.so is risky and easy to screwup. Also if I do mess this up would it be easy to fix? I am worried that there may not be a lot of support for this tablet yet so there are less solutions to flash it back to stock and all that.
  5. fonewiz

    fonewiz Well-Known Member

    Well, there is certainly a risk associated with rooting any device. As you mentioned, due to the limited number of A100 devices in use so far, it will be tougher to fix it if you hose it. I had the same worries myself.

    It's probably best for you to go to the thread I posted regarding rooting issues and post/ask there. In my experience it took me a few days of reading. I tried a similar method over and over from different forums and couldn't get it to root. Finally, I found the link I posted above and it worked.

    The problem is that each set of instructions (including the one I posted) have a few things either slightly incorrect or they assume a certain knowledge on the part of the person reading the instructions.

    For me, the biggest problem I had rooting was not realizing that I had to unzip the file they were referring to. So, I kept placing the file where they told me to to in .zip format which was never going to work. It took me a while of thinking about what the instructions were accomplishing to realize my problem.

    At this point I still don't have a recovery installed on the device because I have not seen a guide or any mention of a recovery that is known to work on the A100. All known hacks right now are for the A500 and that is a different device with a different version of Honeycomb.

    Rooting is good though because you can do things like fix Netflix etc..

    My next goal is to get Rom Manager or similar installed with a recovery so I can backup my device completely in case I mess it up with further mods or it just flakes out for some reason.

    At this point, I am not willing to be the first to install/test installing Rom Manager and/or recoveries. So, I will wait since I may have no way to bring the device back from the dead, as you mentioned.

    Good luck, let me know if I can help..:D
    Lennatron likes this.

Share This Page