Network Defined Time and Date Wrong??Support


  1. petronivich

    petronivich New Member

    Hi i have has the SE arc for about 2weeks now and i have noticed that my time and date are wrong, they have been fine up till now.
    The current time zone is correct not that i can change this as it is current set to network provided values. The time is showing the correct time just 12 hours out, for example phone is now displaying 05:41am instead of PM. The date is also wrong by 6 months thinking its 31st of december this year. I am unable to change these values as it is set to automatic.

    I have tried using manual time settings but found the phone lost 25minutes during the night resulting in me getting up late for work.

    I am not sure what i can do, tried restarting the phone to no avail, any help would be greatly appreciated thanks...

    Advertisement
  2. rosered

    rosered VIP Member VIP Member

    Have you downloaded any apps in the last few days that may have affected the time settings or possibly started using a Task Manager that is knocking out the time/date function or maybe turned off something in the Settings>Applications>Running Applications that has affected the time.

    Your other recourse is to run a software repair via PC Companion or Sony Ericsson Update Service or Factory reset from within the phone. This will wipe your phone tho so make sure you back up everything first... contacts/sms and you will have to reinstall apps afterwards too. If the repair does sort it then I would suggest keeping a close eye on your apps as you install them to see if you can pin down one that is messing with your settings.
  3. gazbaz

    gazbaz New Member

    Hi there,

    I've been having the same problem and nothing I found on the forums worked. So I was fiddling around and found that this did the trick

    1. Switch to wifi so that the phone doesn't access data over the carrier network.
    2. Manually change the date and time back to what it should be.
    3. Switch automatically use network for date and time back on.
    4. Turn wifi off and resync with carrier network. Leave it for a few minutes just to see if it changes back.
    5. Switch phone off and back on and hopefully you'll still have the right date and time.

    After about 10 minutes, mine is still reading the right date and time, so hopefully it will stay that way.

    This happened to me after taking out the battery by the way.

    Good luck

    Gaz
  4. rbruce1314

    rbruce1314 Member

    I too tried everything @gazbaz did - with no success at all; it did show the right time but still gained seceral seconds per day.

    Can I refer the learned gentleman to this thread elsewhere on this forum:
    http://androidforums.com/sony-ericsson-xperia-arc/430665-xperia-arc-clock-time-o2-uk.html

    As a follow-up I have tried all that follows: (posted as a request on the SE forum): Main: Xperia Arc clock on o2, UK

    "Final sequence:
    Whether on auto or not, the phone settled down to give perfect timekeeping for 6 days of the week, then every Saturday night/Sunday morning would gain exactly 35 seconds. Happened 5 weeks in a row.
    So, for other reasons the battery had to come out a few days ago. When put in, late at night, the clock showed no signs of correcting itself before I went to bed. When I woke up the clock had sort of corrected itself in that the time was corrected - but at 2min38s fast - and the calendar/date hadn't reset!!!
    Last shot was a phone reset, since when there has been no Saturday 'surge' but instead a steady gain of about 6-7 sec per day; again its' the same whether auto is on or off."


    So it seems that I am not the only one with this problem after all!!


    I've given up here - I assume it's a fault in the hardware and that the phone will have to get repaired/replaced under warranty - or I will just have to live with it.

Share This Page