New Desire Yesterday - Very Disappointed With Internet


Last Updated:

  1. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    The internet on my new Desire seems incredibly slow - on Wifi or 2G/3G...

    It doesn't really work at all on Wifi (though the signal's excellent) and takes minutes to even start loading a page on mobile internet...

    Can anyone suggest anything to improve this?
     

    Advertisement
  2. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    Just to add - I've just scanned a link to download a file, and it just says
    "Waiting for data connection..."

    Even though the wifi's connected and has a full signal :(


    I disabled the wifi to force it to use the mobile connection and it's started to download...
     
  3. frogger

    frogger Member

    Joined:
    Apr 23, 2010
    Messages:
    22
    Likes Received:
    0
    sounds like you got a problem with the router not the phone. had my desire for a while now and use the wifi with my sky router (netgear) with no problems at all
     
  4. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    I use the wireless with my Nokia E72 and Netbook with no problems at all, so pretty sure it's not that...
     
  5. riverboat2001

    riverboat2001 Well-Known Member

    Joined:
    Apr 29, 2010
    Messages:
    157
    Likes Received:
    10
    I find the wifi superfast, although i have got a 50mb connection
     
  6. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    I've got a 20Meg connection :( lol...
     
  7. ynwa

    ynwa Well-Known Member

    Joined:
    Apr 30, 2010
    Messages:
    134
    Likes Received:
    5
    WiFi is fine for me. 3g is very disappointing though.
     
  8. Pryomancer

    Pryomancer Well-Known Member

    Joined:
    Mar 29, 2010
    Messages:
    673
    Likes Received:
    57
    I've got a 5mb connection and my Desire still zips through websites.
     
  9. dolbydan

    dolbydan Member

    Joined:
    May 1, 2010
    Messages:
    18
    Likes Received:
    2
    Restart your router and phone, solved problem for me.
     
  10. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    Sadly that doesn't solve it for me :(

    I've installed a different browser and that doesn't load pages any quicker :(
     
  11. Its_Red

    Its_Red Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    72
    Likes Received:
    12
    I would suggest trying on several other wifi connections and if it still fails return it as the wifi on is actually very good.
     
  12. Ronaldo

    Ronaldo Active Member

    Joined:
    May 5, 2010
    Messages:
    33
    Likes Received:
    4
    dude the problem is not router or really the phone. this phone does not like routers using DD-WRT firmware and if you are not using that then the firmware on the router is not compatible with the phone, the phone is picky on which router you use and security settings.

    I had a problem too took me a while to realise, i figured it out by using a old netgear router.

    try your phone with a friends wifi (different model router then urs) and it should work fine. i speed tested wifi and i get about 16mb.

    hope it helps
     
  13. stringent

    stringent Well-Known Member

    Joined:
    Apr 30, 2010
    Messages:
    67
    Likes Received:
    4
    Might be worth checking to see if there is a firmware update for your router. Before that though as someone suggested try it on your mates WiFi first.

    My WiFi is fine so is my mobile Internet. Which provider are you with?
     
  14. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    It's been suggested that it could be Juice Defender - I installed it and disabled it until I had a few mins to suss it out...

    There seem to be several people who have had issues with Wifi/APNs with Juice Defender...

    Apparently if you disable it, it disables all Wifi connections! Shocking! lol
     
  15. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    Since uninstalling Juice Defender, my Wifi issues seem to have diminished slightly... So fingers crossed it's resolved now :)

    Thanks Psycho!
     
  16. cupidstunt

    cupidstunt Active Member

    Joined:
    Apr 24, 2010
    Messages:
    28
    Likes Received:
    4
    Have you tried changing the channel on your router? This worked wonders for me.

    I'm sure I've read that certain channels dont work well with the desire.
     
  17. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    That was one of the things I did too, as well as changing the security from WPA to WPA2... My channel was set to 6, think it's 8 now, but not seen any comments about which is best.
     
  18. PawPaw

    PawPaw Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    72
    Likes Received:
    2
    WiFi is good for me but i do find that 3g is rather disappointing at times.
     
  19. gie62001

    gie62001 Well-Known Member

    Joined:
    Aug 2, 2009
    Messages:
    269
    Likes Received:
    25
    what you could try and do is to go to your default internet browser on desire and press menu button.then go to more and settings and untick Mobile View in settings and then try to load web pages.
    for me it had major difference especially with some websites.
    or another thing is that some app is blocking or using your data connection.
    also you could try and do factory reset as maybe something wasn't set up right.
     
  20. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    I think I've got it sorted, but I'll try disabling the Mobile View, thanks :)

    I'm thinking of resetting it anyway as it seems to be quite poor as an actual 'phone'

    It takes about 5 seconds after pressing to dial a contact for it to actually show the Dialling screen :(

    I'll start another topic about that though lol
     
  21. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,419
    Likes Received:
    172
    Rich, see my reply on your Nokia thread ;)
     
  22. richcowell

    richcowell Well-Known Member This Topic's Starter

    Joined:
    May 10, 2010
    Messages:
    93
    Likes Received:
    6
    Have done, and thanked it... Thanks :)

    I'll check that out over the weekend...

    Rick :)
     
  23. nx1977

    nx1977 Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    2,419
    Likes Received:
    172
    I've just had to change my router channel thanks to a load of new BT hubs popping up. They can all fight over ch1-7. I'm now on ch13, and nothing else near me using any nearby channels to interfere with me.

    Noticed the PC is better too, but until the Desire acted up, had no idea I had a channel issue. The N96 must have coped with it well, as had to change channels when I first got the Desire.
     

Share This Page

Loading...