New Email messages not arriving automatically


Last Updated:

  1. parman18

    parman18 New Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    2
    Likes Received:
    0
    When I first got my new DROID a few weeks ago, new email messages arrived and I was notified by a ringtone, and a blinking green light in the upper right corner. Now that has stopped completely. If I want to check for new email messages I have to manually start the email app and manually select refresh for the app to go out and look for new messages (via Yahoo pop mail). What happened? Is there a simple setting somewhere that got switched?
     

    Advertisement
  2. CatsTide

    CatsTide Well-Known Member

    Joined:
    Oct 29, 2009
    Messages:
    752
    Likes Received:
    106
    check your notification settings in email...sometimes they change themselves
     
  3. parman18

    parman18 New Member This Topic's Starter

    Joined:
    Dec 6, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks for the quick reply. I checked the notification settings, and everything looked o.k. I exited the settings, and lo and behold, I received a email "arrived" sound and the green light started blinking. Didn't change a thing. Maybe the DROID just needed a wake up slap, sort of like kicking the tires on a car to get it started!!!!
     
  4. oldgzr

    oldgzr New Member

    Joined:
    Dec 31, 2009
    Messages:
    4
    Likes Received:
    0
    My wife's droid did pretty much the same thing, although we went all out and turned the notification off and then immediately back on. All fixed.
     
  5. bdudek

    bdudek Active Member

    Joined:
    Dec 19, 2009
    Messages:
    26
    Likes Received:
    0
    I'm having the same problem. My email won't update automatically while the Gmail app will. I'm hesitant to use Gmail app because I am not able to load pictures while the other Email app can. I've made sure notifications are on, switched it off, then back on but I'm still not receiving updates. My first droid worked flawlessly in this department while this one doesn't seem to.
     
  6. Zephyrmoon

    Zephyrmoon Member

    Joined:
    Dec 11, 2009
    Messages:
    23
    Likes Received:
    0
    I had the same problem here too.
    I checked all settings, nothing. Changed IMAP settings, nothing.
    Did a battery pull. Bingo.
     
  7. bdudek

    bdudek Active Member

    Joined:
    Dec 19, 2009
    Messages:
    26
    Likes Received:
    0
    Just attempted the battery pull. When the phone started back up, it found new emails and notified me. However, I've sent new emails to test and the email app isn't notifying me of new emails while Gmail does.

    I realize I can work around this by keeping gmail update notifications going while using the email app on my screen, but I'd like a fix.
     
  8. bdudek

    bdudek Active Member

    Joined:
    Dec 19, 2009
    Messages:
    26
    Likes Received:
    0
    I'm starting to suspect that Home++ might be the cause of the problem. Looking further into it.
     
  9. bdudek

    bdudek Active Member

    Joined:
    Dec 19, 2009
    Messages:
    26
    Likes Received:
    0
    It seems that Home++ is the problem. I uninstalled Home++ and the auto updates started working again every 5 minutes with Email app. I since have re-installed Home++, turned off the droid, turned it back on, got email notifications, then immediately got a force close for Home++. After this force close, auto updates do not work. Emailed the developer. Anyone have any other ideas? Or have similar stories?
     
  10. thaprofessor33

    thaprofessor33 Member

    Joined:
    Nov 16, 2009
    Messages:
    16
    Likes Received:
    0
    This happens to me with my corporate email and gmail apps. Whenever I closed the corporate email app with a task killer the gmail app would go back to auto sync. Weird...
     
  11. Inphosys

    Inphosys Well-Known Member

    Joined:
    Dec 12, 2009
    Messages:
    135
    Likes Received:
    11
    For those that are having problems ... Have you installed a Task Killer?

    I use "Advanced Task Killer" and love the app. However, I have added the "Email" app to my list of ignored programs. That way when I click the "KILL selected apps" button, it kills everything except for the Email app. I've noticed now that the Email app is always running in the background my mail is back to syncing on a regular basis as messages arrive.

    Best regards,
    Brad
     
  12. pjavan

    pjavan Member

    Joined:
    Nov 8, 2009
    Messages:
    9
    Likes Received:
    0
    I just wanted to post that I too have this issue. Its quite annoying as I use this for corporate e-mail sync. I don't even realize I have mail until something happens that I have to reboot my phone. When I reboot, all of a sudden I have like 10 emails from Exchange. I have installed GDE home and now wondering if that may be the cause. I don't remember having the issue at first, but can't confirm whether it started when GDE was installed. IMO this is a big issue :eek::eek::eek:
     
  13. Inphosys

    Inphosys Well-Known Member

    Joined:
    Dec 12, 2009
    Messages:
    135
    Likes Received:
    11
    pjavan -

    You can open Email app, then hit the Menu button at the bottom of your screen and hit Refresh. This will cause it to check in with your Exchange ActiveSync Server.

    I too use my Droid for Exchange. I was having a problem at first because of Advanced Task Killer (ATK). I would click the "KILL Selected Apps" button and the Email app was on the list of things to kill. Only after opening the Email app again would it go out and check my server. Now that I've added the Email app to my ignore list it updates just fine.

    While I'm at it, I might as well mention that I added the Corporate Calendar app and CalWidget to my ignore list as well. This keeps my calendar up to date when I change something in Outlook on my desktop PC.

    Hope this helps!
     
    BabyRN likes this.
  14. almahix

    almahix Well-Known Member

    Joined:
    Dec 12, 2009
    Messages:
    280
    Likes Received:
    37
    I too have had issues with email not updating. I poll 3 pop3 accounts and yahoo in addition to gmail. Often I will need to kill the email app with ATK or power off then power on the phone to restore polling. It is very frustrating. I recently cleared all the accounts in the email app and recreated them in the k9 email app and since then it hasn't stopped polling, but I will keep an eye on it.

    Not running home+ and I still had the issue. I also had the antivirus program mentioned here in another thread but it is now uninstalled. I hope 2.1 addresses email issues. I've decided to wait for Vz to push it rather then root...I'm just not that intrepid!!!
     
  15. KeithG

    KeithG Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    103
    Likes Received:
    3
    Gmail relies on Google talk for push notifications. If you kill the gtalk service you wont receive the message to get your new mail.

    Its also possible that gtalk failed to reconnect enough that it wasnt trying anymore. You can open the talk application to force the sign in. If you see the "signing in" screen that's why push wasn't working.

    Once your signed in try sending yourself a message to your gmail account.
     
  16. turbodog

    turbodog New Member

    Joined:
    Sep 13, 2010
    Messages:
    1
    Likes Received:
    0
    I was not getting received emails in my gmail account unless I went into my gmail app went to menu and hit refresh.

    I tried several of the suggestions on here and nothing worked until I did this:
    gmail> menu> accounts> (select account)> menu> account settings> check Auto Sync.

    after that I sent a few test messages to myself and they arrived with proper notification very efficiently. I was surprised i didn't figure this out earlier. Let me know if this works for everyone else.
     

Share This Page

Loading...