New G1 owner - Rooting helpGeneral


Last Updated:

  1. siboyslim

    siboyslim New Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    2
    Likes Received:
    0
    Hi all

    Just got a G1 from ebay after my T-Mobile Pulse died after just 4 months!

    I want to root it to 2.1 but have some questions;

    I think it's running Dev Phone 1 and when I hold the Home key while booting I get the 'Android system recovery utility Build JFV1.43.

    I take it my phone is already rooted, but can anyone talk me through how to get 2.1? Read a couple of guides and it scared the hell out of me lol!

    Thanks

    si
     

    Advertisement
  2. RozzaC

    RozzaC Well-Known Member

    Joined:
    Feb 25, 2009
    Messages:
    647
    Likes Received:
    10
    Well, first of all, you'd need to know which 2.1 ROM you actually want to install onto your G1.

    I've got CyanogenMod's 5.0.7 ROM installed on my G1 which is a 2.1-based ROM, and probably the ROM most people, if not everybody, would recommend to you to use.

    The wiki for installation is probably far better than anything I could write up.

    It seems like you're rooted already, so you won't need instructions on how to root your G1.

    But the first thing I'd recommend you do is to update your recovery utility to something more up to date.

    It's all explained very well in the wiki:

    DangerSPL and CM 5 for Dream - CyanogenMod Wiki

    Use that link and try to follow through the instructions...if you're still confused or worried, come back and we'll see what we can do (and by "we", I mean me! :p )
     
  3. DarkTLRrider

    DarkTLRrider Well-Known Member

    Joined:
    Nov 29, 2008
    Messages:
    227
    Likes Received:
    14
    Agreed. What you have for a recovery agent is an old Jesus Freak version (JFV 1.43). The one I have found the easiest to use is Amon recovery agent. There is a link on the wiki for it. This would be the first step. Next update the radio as per the instructions. Then do DangerSPL. This makes the system partition large enough to run 2.1. Do the radio first or you will brick it. Its not that scary just don't install DangerSPL without the radio, simple. Then get 5.0.7 and the gapps (google apps) file. You can use Amon ra to wipe all the caches and partition the sd card, create the ext and upgrade to ext 3. Can be done from where you are in minutes however take your time and read the instructions. After the first time you will realize how easy it is.
     
  4. siboyslim

    siboyslim New Member This Topic's Starter

    Joined:
    Jun 8, 2010
    Messages:
    2
    Likes Received:
    0
    Thanks for your help guys, went through the wiki and I now have 2.1 running, although I don't appear to have partioned my card? Strange.

    Si
     
  5. RozzaC

    RozzaC Well-Known Member

    Joined:
    Feb 25, 2009
    Messages:
    647
    Likes Received:
    10
    Did you follow the instructions to partition the SD Card?

    There's a command you canuse in the terminal to check if you have any partitions on your card..

    Apps2SD - CyanogenMod Wiki

    That should tell you everything you need about partitioning you SD card for Apps2SD.

    If you have Amon_RA Recovery installed...it's as easy as selecting the option in the recovery menu
     

Share This Page

Loading...