New Phone

Discussion in 'Orange' started by htcdesirefan, Apr 14, 2012.

  1. htcdesirefan

    htcdesirefan Member
    15

    May 9, 2010
    18
    0
    15
    Hi,

    I got a new phone delivered yesterday from Carphone warehouse on an orange tariff. Put sim in and was told it would take 24 hrs to activate. Its been 24 hrs and although the phone works i cant txt or call and no one can call or txt me.

    Ive called Orange but they cant help because i got phone and contract through carphone warehouse. Carphone warehouse have told me to take sim out and leave phone off for while and put back which ive tried and said they have re sent whatever they needed to resend. Im not very technical...not sure if im missing something or if it is a problem their end.

    Can anyone help?? Thankyou
     

    Advertisement

  2. alpha0990

    alpha0990 Well-Known Member
    78

    Nov 11, 2011
    550
    62
    78
    Those orange idiots might have put a security block in place specially if you used a credit or debit card that doesn't match your address. If there's still time, it would be a good idea to cancel the contract.
     
  3. IOWA

    IOWA Mr. Logic Pants
    VIP Member
    323

    Dec 2, 2009
    8,852
    2,367
    323
    Network Admin
    Chicago
    Thread moved to the Orange forum to try and get you some carrier specific advice. Let me know if you need anything else, and welcome to AndroidForums. :)
     
  4. dnapro

    dnapro Well-Known Member
    28

    Hi htcdesirefan

    Sorry got here a little late to spot this one, has anything been resolved as yet? I do hope so...
     
  5. Ian Harding

    Ian Harding Member
    15

    Mar 25, 2012
    21
    0
    15
    I can't offer a solution, although hopefully you've got it sorted now.

    To add my experience in case it helps anyone: I recently upgraded to a new Orange contract and handset through CPW. The new SIM wouldn't connect to a network when first tried, so I worked around it by putting the SIM from my old handset in the new one - which worked fine.
    After 3-4 days suddenly I had no service, so put the new SIM in and it was up and running.
    Seems like the activation delay is normal, and must be very frustrating for anyone who doesn't have an existing SIM to use as an interim measure.
    Ian
     

Share This Page

Loading...