1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

New photos "damaged, corrupted, or is too large".Support


  1. Speedbark

    Speedbark New Member

    I recently moved my SD card from a Motorola X to a Motorola X2. New pictures and video taken are getting an error message stating, "Wndows Photo Viewer can't open this picture because the file appears to be damaged, corrupted, or is too large", when opening either after being downloaded or opened directly from the SD card. The images and video taken are fine when view on the devise itself; sharp and clear. I've taken the files to other computers with the same result (XP and Windows7). I've also attempted to open the pictures with other programs: Photoshop and GIMP2. All my pictures from my old phone download and display just fine on the PC.

    How can I get my pictures off my phone? Why are they getting this error? HELP!

    Advertisement
    :
  2. Scur

    Scur Well-Known Member

    I don't know, new to me. Have you just viewed them in your gallery and shared them with something like Google Drive or whatever is most handy for you?
  3. coolpoete

    coolpoete Well-Known Member

    There could be an issue with your SD card. Backing up to the cloud as Scur suggested would be a great idea, followed by reformatting the card and seeing if that works.

    If you don't have cloud service I would try using a file explorer on the phone and copy the pictures from the SD card to the phone itself. You should then be able to plug your phone in, navigate to the folder on the phone and try to copy the files from there. If that works I would then back up anything else you want from the SD card to your PC and reformat your SD card on your PC. Then try copying the files back to your card and see if the phone or PC will read them now.
  4. Speedbark

    Speedbark New Member

    Thanks for the comments. Other forums (not the exact situation, but close) suggested issues with the SD card. I did not believe it to be the case as nothing else other than the photos are being affected.

    I reformatted the SD card and put back the backed up photos. Bad photos off, bad photos on. And again, newly captured images have the same issue. There must be something about how it is taking and storing the pics. I've never had issues with jpg's before. I even turned off the auto location tagging. No tags at all. I even then turned the resolution down to 1 mp. No change. I cannot see any other settings I can fiddle with.

    I have found a work-around. Not a good one however. I can text myself pics and save them to the SD card. These jpg's are fine when copied to the PC, but with a major loss of resolution. This is not something I can abide by even if I found an editing app that could re-save the jpg's, that would be a pain in the butt to do every time.

    Any other ideas. Bad phone?
    -----
    Well, that gave me the idea to try a new camera app off the Market to see if the software made difference. Saddly, the same result. I am a complete loss.
  5. coolpoete

    coolpoete Well-Known Member

    I'm not sure either. For the sake of experimenting try removing the card altogether, taking a few pictures, then try to access the pictures by connecting the phone to the PC and see what happens. Then you can fully rule out whether it's the phone or the card.
  6. Speedbark

    Speedbark New Member

    Yes, ealier, I did switch the storage location to the onboard memory. I did as you suggested, however, and removed the SD card altogether and took a pic. Same as before. The image cannot be displayed on the PC when the phone is plugged into it. Same if copied to the PC. Fustrating.
  7. coolpoete

    coolpoete Well-Known Member

    Is this on the x or x2? Have there been any modifications made on the phone? Is it in stock?
  8. Scur

    Scur Well-Known Member

    Have you made a Picasso account and uploaded/synced them to there?
  9. Speedbark

    Speedbark New Member

    Milestone X2.

    Yes, I tried Picasa. Same Result.

    Thanks for the ideas. I contacted Motorola directly. They were not much help, apart from confirming my second to last resort (the last being turning it in on its warrenty). I hit the reset to factory button.

    THIS DID WORK. However, I do NOT think it was the solution. As I was reloading apps and adjusting the settings to my preference, I came across the encryption options. I remembered that on my previous device, I did not set any encryption on the internal or SD card, but when I got the new X2 I DID set to encrypt internal and SD. Although I have not tested the theory (and do not really want to), this could be the smoking gun. Having encryption for the internal and SD card on, I suspect was not allowing an external device (PC in this case) to view data, as it is supposed to. Now, how one deals with data on the phone device and gets it off is another subject. Does one have to decrypt the entire SD card to do so??

    If any of you folks come across this or this happens to you, did you turn on encryption? If so, this may be a reason you cannot get your data off your phone. Just a theory at this point, but worth exploring before you reset your phone.

    I'd like to hear if someone tests this.
    coolpoete likes this.
  10. coolpoete

    coolpoete Well-Known Member

    Glad you got it fixed!
    (I don't use encryption as I have no use for it.)
  11. splifmyster

    splifmyster Well-Known Member

    Hey I had the same thing happen to me with my other phone but when I reflashed the rom and did a factor wipe it fixed it hope this helped
  12. Pilot1095

    Pilot1095 New Member

    When you encrypt your phone or SD card, and then try to transfer photos taken after encrypting, viewers on your PC won't be able to read them.
    Also, once encrypted, you would have to transfer/email them to yourself at an email address and then download them to your PC to view them.
  13. pascuzzo

    pascuzzo New Member

    Yes, this is most def an encryption issue. If you turn off the encryption on your android, any photos taken from that point forward will transfer and open easily. However, any photos that were previously encrypted, will transfer but will show as being corrupted.
Loading...

Share This Page