New problem...


Last Updated:

  1. Shelbster

    Shelbster Guest This Topic's Starter

    For the past two nights, I have left my phone charging all night. Both mornings I attempted to use the web browser after unplugging the phone. Every web site I went to gave me a message that the site was down or I was not connected.

    I checked my phone and it showed that I was connected to my wifi network. However, there was no 3G indicator at the top of my screen. It showed the wireless signal bar directly next to the call indicator bar. I got up and switched rooms in the house, and saw the 3G indicator come up next to the wireless indicator. At that point I was able to get on the internet. (Althought the 3G indicator was present, the phone did not appear to be using 3G, as the 3G arrows were not lighting up)

    I am really confused about a couple things here. First, why was my 3G indicator missing when I first woke up and unplugged the phone? Second, why was my phone unable to connect to the internet via wifi without the 3G indicator present?

    I am really wondering if my phone is using 3G for internet even when there is a wifi connection. This would seem to cause more battery drain in my phone. Is anyone else having a similar problem? Any thoughts?

    p.s. juice defender seems to show periods where my phone is using 3G and wifi at the same time.
     

    Advertisement
  2. kmthomas2009

    kmthomas2009 Member

    Joined:
    Jul 15, 2010
    Messages:
    13
    Likes Received:
    0
    My phone does that 2...When it shows the 3g indicator that means that wat ur using...even tho ur wifi bars are up there u still have a weak or no signal...if it happens to me i restart my internet box or connect to my neighbors internet(lol) and it works fine.
     
  3. Mnemic

    Mnemic Member

    Joined:
    Jul 20, 2010
    Messages:
    19
    Likes Received:
    3
    When the phone sleeps, I believe by Default it Also Sleeps the WiFi connection, so when you charge it up, and screen goes off, it also turns WiFi Off.
    if you have weak 3G signal and try to use it before it re-acquires WiFi, you'll prob get the Unable to connect message.

    To Check... Menu -> Settings -> Wireless & Network -> Wifi Settings -> Menu -> Wi-Fi Sleep Policy -> Never.

    Theres a few threads about Never, and I changed to it and have had no decrease in battery life, but I have seen a decrease in 3G usage, since my phone doesn't use 3g to check mail when its sleeping now.

    HTH.

    -Paul
     
  4. MrTony

    MrTony Banned

    Joined:
    Jul 16, 2010
    Messages:
    260
    Likes Received:
    36
    By default, the Wi-Fi turns off when the phone sleeps. You can change this behavior as Mnemic described.
    Also by default, Juice Defender turns off 3G when the phone sleeps, only turning it on for 1 minute every 15 minutes to feed apps that need a data connection. It usually takes several seconds to a minute for my 3G to turn back on when I wake the phone up.
     
  5. Shelbster

    Shelbster Guest This Topic's Starter

    Thanks for the suggestion. I do have my wifi set to never sleep though.

    Can anyone confirm that the phone is using 3G if the wifi bars and 3G indicator is showing?
     
  6. ScaGin

    ScaGin Well-Known Member

    Joined:
    Jul 19, 2010
    Messages:
    47
    Likes Received:
    1
    I use 3G Watchdog. It shows 0% usage of 3G when I am home for the
    weekend using Wifi.
     
  7. Shelbster

    Shelbster Guest This Topic's Starter

    Does your status bar at the top of your screen show the 3G icon when you are using wifi? Meaning, is the 3G indicator there, but not the arrows are not lighting up, or are you just seeing the wifi indicator?
     

Share This Page

Loading...