New ROM of Android 2.2 (Froyo) for Liquid E


  1. vovidaisu

    vovidaisu Member

    The new ROM of Android 2.2 (Froyo) for Liquid S100 (A1 & A1E) for you. If you know how to flash the ROM with the Acer download tool, it is easy to flash it.

    1) Download the Acer download tool from this link: Free File Hosting, Online Storage &amp File Upload with FileServe
    2) Download BIN file of Froyo version from this link : Free File Hosting, Online Storage &amp File Upload with FileServe

    After finishing the downloads,

    1)pls unzip both of them
    2) Run acer_DownloadTool.exe
    3) Select the correct .BIN file
    4) Connect Liquid S100 via USB
    5) Click "Start" to start flashing the Froyo ROM
    6) Don't disconnect USB cable until the flash finishs and you see the completed message

    Good luck! Enjoy your Liquid with Froyo

    Advertisement
    :
    happycat501 likes this.
  2. vovidaisu

    vovidaisu Member

    Another solution :

    If you have a Liquid E, you can use the below method to flash Liquid E with SD card . It is more convenient than using Acer download tool

    You can download Froyo ROM of Liquid E from below links

    1) Download ROM of Liquid E (Froyo) : Free File Hosting, Online Storage &amp File Upload with FileServe
    2) How to flash ROM with SD card : Free File Hosting, Online Storage &amp File Upload with FileServe

    * Unzip the downloaded file and you will get 02 items: update.zip and folder image
    * Copy both of them to SD card
    * Power off your Liquid E
    * Press and hold <Volume down> + <Camera> and press <Power> until it vibrates 3 times. Then release all.

    It is used only for Liquid E not Liquid A1.
  3. Wallbanger69

    Wallbanger69 Member

    Hi

    Does the phone need to be rooted to install this update?

    Also- what benefits are there to 2.2. Are there any serious drawbacks?

    Thanx
  4. clockwork58

    clockwork58 Well-Known Member

    I'm starting to think I should of got this phone.
    My X10 just got upgraded to 2.1 this weekend. Thanks Sony.

    Now you get an official Acer release of 2.2 with Flash support.

    *sigh*
  5. cocopuffz

    cocopuffz New Member

    Just installed the 2.2 update via the SDcard Method. Works perfectly.

    *Question 1* I used to be Rooted on 2.1... I used the Universal Root app. Doens't work anymore. Is there another way to root this puppy?

    *Question 2* I can't update anything in the Android Market now. Appbrain won't update the apps either although I can still sync. Has anyone else experienced this? Any solutions?
  6. cocopuffz

    cocopuffz New Member

    Supposedly we have the option of wifi tether now, built in as opposed to before where you had to have a specific kernel module enabled. Apps to SD works now. Angry birds, Opera Mini and Evernote seem to install onto the SD. Cleared some space for me.

    The overall the handset seems a little quicker. Apps like Handsent which used to lag a bit on 2.1 now pop up instantly with all my messages ready to go. Scrolling through messages is much faster now. I used to blame Handsent for the slowness. I probably owe them a new star rating lol.


    I still haven't been able to update any apps in the Market, however... it now detects apps that disappears a while back. It keeps asking to do a manual update... hope there's a fix for that. Everything still works though...
  7. skittleys

    skittleys Member

    Does this mean the official 2.2 release (the one that was supposed to come out in October) will be available soon?!?!
  8. gwilo

    gwilo Well-Known Member

    It is the official release go to acer.ca support area and it is there under Froyo
  9. Shamino

    Shamino New Member

    I tried updating my Liquid E to Froyo using the instructions included in the downloaded file. But I get an assertion fail and the installation aborts.

    I currently have the following build number installed: Acer_LiquidE_1.100.79_PA_FIDO

    APN Version: 1.96-3

    Product SKU: PA-FIDO

    Device info version: 2.1

    Here is the recovery log:


    Starting recovery on Wed Nov 17 04:27:45 2010
    framebuffer: fd 4 (480 x 800)
    Build : malez-liquid-0.6
    I:Got arguments from boot message
    I:Set boot command "boot-recovery"
    Command: "recovery" "--update_package=SDCARD:update.zip"

    ro.secure=0
    ro.allow.mock.location=0
    ro.debuggable=0
    persist.service.adb.enable=1
    ro.sf.lcd_density=240
    ro.modversion=malez-liquid-0.6
    ro.factorytest=0
    ro.serialno=recovery
    ro.bootmode=unknown
    ro.baseband=A1-04.01.03
    ro.carrier=unknown
    ro.bootloader=1.03.00
    ro.hardware=salsa
    ro.revision=0
    ro.emmc=0
    ro.hw_version=6
    ro.amss_version=A1-04.01.03
    init.svc.busybox=restarting
    init.svc.fstabGen=restarting
    init.svc.extfsck=stopped
    init.svc.msfsck=stopped
    init.svc.recovery=running
    init.svc.adbd=running

    Finding update package...
    I:Update location: SDCARD:update.zip
    Opening update package...
    I:Update file path: /sdcard/update.zip
    I:1 key(s) loaded from /res/keys
    Verifying update package...
    I:Verified META-INF/CERT.RSA
    I:Verified META-INF/MANIFEST.MF
    I:Verified update_restore.zip
    I:Verified boot.img
    I:Verified META-INF/com/google/android/update-binary
    I:Verified image/appsboot.mbn
    I:Verified recovery/recovery-from-boot.p
    I:Verified image/dsp1.mbn
    I:Verified META-INF/com/google/android/updater-script
    I:Verified image/osbl.mbn
    I:Verified image/qcdlckie.mbn
    I:Verified META-INF/com/google/android/update-script
    I:Verified image/amss.mbn
    I:Verified image/dbl.mbn
    I:Verified update.zip
    I:Verified image/fsbl.mbn
    I:Verified recovery/etc/install-recovery.sh
    I:Verified check_prereq
    Installing update...
    script aborted: assert failed: getprop("ro.build.display.id") == "Acer_LiquidE_1.100.79_PA_FIDO"
    I:read: ui_print assert failed: getprop("ro.build.display.id") == "Acer_LiquidE_1.100.79assert failed: getprop("ro.build.display.id") == "Acer_LiquidE_1.100.79I:read: _PA_FIDO"
    E:unknown command [_PA_FIDO"]
    I:read: ui_print

    E:Error in /sdcard/update.zip
    (Status 7)
    Installation aborted.
  10. vovidaisu

    vovidaisu Member

    1) You can use Download tool to upgrade to Froyo via USB connection and your Liquid E will be flashed easily. It is easy and convenient for new Android user.
    2) What benefits with Froyo?
    a) Your Liquid E runs faster and smoothly. You will see the outstanding difference after upgrading to Froyo
    b) Flash video can run smoothly with Froyo in your Liquid E.
    3) Your phone becomes portable hotspot & Tethering. Its functions are same as a Wifi router + ADSL when you use notebook to access Internet
    4) You can enjoy many new applications/games which only run in Froyo
    5) Many thinngs have been waiting for you to discover/enjoy...
    dierna likes this.
  11. vovidaisu

    vovidaisu Member

    1) Your ROM ver is dedicated to PA_FIDO so when you use a universal version. Updating is failed.
    2) Pls use the upgrade process with download tool & BIN file. (2nd method)
  12. vovidaisu

    vovidaisu Member

    1) Your Universal Root application hasn't support Android 2.2 (Froyo) so it won't work with Froyo. Pls source another root app which supports Froyo
    2) You can update any apps in Market if they support Android 2.2. Same as for AppBrain. Some apps in either Market or AppBrain haven't had the new versions supported by Froyo. For them, pls wait for their upgrades with Froyo
  13. johnnycarrson

    johnnycarrson Member

    I updated my phone with the official rogers 2.2 release from acer. I used the SD card method without any problems. Android 2.2 seems to run a lot faster on the phone and the new features are great.

    I was wondering if anyone has found a way to root the phone with the official rogers 2.2 release? I would like to take advantage of some of the 2.2 only apps that require a rooted phone but am not sure how to go about doing it....

    Thanks in advance
  14. skittleys

    skittleys Member

    Where did you find the rogers release?!?! It certainly doesn't come up with the "Update Notifier"!

    Edit: Nevermind. Wish Rogers would actually release it!
  15. Wallbanger69

    Wallbanger69 Member

    The Rogers and Fido versions are available at the acer.ca site. Look in the Service and Support sections.

    I presume that these updates are "officially" supported.:)
    dierna likes this.
  16. Shamino

    Shamino New Member

    I am not using a universal version though - it is the PA_FIDO version I am using and my phone currently has a PA_FIDO build on it.

    I suspect that my malez recovery image image is bad either due to bad SD (the SD I'm using is quite old) or bad download. The reason I suspect this is that, the assert command is the first line in the update-script, but from the log, it does not seem to be parsing the script properly - It thinks "_PA_FIDO]" is a command.

    I shall try again with another card and download and see what happens.
  17. Miller57

    Miller57 Member

    Ok i tryed to put android 2.2 into my phone. And by doing that i downloaded the update from the Acer site
    I opened up the tutorial of how to do it, and i did everything is asks for and stuff and when i got to the part of hold volume down + camera button, then press power button and itll vibrate 3 times... it did, but then it said the light would flash up and stuff and it didnt.. so i tryed to restart and turn my phone back on, and now it wont... it loads up the android thing.. then randoms colours appear... then it repeats it over and over.. Please help
  18. dierna

    dierna Well-Known Member

    w00t! It worked!
  19. dierna

    dierna Well-Known Member

    Same here, but be patient. It took mine around ten minutes to finish doing its thing. The LED never did come on, but the update worked.
  20. vootabangee

    vootabangee New Member

    recently upgraded to 2.2 on my liquid e but now my bluetooth won't turn on... any suggestions on how to fix this?
  21. Miller57

    Miller57 Member


    Yea its been like this for 2 days, and now when ever i turn it on, it shows some messed up colours, then stays on the "Acer" "android" screen with the little green guys
  22. corypi

    corypi Well-Known Member

    So updated fine but having a issue with the move to sd feature when I do this it renders the app usless and I can't find then in the dock bar and all shortcuts say the apps have been uninstalled ... help please... sorry if I shoulda started a new thread
  23. gwilo

    gwilo Well-Known Member

    Did you 'move' the app to the SD card or did you install the app on the SD card?
  24. corypi

    corypi Well-Known Member

    i hit move to sd and then it uninstalled it but then i found out i had to goto the market and reinstall... witch i found dumb so i forced sd to ll apps through adb with setInstallLocation 2 and it works perfectly
  25. flirtvirus

    flirtvirus Active Member

    Saw the 2.2 Froyo on Acer.co.NZ...available for E but.....only for Ram of 512mb..
    How about A1 ?? Any Froyo avail from Acer site..??

    Currently running on rooted 2.2...fine but no chinese write support. : (
Loading...

Share This Page