*New Root Method that works with the new SDCARD update from ZTE

Last Updated:

  1. druble81

    druble81 Member

    ***This is a SUPERUSER root , NOT SuperSU!!!***

    OK, many of you already know that ZTE has released an update for our phone. We also know that it breaks root. The current methods we have for root did not work for me to root the phone after the update. I have found a method that works on our phone after it has been updated with the SDCARD update from ZTE. I cant give the exact instructions because I am already rooted and I don't want to mess with reverting my phone back to stock but I will give enough instructions that you should be able to root successfully. If someone wants to post the detailed exact instructions I will update this post to contain those instructions with credit to whomever posts them. I am assuming this will probably work on the phone before updating as well but I am not sure.


    1. Download and install SRSRoot from SRSRoot One Click Root for Android (SuperUser)
    2. Connect your phone to USB and ensure that USB Debugging is turned on.
    3. click the Root Device (SmartRoot) button.
    4. Pay very close attention to what is going on your screen and on the phone. When it says rebooting your phone for the first time, be prepared. You must hold down on the volume up key to boot into FTM mode.
    5. Click OK in the program.
    6. Let the phone reboot normally on the 2nd reboot.
    7. My phone failed to root on the first method.
    8. It will reboot the phone again using a different method. Be sure to hold down on volume up for the 1st reboot so you reboot into FTM mode.
    9. It will reboot your phone again. Let it reboot normally.
    10. It should now copy some files and change permissions and remount some folders.
    11. Phone will reboot again. let it reboot normally.
    12. You should now be rooted.

    ***So basically the key to rooting successfully is that you hold down on volume up on each 1st reboot attempt to boot to FTM and then let it boot normally if it is the 2nd or 3rd reboot for the current exploit it tries. Mine was successful after the 2nd exploit it ran so I only had to boot to FTM Twice. The total process took me about 3-4 minutes. If someone wants to help with more detailed instructions I am sure a lot of less experienced Android users could benefit from them.

    rcolitz likes this.
  2. jimsmith80

    jimsmith80 Well-Known Member

    What update?
  3. redjama

    redjama Guides Guide

    I was wondering the same thing
  4. jimsmith80

    jimsmith80 Well-Known Member

    Found it on zte's web site. I'm downloading now
  5. jimsmith80

    jimsmith80 Well-Known Member

    Its stock B09
  6. redjama

    redjama Guides Guide

    Not JB though?!?
  7. jimsmith80

    jimsmith80 Well-Known Member

    Nope. ICS 4.0.4. Same as what came with the phone. Nice to have a copy from the manufacture
  8. druble81

    druble81 Member

    I'm not sure this is the 'Factory' software. It has made at least a few improvements to my phone by loading the update. I get much better battery life then I was getting before. I get far less stutters / slowdowns. It seems that whatever they have done has increased the stability and performance. It's not a dramatic change but I notice the difference. The battery life however is a big improvement at least for myself. I could drain my battery dry by mid afternoon and now it last me all day on a charge and I use my phone and internet a lot.
  9. donjuro

    donjuro Well-Known Member Developer

    And if it was "factory" why wouldn't we be able to root with the last method? I have yet to try it and plan to soon, I need to find time out of my new job to flash my phone with the new firmware, and to find out what the last version of dsf worked so I can compare performance between kernels. Do you think the improvements are kernel modifications? Or firmware updates? Or os modifications?
  10. thagheist3

    thagheist3 Active Member

    Unrooted my phone to try the update along with this and now phone just boots to android logo :3
  11. bcrichster

    bcrichster Well-Known Member

    Next time try the ota update root keeper APKs or the temp unroot built into SuperUser
  12. thagheist3

    thagheist3 Active Member

    Going to retry this method and a few others I want my custom Rom back :p so much bloat lol
  13. Robertech

    Robertech Well-Known Member

    Someone wanna upload a rom with the update installed? I cannot get the pos to install with cwm no matter how I pack it or tweak the updater script. I keep getting "status 0" and I'm getting soo angry ...
  14. GoatTheHero

    GoatTheHero Well-Known Member

    Use the stock recovery to install the update.
  15. Robertech

    Robertech Well-Known Member

    Got it, thanks. Any way to root from the phone away from PC?
  16. AMOCO

    AMOCO The Computer Dude Guide

    Well this worked for me.
    1)I uninstalled the CWM with the stock recovery.
    2)Uninstalled the SuperSU through the app.
    3)Installed the update from ZTE website.
    4)Used the method in this post to root,Worked fine.
    5)Reinstalled CWM.
    6)Reinstalled a backup I had.
    7)Merged SuperSU to Superuser.
    8)Updated my applications in google play store.

    Easy to do.
  17. fryguy2

    fryguy2 Well-Known Member

    Has anyone tried Framaroot App to root the phone?


    I used this on a buddy that had an Alcatel, and worked like a charm. Start App and rooted phone.

  18. Downgraded286

    Downgraded286 Active Member

    Hey guys!

    Root went smoother than that for me (4.1.2 JB here).
    I simply hit the smartroot button, exploit menu came up on my phone, Aragorn failed but Gandalf was there so I tried that one. Hit okay, the phone sat there for a minute, and it came up and said success. Rebooted the phone and Superuser was there.
  19. SuperR

    SuperR Well-Known Member Developer

    FYI, this device came with B07 or B09 and was updated to B13 so using this "update" is actually a downgrade. B09 might work better than B13, that I cannot say since I don't own one of these.
  20. Downgraded286

    Downgraded286 Active Member

    I didn't install any update, I just found this root method because others I found weren't working. Maybe that's why my installation went differently from some others.

    This is stock 4.1.2 JB I installed it on... so I'm not sure what you would call that. I don't really understand B07, B09, B13...
  21. AMOCO

    AMOCO The Computer Dude Guide

    These are update codes,My old Force came with B09.Them just in the last year they (Boost)put out a new update B13.But this was all on ICS.
  22. coffinsupply

    coffinsupply Member

    links are dead anyway

Share This Page