New Samsung Galaxy S i9000 are unrootable


Thread Status:
Not open for further replies.
  1. zopper

    zopper Well-Known Member

    Dear all,

    I have a new SGS with the latest firmware that came pre-installed. The recovery menu and download menus are disabled.

    I installed the One Click Lag fix to see if this would give the device root, but all it really does is copy the update.zip onto the SD card. Then it instructs the user to reboot and enter recovery using the key sequence. Since this is impossible on the new SGS versions, I have conclused that rooting the 'phone is impossible.



    My SGS will go onto Ebay because I choose the SGS for these reasons:
    Great hardware spec and wide screen
    Good chance of loading non-standard kernels onto it.

    Of course, there will be a littel while afore I put it onto ebay so I can happy to test any other theories people can offer, so long as there is no danger of bricking the device otherwise I won't even be able to sell it on ebay.
    Best regards.

    Advertisement
  2. NZtechfreak

    NZtechfreak Well-Known Member

    Take a look at XDA, yours probably has the new recovery on it, you can change it to the old one for Rooting.
  3. zopper

    zopper Well-Known Member

    Chicken and egg situation.
    How can one install a new 'recovery image', when the recovery menu is inaccessible?
  4. urine_luck

    urine_luck New Member

    i had the exact same problem as you........with a bit of research i found a work around.

    you need to use the adb shell to enter recovery mode and use a fix to enable your phone to use the three button trick.

    if i find the link ill post it back here. but trust me if u research u will find a work around. i just finished installing froyo.
  5. zopper

    zopper Well-Known Member

    I hope you do. I have asked on xda-dev but have had no luck, yet.
  6. chrisjackson1985

    chrisjackson1985 Well-Known Member

    Mine is the same, disabled. However, I rooted my device today and applied the lagfix.

    You need to, install the lagfix app from the market and click root your device, this will place the update.zip onto your sdcard then tell you to reboot into recovery mode to apply.

    To enter recovery mode, enable debugging on your device and download the xda one-click root tool, and click root 2.1, this will put you into recovery mode on your device. (you do all this while its plugged into your pc, the tool is also for your pc, its not an app, just google for it, xda one click root for samsung galaxy s)

    Any trouble, ask.

    But my device has the 3 button recovery mode disabled aswell, but I did it today the way I've just mentioned.
    chrisully and Ih4teKies like this.
  7. zopper

    zopper Well-Known Member

    The only thing I have found is this, but it does not tell me how to do it:
    One-Click Root/Unroot for Most Galaxy Devices | xda-developers

    I have found stuff for the N1, but this is not the GSG.

    Surely, when you did this yourself, you kept the URLs that you used. Please would you post those, and if you can remember (you did it today so it ought to be fresh in your mind) would you jot it down in a post.
  8. zopper

    zopper Well-Known Member

    I have found the URL:
    Release: 3-button combo fix for any firmware version - xda-developers

    However I cannot use it because the fix may well brick the 'phone depending on how Samsung have done this:
    Just have to root now.
  9. zopper

    zopper Well-Known Member

    I have an idea: Could I run the One Click Lag Fix, which'll copy the update.zip onto the internal SD.


    Then:
    1. Go to settings -> Applications -> Development -> Enable USB Debugging.
    2. Start a new command prompt and type "adb reboot recovery"
    3. Once in recovery mode, unplug the phone from the computer.
    4. Use the volume button to navigate downwards, and select "apply sdcard:update.zip".
    Press home key to execute.


    This should allow me to root the 'phone, and then check whether Samsung screwed the PBL or not. Will thus method work?
  10. zopper

    zopper Well-Known Member

    OK. Root applied. Phew.
  11. Majjjjo

    Majjjjo New Member

    Hello Zopper.

    You are lucky man. I am very close to colaps. Tried everything, to spend about 3 whole night with browsing..., neither one metohod is works. My Samsung Glaxy 9000s is just week old, and assume there is similar problem than you did.

    Please hlep me to root phone. Three button combination doesnt work, adb reboot doesnt work, one click button doesnt work. It drives me to mad.

    Many thanks in aadvnace
    Majjjjo
  12. snapper.fishes

    snapper.fishes Well-Known Member

    Ah yes. Clockwork mod recovery does boot your phone into recovery mode if you have an update.zip file in your internal SD card. Haven't thought of that before. Well, guess it is useful for at least one thing.
  13. chrisjackson1985

    chrisjackson1985 Well-Known Member

    Install rom manager and install the clockwork mod within that app, and reboot into recovery also from within that app.

    you can also plug it into the pc, and use the pc tool for xda, one click samsung galaxy s root tool, and root and enter recovery that way.
  14. chrisully

    chrisully Member

    will this work on a desire?
  15. snapper.fishes

    snapper.fishes Well-Known Member

    You might want to ask this in the Desire forum instead.
Thread Status:
Not open for further replies.

Share This Page