[NEW SKOOL] Install and Use xRecovery


Last Updated: 2012-05-13 18:53:55
  1. gabeyong

    gabeyong Well-Known Member

    Hi,

    This is a "new skool" method of installing xRecovery to Xperia X8

    DISCLAIMER: Please use the info below at your own risk with no warranty of any kind.

    IMPORTANT:
    Xperia X8 must be E15i [NOT E15a]
    Xperia X8 must have the latest firmware: Eclair 2.1.1.A.0.6
    Xperia X8 must be ROOTED - use SuperOneClick
    Xperia X8 must have Busybox 1.1.7 installed (from Android Market - it's free)

    IMPORTANT Note for BusyBox
    What you have downloaded from Android Market is the BusyBox Installer
    After you get the app from the Android Market you still need to <launch> and <install> BusyBox

    NOTE:
    E15a has UMTS/HSPA 850/1900/2100
    E15i has UMTS/HSPA 900/2100
    If you have E15a and use <xRecovery_E15i_installer.apk> you will lose 3G/GPS/GSM services.

    DOWNLOAD:
    xRecovery.E15i.installer.zip

    METHOD:
    Step 1: Download, unzip, copy to SD Card and install <xRecovery_E15i_installer.apk>
    Step 2: Reboot and when the words Sony Ericsson appears on startup <multiple click> the back button.

    xRecovery USAGE:
    Select Buttons = Volume Up & Volume Down Buttons
    Enter Button = Home Button
    Back Button = Back Button

    To BACKUP your Xpedia X8's current ROM
    select <backup and restore><backup> from the menu

    This will create a backup file in your SD Card <SD/xRecovery/backup>
    You can copy this backup file to your PC for safe keeping and at a later date copy it back to your SD card </xRecovery/backup> to restore

    To RESTORE from a backup of your current ROM
    select <backup and restore><restore> from menu & select the <file_name>

    CREDITS:
    zoz33, zdzihu and unic0de from XDA-Developers ;)

    Were you successful installing xRecovery using the New Skool Method? :)

    Advertisement
    Liam_K, shanjia, teejbee and 4 others like this.
  2. boyngeemmaa

    boyngeemmaa New Member

    i follow your instructions.. but it boot normally.. even thoug im doing the multiple tap on back button


    you did't mention that the busy box i've downloaded from the market is only a installer.. i thought it will automatically installed on my phone.. thanks very much.. its working now..
  3. bbkpro

    bbkpro New Member

    I have installed the Busybox from the busybox installer and that says status:done and have used the xRecovery installer to install the chargemon, busybox and xrecovery.tar to the system/bin area, everything is installed or placed where it should be but when i turn the phone off and reboot it I cant get the xRecovery menu from pressing the back button during the Sony Ericsson screen? HELLLPPP please :(

    *Just checked the market and i have busybox 3.3.9 installed not 3.3.7, this wont make a difference will it?
  4. gabeyong

    gabeyong Well-Known Member

    Hi,

    Just check a few things:
    1) Phone model is E15i with the latest firmware 2.1.1.A.0.6
    2) You did not mention if you have rooted your phone. Your phone must be rooted - <SuperUser> icon in your phone.

    If your phone "qualify" it should work. It doesn't matter if it is BusyBox v3.3.7 or v3.3.9
    just <launch> the BusyBox Installer and <install> BusyBox 1.1.7

    cheers

    Do or do not... there is no try - Yoda
  5. restituto

    restituto New Member

    I did as you instructed but when i reboot it goes straight to normal boot, it did not go into xrecovery, then i tried to install again xRecovery, it says it's aleady installed. What to do now?
    Thanks
  6. shehkian

    shehkian New Member

    finally i found a better solution
  7. gabeyong

    gabeyong Well-Known Member

    Hi,

    You have to check if you have met the prerequisites on at the top of my post.

    otherwise you have to do it the manual way.

    OLD SKOOL METHOD

    cheers :)
  8. cool2hate

    cool2hate New Member

    same problem i couldnt took backup of my ROM xrecovery does not works. I tries manual and automatic boot methods still no gain :S ROM Manager couldnt do either :S
  9. hackhan

    hackhan New Member

    you are good man dude :D thanks everything!
  10. anilwits

    anilwits New Member

    thank you so much gabeyong....u r the best......
  11. nini_2010

    nini_2010 New Member

    I have tried the old school method and did not work,wanna try using new school method.do I have to install again busy box.i found that for v1.1.7 got many version from 1.1.7.1 till 1.1.7.4.which one should I pick and where to install it,system/bin or system/bin.please help me.
  12. gabeyong

    gabeyong Well-Known Member

    Hi,
    Install the latest Busybox whatever the version
    Then you have to ROOT your phone using SuperOneClick

    Assuming you have E15i... and a file explorer like Astro...

    download and install the xRecovery.E15i.installer.apk

    cheers :)
    gabe
  13. vascoadao

    vascoadao New Member

    Hello all from a newbie!
    I think I've mada everything correctly to install Xrecovery on my SE Xperia X8... but when I use Astro file manager to check if all files in the right place (\system\bin\) Xrecovery.tar is missing. I can't move it using Astro.
    When I try to use XRecovery installer it reports:
    "cp can't create '/system/bin/xrecovery.tar': Read only file system
    Any ideas or suggestions? :eek: Thank you!
    (I have busybox and used superoneclick to root the phone, I have superuser installed and Xrecovery installer is listed there)
  14. gabeyong

    gabeyong Well-Known Member

    hi,
    if you have done everything correctly you should be able to reboot and go to xRecovery menu by pressing the back button.

    otherwise you might have to use Root Explorer to copy and paste the three files manually and before you paste the three files using Root Explorer do remember to <click><Mount R/W>

    cheers :)
    gabe
  15. vascoadao

    vascoadao New Member

    i thought, using XRecovery, even Xrecovery.tar will be moved to /system/bin/
    Do I need Root Explorer to mount R/W the internal memory? Can I use terminal emulator?
    Thanks
  16. gabeyong

    gabeyong Well-Known Member

    Hi,

    I do not know how to use terminal emulator.
    I used Root Explorer.

    cheers :)
    gabe
  17. richumathew

    richumathew New Member

    is it okay to install busyox after rooting x8?....and i cant get in to xrecovery..-_-.....plz help
  18. gabeyong

    gabeyong Well-Known Member

    hi,

    look here OR here

    watch the video and follow the steps

    cheers :)
    gabe
  19. makodroid

    makodroid New Member

    To: Gabeyong

    Followed your instructions
    1.successful root using superoneclick
    2.download busy box and install v 1.17.1 found ok
    3.launch/install xrecovery.apk followed on the link found ok
    4.reboot phone and after sony ericson logo appear press back several times
    but won't work.

    any problems with my installation?im a bit newbie so pls bear with me.;)
    * before try copying/install through rootxplorer but not possible because of file permission even though change it/permit and said out of memory.

    pls reply, much appreciated.

    best grds,
    makodroid
  20. asce2428

    asce2428 New Member

    please is there anyone else can help me with my problem?

    I cannot paste the file busybox, chargemon and xrecovery.tar to system/bin it keeps giving me this message "you cannot paste here because the file system is read-only." please anyone help me with my problem. :(

    thanks !!
  21. gabeyong

    gabeyong Well-Known Member

    Hi,

    if you are using Root Explorer before you paste the files <Select><Mount R/W> at the top of the screen. if you select Mount R/W you should be able to copy and paste without problems.

    cheers :)
    gabe
  22. AcidSpill

    AcidSpill New Member

    few days b4,i rooted my phn(successful) and installd rootexplorer..
    smwhr i read tat clockwrkmod z new vrsn f xrecvry..so i dwnlded tat
    it had META-INF and system folder>{xbin>>sh, bin>>recvry.tar,chargemon,charger)

    as it ws writtn in instrctn to cpy cntents f bth 'XBIN' n 'BIN' into /system/bin n grnt permissions..
    i did the same by clckn mount r/w..n pasted it
    #rebooted..

    Now rootxplorer shws Restrt App error..and wifi and odr thngs r disabld on phone..
    any .apk regrdng root access doesnt seem to wrk,evn wen Superuser app alows thm permissn

    #flashtool tried too..(not wrking nw)
    #tried to re-root..(not wrking)

    PLZ HELP!!:(:( m stuck badly..
  23. shanjia

    shanjia New Member

    It works on mine,thank you so much Mr. :)
  24. imran2197

    imran2197 New Member

    i have installed xrecovery( the one from new skool). i have rooted my phone via super one click. i have the superuser icon in my phone. i have also installed root explorer. BUT i m totally lost at the 3 files thing! I dont know what 3 files everybody is talking about. but i installed busybox from th android market. version 1.19.4 . help meeeee!!
  25. gabeyong

    gabeyong Well-Known Member

    Hi,

    If you have installed xRecovery the 3 files are not required.

    cheers :)
    gabe

Share This Page