[NEW SuperOneClick] Root, Install & Use xRecovery on Xperia X8


Last Updated: 2014-01-01 09:56:26
  1. gabeyong

    gabeyong Well-Known Member

    Hi all...

    Just installed xRecovery on my Xperia X8.
    Firmware: Android Eclair v2.1

    Just wanted to share how it is done.

    DISCLAIMER: Please use the info below at your own risk with no warranty of any kind.

    A) INSTALLING xRecovery

    WHAT YOU NEED: <download>
    SuperOneClick :-
    SuperOneClickv2.3.3-ShortFuse OR Alternative Mirror
    SuperOneClickv2.1.1-ShortFuse
    SuperOneClickv1.9.1-ShortFuse


    xRecovery (3 files within the .rar file) :-
    xRecovery0.1.rar

    Note: There are 3 versions of xRecovery (xRecovery v0.1 for Xperia X8, xRecovery v0.2 and xRecovery v0.3 for Xperia X10) but only xRecovery v0.1 will work on the Xperia X8. These xRecovery files are developed specific to a type of android phone not upgrades/updates.

    Root Explorer :-
    Root.Explorer.v2.19

    HOW IT IS DONE:

    Step 1: Root your Xperia X8
    - download and unzip SuperOneClickv1.9.1-ShortFuse to PC Desktop
    - connect Xperia X8 to PC (Do not mount)
    - on your phone <goto><setting><applications> select <unknown sources>
    - on your phone <goto><settings><applications><development> select <usb debugging>
    - Launch SuperOneClick -> click <Root>
    - you will see - <not successful - is your phone software higher than 2.0?>
    - click <yes> and then <success> & <test su> message
    - Reboot Xperia X8

    NOTE:
    If SuperOneClick is running but hangs mid-process you need to install .NET Framework v2.0 or above. DO NOT ASSUME you are running Windows 7 it has .NET Framework installed.

    If you are successful in ROOTING your phone - SuperUser app will be installed to your Xperia X8.
    If you are not successful:-
    (a) check your PC <devices><usb> to see if your phone is recognized by your PC (troubleshoot PC driver problem)
    (b) <usb debugging> in your Xperia X8 phone settings enabled?
    Then <Launch> <SuperOneClick> and try again.

    [if you don't have a file manager on your phone]
    Install <Astro File Manager> from Android Market


    Step 2: Mount Xperia X8 (to access SD Card)
    - copy <Root.Explorer.v2.16.apk> to root of SD Card
    - using PC create folder <xRecovery> and unzip xRecovery0.1.rar
    - put the 3 files into the xRecovery folder you've created
    - copy the xRecovery folder to root of SD Card

    Step 3: UnMount Xperia X8 from PC

    Step 4: Launch <Astro> Install <Root Explorer v2.16.apk>

    Step 5: Copy xRecovery files to </system/bin> of your phone
    - Launch <Root Explorer>
    - scroll down to /sdcard <click to access>
    - scroll down to xRecovery folder <click to access>
    - Select each of the 3 files (one by one) <click & hold><copy>
    - <click> parent folder (twice)
    - scroll down to <click to access><system>
    - <click to access><bin> and <click><Mount R/W>
    - press <paste> button

    COPY ALL THE 3 FILES (one by one) FROM xRecovery Folder to </system/bin> folder
    (i.e. busybox, chargemon and xrecovery.tar)

    Once you have done that... you have installed xRecovery to your Xperia X8

    SHUTDOWN -> Wait 5 seconds and REBOOT

    When you see the words [Sony Ericsson] on the phone screen - start pressing the back button on your phone multiple times and you will enter the xRecovery Menu.

    USING xRecovery

    Select Buttons = Volume Up & Volume Down Buttons
    Enter Button = Home Button
    Back Button = Back Button

    To BACKUP your Xpedia X8's current ROM
    select <backup and restore><backup> from the menu

    This will create a backup file in your SD Card <SD/xRecovery/backup>

    Note: Typically the backup should be around 256MB in size, so you may want to copy the file to your PC to lighten your 2GB SD Card.

    To RESTORE from a backup of your current ROM
    select <backup and restore><restore> from menu & select the <file_name>

    Note: If you have a backup on PC just copy it to <SD/xRecovery/backup> and restore as usual.

    To install a Custom ROM (e.g. GINGERBREAD 2.3.3 CM7 for Xpedia X8)
    Just download it from the xda-developers.com website and copy to SD Card
    reboot and use xRecovery to <restore> the Custom ROM to your Xperia X8.

    And that's it..... Have Fun!!! :)

    Reference:
    YouTube Video

    Upgrade your Xperia X8 to Floyo 2.2.1 <-- Hit the Link!

    Installing Gingerbread 2.3 ROM on Xperia X8 <-- Hit the Link!

    Installing GingerDX ROM 2.3 on Xperia X8 <-- Hit the Link!

    Advertisement
    ebn3ez, SHORTEDBOARD, salt79 and 18 others like this.
  2. nnndaru

    nnndaru New Member

    This is the best guide in chronology for newbie like me :DD
    After take a long time, i try to arrange the tutorials that spread in this forum and other xperia forum, the result steps are same as yours, but you did better than me, :p

    I've reflashed my xperia x8 this morning, restart from downloading via pc companion, because the system has crashed. Whereas, i've bought my phone about 2weeks ago.. LOL :D

    Thank you anyway
    Sorry about my bad english
  3. gabeyong

    gabeyong Well-Known Member


    Hi,

    I am glad you liked the guides I put out.
    Enjoy your Xperia X8!!!

    cheers! :)
  4. nnndaru

    nnndaru New Member

    :)

    i have a problem here, after step 6, and shut my phone down,
    reboot, wait for sony ericsson, pressing the back button several times
    but i still couldn't open xrecovery.. it boots just like usual

    how come?
  5. gabeyong

    gabeyong Well-Known Member

    I think you are stuck at the following
    1) Search for BusyBox from Android Market and install - after you do this you must <exit> and <launch> BusyBox installer from your phone to install Busybox v1.1.7

    (I will edit the above instructions for Step 5)

    OR

    2) you were not successful in putting the three xRecovery files into /system/bin

    If you cannot manage after a few tries go look up [NEW SKOOL] Install and Use xRecovery
    since your phone is a full-wipe-new-install.

    hope that helps...

    cheers :)

    Try you must! - Yoda
    nnndaru likes this.
  6. nnndaru

    nnndaru New Member

    I have installed the busybox from the market, and than i put the three files using Root Explorer (busybox, chargemon, xrecovery.tar), that's mean i should overwrite the installed busybox in /system/bin? is it right?

    :) thank you again, i've just opened the new skool version, but i dont undestand why i can't download xRecovery E15i from megaupload, haha
  7. gabeyong

    gabeyong Well-Known Member

    Hi,

    Sorry to hear that you are still struggling to install xRecovery.
    I have added the file to Mediafire so hopefully you can download.

    xRecovery APK Installer <-- here

    cheers :)

    Try you must - Yoda
    nnndaru likes this.
  8. nnndaru

    nnndaru New Member

    Haii too, :D

    thanks, you're so helping anyway :)
  9. aloy99

    aloy99 Member

    Yay, works great for me!
  10. aloy99

    aloy99 Member

    Wow, works, but when I use a certain rom I can't even access xrecovery anymore. Guess have to use flashtool.
  11. shit_lord_68

    shit_lord_68 Member

    Hi gabeyong, can u please help me out here...
    I did everything like u said and everything was fine until I tried to install BusyBox...
    I downloaded it from market, opened it, then i pressed the ''ok'' button and it shown me a massage ''Please wait while we locate BusyBox and gather system data...''
    Then, after one minute, it said Sorry,the app has stopped working...
    And I am forced to close the app
    What can I do?
    Please help
  12. gabeyong

    gabeyong Well-Known Member

    Hi,

    just check a few things...
    1) usb debugging still enabled? - <disable> usb debugging --> settings><applications><usb debugging><uncheck the box>

    2) after system crashed try - <shutdown><reboot after 5secs> OR <take battery out 5 secs and reboot> try re-installing busybox

    3) skip the busybox 1.1.7 install and COPY ALL THE 3 FILES (one by one) FROM xRecovery Folder to </system/bin> folder (i.e. busybox, chargemon and xrecovery.tar).

    hope that helps...

    cheers :)

    Do or Do not... there is no Try - Yoda
  13. shit_lord_68

    shit_lord_68 Member

    Will try,and also I will let u know if it helps
  14. shit_lord_68

    shit_lord_68 Member

    Thanx so much...
    U really helped me...
    Excellent guide!!!
  15. gabeyong

    gabeyong Well-Known Member

    Hey, Glad it works for you... :)
  16. shit_lord_68

    shit_lord_68 Member

    I'm sorry for my noobness when it comes to installing new rom...
    But, can u please post a guide to install new custom rom from xda-developers. .
    Thanks in advance...
  17. gabeyong

    gabeyong Well-Known Member

    Hi,

    Have a look at this post:

    CM7-X8-J005 ROM

    But beware - these ROMs are still in development stages.
    It will cause your phone to have intermittent crashes and reboots

    cheers :)

    Do or Do not... there is no Try - Yoda
  18. choemin

    choemin Member

    Cool... where is Sony 2.3 ROM?
  19. Blitzkri3g

    Blitzkri3g Well-Known Member

    Nowhere to be found.
    2. 1. 1 is the latest and last official update from SE.
    N.
  20. westinboy123

    westinboy123 Member

    Help me.. I have spent hours trying to get ROOT ACCESS!!!! AH... Pisses me off. Firstly I run superoneclick and it says my phone is rooted. But when I go to superuser apps. NO APPS IN LIST!!!!! I use root checker. YOUR PHONE IS NOT ROOTED>!!!!!! WHY WHY WHY. HELP PLEASE
  21. westinboy123

    westinboy123 Member

  22. westinboy123

    westinboy123 Member

    The problem is that even when I have superuser app in my phone... The PERMISSION BOX doesn't show even when I try to use adfree, rom manager!!!! AHHHHHHHHHHHHH
  23. westinboy123

    westinboy123 Member

    And I used terminal emulator type su.. access denied..
  24. lostwarrior

    lostwarrior Member

    when i copy the xrecovery files to system/bin it says"cannaot copy the file system is read only.."...
    what should i do?
  25. gabeyong

    gabeyong Well-Known Member

    launch <Root Explorer 2.14.2> <select> <Mount R/W> on the top of the app screen.

    you should be able to copy & paste now!

    cheers :)

Share This Page