[NEW SuperOneClick] Root, Install & Use xRecovery on Xperia X8


  1. westinboy123

    westinboy123 Member

    Gabeyong can you answer me..
  2. gabeyong

    gabeyong Well-Known Member

    Hi,

    Without sounding impolite or demanding...
    Which version Android ROM are you running? 1.6 or 2.1.1?
    What message did you receive when you completed the Rooting? <success?>
    <test su>?

    Note:
    1) there will not be any apps listed on your SuperUser List unless you install an app that requires root access that trigger an SU request event.
    2) If you have rooted your phone successfully apps requiring root access will "trigger" SuperUser request message box and you have to <click><remember><ok> to allow su access for the app and then the app will be listed on the SU app list.
    3) install Root Explorer and <launch> it to test if SuperUser will "trigger" request message.

    If SuperUser is not triggered when you launch Root Explorer then you have not successfully rooted your phone.

    have a look here for a similar example... Hit the link below.
    SuperOneClick Rooting of Android Phone <--- here

    cheers :)

    Sometimes one pays most for the things one gets for nothing - Albert Einstein
  3. Pretty

    Pretty New Member

    Hello
    Ummm, first I want to thank you gabeyong!
    Thank you thank you thank you

    However, I have a request, and I hope that does not bother you this: (
    Well, I have a problem with Mijobload
    So I want you can upload these files
    To (Media Fair) or (Rapidshare) or (hotfile) or any things :(

    These files:
    MEGAUPLOAD - The leading online storage and file delivery service
    And :
    MEGAUPLOAD - The leading online storage and file delivery service


    And sorry for the inconvenience
    With thank you:)
    (Sorry, my native language is not English)
  4. gabeyong

    gabeyong Well-Known Member


    xRecovery 0.1 <-- here

    Root Explorer 2.14.2 <-- here

    cheers :)
    Pretty likes this.
  5. epica1977

    epica1977 New Member

    I make all the progress and i try to get to xrecovery but i can't....i turn off the phone and then reboot i push the back button but nothing happen...please help me...
  6. gabeyong

    gabeyong Well-Known Member

    Hi,

    If you cannot enter the xRecovery menu when the <back> button is depressed multiple times - you have not successfully moved the 3 files required for xRecovery to work in /system/bin folder of your phone.

    You might have to try again.

    cheers :)
  7. cool2hate

    cool2hate New Member

  8. kallunga

    kallunga New Member

    yepe!
    after 3 hours booting and rebooting and replacing...
    but, works.
  9. chaangster

    chaangster Member

    Gabeyong, i tried to root it but it just stuck there and say <killing ADB Server> and i waited for 30 min. Pls help me asap.
  10. gabeyong

    gabeyong Well-Known Member

    Your Xperia X8 is not recognized by PC.
    Make sure your X8 USB drivers are installed properly.

    cheers :)
  11. chaangster

    chaangster Member

    How do I install X8 USB Drivers? I have the zip file but I can't seem to find the launcher.
  12. chaangster

    chaangster Member

    Thx I got it now.
  13. chaangster

    chaangster Member

    I have installed root explorer but it kept on saying "Restart App" why is it so?
  14. gabeyong

    gabeyong Well-Known Member

    Hi,

    before you can use Root Explorer you need to Root and have SuperUser installed. SuperUser needs to give su permission to Root Explorer for root excess - If you have not done this "Restart App" occurs.

    You can check by clicking on SuperUser to see if Root Explorer is listed.

    cheers :)
  15. niamhnanog

    niamhnanog New Member

    Hey Gabeyong, thanks so much for all your time and effort put into these threads, your a massive help to those of us out there who don't quite have the know how!
    I've been following the steps and I've successfully rooted my phone using SuperOneClick but now...

    1: I'm not sure exactly where 'root of sd' is as a location, I guessed it to be the '/sdcard' folder but after transferring rootexplorer over it doesnt show up in the folder at all..

    2: After i unzipped xrecovery it came up with 2 folders named 'res' and 'sbin' with 3 other files named init.rd, init and default.prop... 27 files in total but one named busybox, chargemon or xrecovery.tar, very confused....

    Any help at all would be great thank you!
  16. gabeyong

    gabeyong Well-Known Member

    Hi,

    Answer:

    1: Yes, root of the SD card = /sdcard

    2: yes, you only need 3 files - copy them to /system/bin (i.e. busybox, chargemon and xrecovery.tar)

    cheers :)
  17. killerkiller30

    killerkiller30 New Member

    well i done what it say install the busybox chargemon and xrecovery in the correct place i did root it for superuser the issue i am havin is near the last part where getting xrecovery to work did the back button ive been read other formers the they press volume but that what i heared i am hoping u can help because SE wont :mad:
  18. killerkiller30

    killerkiller30 New Member

    i even hear of app2sd but that seems a bit diffcult to use i guest
  19. sanji29

    sanji29 New Member

    can any1 help me to root x8 eclair using windows xp?? please?
  20. massiliafrog

    massiliafrog New Member

    Hi,
    Thks for the clear how to, however, i'm stuck quite in the begining...

    running unbuntu 11.04 for my PC and adroid 2.1 on my X8
    I managed to run superoneclick 1.9.1
    I started rooting the x8 but I cant fininsh the procedure

    I do see the <not successful - is your phone software higher than 2.0?> message
    I click <yes>
    but then I get stuck at "chmod psneuter"
    I've been googling that a bit but cant find any solution, so I decided to come back here to ask...

    any idea to help would be appreciated

    thks
  21. gabeyong

    gabeyong Well-Known Member

    Hi,

    I don't what went wrong but from superoneclick.org website

    QUOTE
    The superoneclick program requires Microsoft .NET Framework 2.0+ or Mono v1.2.6+ for operating systems with native support:

    Windows Vista
    Windows 7
    Ubuntu Hardy (8.04 LTS)
    Ubuntu Jaunty (9.04)
    Ubuntu Karmic (9.10)
    Ubuntu Lucid (10.04 LTS)
    Ubuntu Maverick (10.10)
    Debian Lenny (5.0)
    Debian Squeeze (testing)
    Debian Sid (unstable)
    Debian Experimental

    You NEED to put your phone on USB Debugging mode
    You NEED to install make sure the Android drivers for your phone are installed
    Make sure you DO NOT mount your SD card.
    If you still can't get something to run, try doing it in recovery mode.

    UNQUOTE

    cheers :)
  22. massiliafrog

    massiliafrog New Member

  23. gabeyong

    gabeyong Well-Known Member

  24. massiliafrog

    massiliafrog New Member

    thks for the suggestion. in fact i tried the older version first, but stuck at chmod also

    since i'm quite used to linux command i've been tring to root it manually following this, i'm almost there it seems...
    got superuser installed but the su works only once from adb and then on next reboot it's gone...
    tried z4root wich give me a black screen...
    i'm affraid i'll be stuck with android 2.1 cos my patience is getting smaller ;)

    thks for the help anyway, is good to see someone answering ;)
  25. gabeyong

    gabeyong Well-Known Member

    Sorry it did not work out...

    Have a look here... Xperia X8 Root

    You might have to borrow a Windows PC to root your phone if this doesn't work out.
    I borrowed my firend's Win7 laptop coz I only have a Mac.
    Heh :)

    cheers :)

Share This Page