1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[NEW SuperOneClick] Root, Install & Use xRecovery on Xperia X8


  1. gabeyong

    gabeyong Well-Known Member

    Hi,

    there are lots of things that can go wrong...

    1) Win7 32bit NOT 64bit
    2) faulty usb cable
    3) usb drivers not installed properly or sd card mounted
    4) phone settings <unknown sources> & <usb debugging> not enabled
    5) superoneclick not responding - app conflict (restart Win7 PC required)

    check these faults... and try to follow the video if possible...

    cheers :)
    gabe
  2. be_born

    be_born New Member

    Hi all,
    when i get to this step:

    Step 5: Copy xRecovery files to </system/bin> of your phone
    - Launch <Root Explorer>

    I experience problems. When i launch Root Explorer, I get this error message:

    Restart App
    Root Explorer has not yet managed to obtain root access. Because of issues with Superuser, this often happens the first time the app is run but is usually fine from then on.

    Click OK and restart the app to try again. Make sure you respond correctly to the Superuser prompt.

    Any ideas how to solve this?
  3. Fannaringi

    Fannaringi New Member

    Hi,

    I was trying to root my phone following this guide. I'm having this will known
    problem with the root explorer. I tried reinstalling it but I never get up a similar window like in the picture. How do I sort that out ?

    Also, I've seen busybox (from market) mentioned all over the place, there is no
    busybox on the androidmarket, how come ?

    *EDIT*
    It got it working, I'm not sure how I was just lying in bed with the phone rotated and tried
    clicking on root explorer then got up that window.
  4. be_born

    be_born New Member

    Ok, so I got passed my last issue by reinstalling Root Explorer... i am soooo close to getting Gingerbread 2.3.4 into my phone now... please please please help me finish this, someone...

    I copied the v2.7.136 decompressed folder to <SD/xRecovery/backup>, rebooted the phone into the xRecovery menu and tried to restore using the 2.7.136 ROM image... but then i get this message from xRecovery:

    Checking MD5 sums...
    MD5 mismatch!

    Ideas on hove to work around this, anyone?
  5. be_born

    be_born New Member

    Yay, i got it up and running by installing it like a custom zip instead... now all I need to fix is getting the contacts over + find a fix to make the camera work again... hmm...
  6. gaogao6

    gaogao6 Member

    Hi gabe, i reinstall my usb driver and it worked
    thousand thks to u =)

    but i encounter another prob,that is when i copy those 3 files
    chargemon & busybox are copied successfully
    but my "xrecovery is in zip file icon" i have no idea what to do with it,
    the "permission" is also failed to do it...

    pls guide me :)
  7. gabeyong

    gabeyong Well-Known Member

    Hi,

    It should be - <xrecovery.tar>
    just copy it and paste (like the rest) into /system/bin using root explorer.

    cheers :)
    gabe
  8. magnuspi

    magnuspi New Member

    Just a note if you want to do the installation without Root Explorer and from the command line. :D

    1) copy the 3 files (i.e. busybox, chargemon and xrecovery.tar) to sd with adb; in the following from a dir called xRecovery in a dir called xRecovery
    adb push xRecovery /sdcard/xRecovery
    2) get the shell: adb shell
    3) get superuser privilegies: su
    4) change dir
    cd ../system/bin
    5) copy files
    cp /sdcard/xRecovery/* .
    6) set the proper access mode
    chmod 755 busybox
    chmod 755 chargemon
    chmod 666 xrecovery.tar
  9. gaogao6

    gaogao6 Member


    hi gabeyong,

    is it the "permission" step on the "xrecovery.tar" file not necessary??
    because i cant do that before copy into "system/bin", can do that after copied

    and my "permission" has 3 more "special permission" at the bottom =="
    the "xrecovery.tar" file i was downloaded from the other website, becoz i cant open the link u gave ..
  10. gabeyong

    gabeyong Well-Known Member

    As long as you have successfully copied all the 3 files into /system/bin
    your X8 should be able to boot to xRecovery

    cheers :)
    gabe
  11. scorpiopaulius

    scorpiopaulius New Member

    I used xrecovery installer, but when I try to enter to recovery its just stuck on sony ericsson logo and wont turn on even to normal... What should I do? I'm newbie in this phone. :(
  12. gabeyong

    gabeyong Well-Known Member

    Hi,

    Did successfully root your phone before installing xRecovery?
    Otherwise I suggest you use PC Companion to reinstall Android Eclair 2.1
    then follow the instructions to Root and install xRecovery.

    cheers :)
    gabe
  13. kohan

    kohan New Member

    Hi guys,
    I had gingerbread installed on my X8 and now I need to get it bact to original ROM.
    I think that there is something wrong with my phone so I want to use my warranty.
    Can I even unroot my phone so that my warranty will be valid?
    I think I read somewhere about unrooting but now i can't find it.

    Thanks in advance.
  14. gabeyong

    gabeyong Well-Known Member

    Hi,

    Just use PC Companion and reinstall your Xperia X8's firmware back to Eclair 2.1.1 (unroot is done by PC Companion automatically).

    cheers :)
    gabe
    kohan likes this.
  15. kohan

    kohan New Member

    I don't have to remove xRecovery or any other appication before?
    Becouse if they find out that I was messing out with my phone warranty probably won't be valid

    I'm bit scared :/
  16. gabeyong

    gabeyong Well-Known Member

    Hi,

    Rooting is not permanent... once you install the official software it becomes unrooted. There is no way anybody will know if a phone has been rooted or not after you reinstall the official Android Eclair 2.1.1 by SONY Ericsson using PC Companion.

    No fear mate :)

    cheers :)
    gabe
    kohan likes this.
  17. Ac3R71J0

    Ac3R71J0 New Member

    Thank you very much ! Its super simple and works !
  18. mozmagic

    mozmagic New Member

    Hi Guys, a new person here, feel like I know some people already from the number of posts I've read trying to root my X8, I've been reading through lots of posts whilst I've been sat here for a few hours and now going round and round in circles. Hopefully someone can help me as I'm starting to feel very stupid, as I'm computer illiterate, and the missus is starting to need help with the kids. Anyway, I followed the steps and my phone is now rooted, however issues arise when I get to the next step and need to install xrecovery.

    Gabeyong started the thread saying that after rooting I need to install xRecovery using xRecovery0.1.rar

    When I get to this stage it all goes wrong. I don't have 3 files within xRecovery0.1.rar - all I get is one file by this name, there is no busybox or chargemon. I can't unzip the file. Has anyone got any idea where I've gone wrong? I'm running Vista, is it my computer? Should I try to do this on my XP computer? Without these files I don't know how to proceed.

    I've managed to install root explorer as well so not all bad, but really need some help! Thank you guys and gals.

    Moz
  19. mozmagic

    mozmagic New Member

    Erm, now I've worked out what a .rar file is I may be getting somewhere :eek:
  20. mozmagic

    mozmagic New Member

    Silly me, taken all day to do but my phone is rooted, backed up and loads of apps are now on my SD card. :) Perhaps the next time I get some time to myself I can trying installing a different rom? Is that what it's called? :confused: :eek:

    Blimey, if I can do this then anyone can, thanks to this website :D
  21. rupislt

    rupislt New Member

    i have succesfully got to the part where i backed up my firmware and now i have a problem. when i connect the phone to the computer it doesnt show up on the pc or the phone. i have no way to acces my phones memory and no way to install android 2.3 if anyone could help me i would be very greatfull. you can reply to this post or write to rupislt@gmail.com
  22. gabeyong

    gabeyong Well-Known Member

    Hi,

    Root and installing xRecovery does not disrupt USB services.
    Check your PC usb drivers for X8 and your cable.

    cheers :)
    gabe
  23. notuser

    notuser New Member

    I would appreciate some assistance -

    I have followed your instructions provided to the letter, however, I am unable to open "Root explorer". It is giving me the message that it has not obtained root access.

    The problem is that I have no received the notification from Superuser that the app is requesting permission. I have rooted and unrooted, downloaded the newest Superuser version from the Market, and I have also cleared the cache, and yet the notification still does not appear.

    Is there anyway to fix this problem?

    Thanks.
  24. gabeyong

    gabeyong Well-Known Member

    Hi,

    you have to make sure you have 2 things...
    1) USB device driver for Xperia X8 to connect to PC to work properly
    2) .Net Framework 2.0 or higher for SuperOneClick to work properly

    cheers :)
    gabe
  25. notuser

    notuser New Member

    I have both, and yet the problem still persists. Is there anything else that can be done?
Loading...

Share This Page