New to android and nothing works! Please help me!Support


  1. sabrinaguth81

    sabrinaguth81 New Member

    Hello!
    I'm completely new to the whole android thing and just can't figure it out. Can't update my phone, nor can I send pictures (yes, I got a Data Plan). I don't even know where to start...
    I've purchased a Sony Ericsson Xperia X10a from ebay. In order to unlock it, I purchased an unlocking code from unlocking.com. Once I received my code they told me to put in any sim card and then enter the NCK code they sent me. Ok, I did all that,... and I got me a T-Mobile Simcard with 2GB DataPlan. Once I started trying to figure out the whole thing,... I can make/receive calls, but can't send pictures and can't connect to the 3G network. I finally got it connected to my wireless network at home. Also, I downloaded the PC Companion and everything. I can connect the phone to my laptop, but can't update my phone. I'm stuck at the backup. On m.sonyericsson.com/backup I've downloaded the application to backup my data, but I can't install it on my android. I get the message: "For security you phone is set to block installation of applications not sourced in Android Market." So I looked it up on my user guide and it told me how to allow download of web applications. But right there I have the next problem: I don't have an option to mark the unknown sources check box! I can't delete applications either! Did I do something wrong when I unlocked my phone? Or do I have to root the phone (even though I don't even know what that means, but I've read it numerous times online). I just don't know what to do now. I can't even disable the call forwarding when busy. It tells me: "Call settings error: Unexpected response from network." Also,... I've changed the number of my voicemail already. I've got a 630 area code, but in the call forwarding settings it has a 805 area code saved and it won't allow me to change it either. Anyone please know what to do???? I really really need help!!!

    Advertisement
    :
  2. XplosiV

    XplosiV Master X is Watching You VIP Member

    It might sound silly, but some of the symptoms you describe sound like they can be resolved by doing a factory reset (as much of a pain in the arse as it is) I know this works on some other phones, (galaxy s for one when it first came out)

    Don't be concerned about rooting, all that does is give you more permissions than your likely to need, and with such permissions come the higher chance of doing something that could damage/corrupt your firmware, and then it's a whole different ballgame.

    I'm sure other users will be able to help you out more specifically.
  3. beau420

    beau420 Well-Known Member

    Reset the phone to factory default or reset settings...Menu button->Settings->Privacy.....do one or the other....

    Sometimes I feel like a broken record....but here is hoe to fix the being able to send photos problem:

    You need to know your MMS settings if that Setting Download option doesn't work.

    If PC Companion doesn't work (like it didn't work for me) then download SEUS from Sony and update using SEUS instead.

    Hope that gets you started....let me know how it goes and if you have any other questions after.
  4. KTP

    KTP Well-Known Member

    i found this on another forum:

    hopefully this helps as from what i read of your post, its just needing the APN set up for your carrier.
    sabrinaguth81 likes this.
  5. sabrinaguth81

    sabrinaguth81 New Member

    I've tried everything you guys suggested. The one that finally worked was KTP's solution. I finally was able to send MMS,... :D it shows the E now to the left of the strength signal. Thank you so much for your help. Now I have only one last question... what is the difference between E and 3G? :confused:
  6. beau420

    beau420 Well-Known Member

    The E is Edge.... the H is HSDPA.

    Enhanced Data Rates for GSM Evolution - Wikipedia, the free encyclopedia
    High-Speed Downlink Packet Access - Wikipedia, the free encyclopedia
  7. sabrinaguth81

    sabrinaguth81 New Member

    Ok,... thanks,... I found out that EDGE is a lot slower than 3G. Now, my Sony Ericsson Xperia X10a is a 3G phone, so does anyone know the MMS/internet settings for 3G T-mobile that are compatible with my Xperia X10a? I mean, I'm happy I finally got it set up, but if I can have the faster 3G, I prefer that of course. I really appreciate the help!

    Before I set it up with the settings for EDGE I rooted my phone,... now I have another little problem. When I try to call my voicemail, it won't let me enter my pin. It seems like during an active call I can't do nothing on my touch screen. Does anyone know why that is? Should I just reset my whole phone? If I would have known that I will have so many problems, I would have never picked the Xperia X10a. I was sure somebody could unlock it for me, but it turned out that nobody in my area could and that's how I got stuck with all those problems by myself. I also can't delete applications. I can force stop them and clear the cache, but I can't remove them from my phone.
  8. beau420

    beau420 Well-Known Member

    If the touch screen doesn't wake up when you move it away from your ear then I have two questions....Do you have some sort of cover that would cover the proximity sensor or do you have a special lock screen app?

    Might be a proximity thing. It has some thing that senses whether the phone is close to the ear and when you move it away it should illuminate the screen from what I remember.

    As for the Edge thing. Check this:

    Comparison of wireless data standards - Wikipedia, the free encyclopedia

    And if you take a look at your cellular providers in the list where you can select which provider you want to use, are there any icons beside any of the other providers? Under Settings->Wireless->Mobile the option in there that allows you to select which provider you want. Look for the 3G or an H

    Uh oh...read this

    xperia x10 3g frequency - T-Mobile Community

    Maybe you need a x10i for Tmobile to use 3g...might be stuck on edge unless you change cell companies or change to the x10a.

    I'm not 100 percent sure, but that's what it looks like.
    sabrinaguth81 likes this.
  9. sabrinaguth81

    sabrinaguth81 New Member

    Hi beau420!

    Thanks so much for your help! Indeed, I was using a hard cover, which covered the proximity sensor. I switched to a gel cover now and everything is working fine. I assume the 3G and Edge problem has something to do with my phone. So far the Edge is working,... even if it's not that fast,... it's ok. It's better than nothing. Even though I've noticed that I still can't send pictures. They appear like they were sent, but my friends don't receive anything. Don't really know why,... as I've tried different APN settings and the one I got now was the only one working so far... If anyone knows the exact APN settings for the Xperia x10a for T-mobile,... I really would appreciate it...
Loading...

Share This Page