1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support New to VM/Android and everythere else :) ....


  1. trekleech

    trekleech Well-Known Member

    Hello, everyone -

    so I finally got my first Android. It took me forever. I was looking to just hold out hope with TMobile but after having my account since 2003, screw them for forcing me into new data plans and horrible pricing on decent phones.

    Anyhow I got Virgin Mobile, with Beyond $15 plan and the Kyocera Rise. Why VM, basically, the phones. I can get me a decent phone it seems anytime of the year and be under $100. That's a bargain.

    So I need some tips and a few starts.

    How do I tell the phone to use my WiFi as my primary Internet source.

    Wifi Calling.... With my old Blackberry it was as simple as connecting to my WiFi, disabling Mobile Network and everything was handled through my WiFi.

    Please if possible in detail, how to set that up with this kind of phone. So that the phone quality is clear. My WiFi signal should be excellent unless the receiver on the phone is bad. :)

    It took me about 30 minutes to learn how to add a contact and about 5 minutes later how to send a text. :(

    Wish me luck and thank you for any responses.


    Best regards,

    Trek

    Advertisement
  2. trekleech

    trekleech Well-Known Member

    Hello, everyone -

    I've done so digging (reading) and this is what I've done. I've installed Google Voice on my phone. I've installed Groove IP. (Paid version) I was able to make a call through Groove IP it was clear, but the personal said the number didn't come up as my own.

    So now I'm struggling.

    I don't want to use my airtime minutes, but use the WiFi to make calls but use the regular dialer, not some special app, keep my regular number and have people call me with my regular number and be able to receive it again not use my airtime minutes.

    This not possible?

    With the BlackBerry, once I disabled the Mobile Network and connected the WiFi everything was the same, I had the same number and people were able to call me.
  3. olbriar

    olbriar Moderator Moderator

    I moved your thread here thinking your fellow device owners will be best suited to assist you. Good luck... Oh and congrats on the new phone!
    trekleech likes this.
  4. trekleech

    trekleech Well-Known Member

    OK, I kept plugging away at it some more and finally figured some things on my own through reading.

    I had to delete the Google number in my Google voice account and get a new one. Now I am able to send and receive calls with the new local Google number. Yippy!

    How do I know I won't be be deducting airtime minutes? If when on the go, like making calls using Groove IP or since its VoIP service is completely separate and would never interfere with my minutes only the data like if I'm not within my home WiFi or a HotSpot.
  5. mikeca

    mikeca Well-Known Member

    I think this should work to set your phone to use wifi only you click the right button on the bottom with the 3 dots.

    From there select system settings, click the wifi on

    below the wifi on / off toggle click "more..." then select "mobile networks" then uncheck data enabled, that will turn off your "3g".

    Hope that helps. If you are not worried about getting texts and are using google voice / groove ip you can turn on airplane mode and then turn on your wifi (it will go on). also hope that helps.
  6. cooldudezach

    cooldudezach Well-Known Member

    As far as I am aware, it is not that easy (if at all possible) to set up WiFi calling with your current number. To make sure you don't use airtime minutes is a bit tricky. Best bet is to turn on airplane mode then turn WiFi on, but then you also lose 3g data. Also, unless you use the built-in dialer (or an app redirects to it, some do I believe) you will not ever use your airtime minutes. Groove IP does not use airtime minutes, just calls over WiFi and 3g.
  7. trekleech

    trekleech Well-Known Member

    Wow, these calls I've made today were so poor its unbelievable. I have a 50 MBit plan from my ISP and unless my router WiFi signal just completely sucks, the connection was just horrible. Don't know then if its the WiFi signal, Google, or the phones receiver.

Share This Page