Nexus 7 Dead.....won't charge! :-(Support


Last Updated:

  1. szaszati

    szaszati Member

    Just a quick update on my previous post: the Nexus is now connected to my laptop via the stock USB cable and it's turned off, charging. After about 30 minutes of charging I turned it back on, and was greeted by a "Charging, 1%" message. Maybe there's hope that it will charge, even if slowly. Anyway, I turned it off and I'll wait a couple of hours before turning it on again.

    Advertisement
  2. colchiro

    colchiro Well-Known Member

    Did you try holding the power button down for > 30 secs? :D
  3. szaszati

    szaszati Member

    I didn't have to :D It just started charging after a while. Then I switched to the wall charger and now everything's fine. I think the battery drowned completely, that's why the screen went all crazy. It gave me the freaks anyway :)
  4. colchiro

    colchiro Well-Known Member

    You might have saved yourself a bit of anxiety by trying it first when it wouldn't turn on. :D
  5. zoxxo

    zoxxo Well-Known Member

    So where's the home key on the N7?

    (sorry, I couldn't resist asking the question)
  6. zoxxo

    zoxxo Well-Known Member

    Mine ran down last night and I couldn't get it to boot this morning. I plugged it into the charger with no luck. I was just about to check here or call tech support when I attempted to boot into recovery and it started normally. I figure that I must have held the three keys for 30 seconds and it kicked in using the 30 second rule.

    Either way, I'm just glad I didn't have to resort to sending it in for replacement.

    It's charging now with the power off in the hopes that it will charge faster...
  7. szaszati

    szaszati Member

    I don't know if it had helped. The battery seemed dead empty, it just needed some time to charge before turning it back on :)
  8. szaszati

    szaszati Member

    It sure helped me.. Alternatively, you could try charging it from a USB port first, then with the wall charger. I don't know if it makes any difference, but a couple of people reportedly managed to charge it this way.
  9. fuzzmello

    fuzzmello New Member

    Thanks for your help, everyone. My battery was at 37% when I shut it down and put it on the charger. 24 hours later I tried to power up and got nothing. After two hours of doing everything I could think of I was really stumped because the cord, charger, even the ports checked out.

    The 30-second power-up worked.

    Now I need to go cancel that return I scheduled with Google.
  10. tommort1992

    tommort1992 New Member

    Hi guys, i'm having a similar problem. Battery was on about 10%, no apps running, went to bed. In the morning nothing at all. try to boot up twice, both time get static on screen. think oh crap it's broken. leave plugged in all day when I go to work, get back 9 hours later and still nothing. tried the 30 second bootup and I got a bootloader screen. It's now stuck on the X after the google logo which is animated. if I turn it off, it reboots about 5 seconds later and gets to the same stage. I can only power it down by manually going to the boot loader (vol up and down + power) and pressing power off. every time I boot it I am stuck on the animated x. Any ideas guys, I'm about to fill in a return form, it's that bad.
  11. zoxxo

    zoxxo Well-Known Member

    Sorry, I'm going to ask the obvious question: did you try a different USB cable? The cable that comes with the N7 is very cheap, and I've actually had occaisional problems with it...
  12. tommort1992

    tommort1992 New Member

    yep, done all the standard diagnostics (differnt plug sockets, cables etc). looks like it is charging now however I cannot get it to boot up. All I get is the x. If i try and boot the recovery loader I don't even get past the google screen. I think it's seriously screwed.
  13. skywriter

    skywriter Member

    The charging cable for the Nexus 7 is slightly different. The cable for my
    Razr does not fit it, but I have several cables for my droid X and they do the trick. Love the fact that I now have a back up cable for travel.:)





  14. damiencannell

    damiencannell Active Member

    I think i saw another thread about being stuck in a bootload loop, try doing a search for bootload etc as i'm not sure if a resolution was found.

    Good Luck buddy
  15. craitaka

    craitaka New Member

    Wow.. Thanks EVERYONE!.. I had left my USB drive connected and sure enough, the nexus 7 was dead in the morning. Would not charge etc. I was just packing it up for a return, when I read all your responses here.. the 30 power-up did the trick..
  16. colchiro

    colchiro Well-Known Member

    I've seen similar threads in all the forums I frequent:

    HP Touchpad,
    Nook Color,
    Galaxy Nexus,
    Nexus 7.
  17. nebler

    nebler Well-Known Member

    just had to do the "30 second" trick on mine as it just 'blacked out' on me after using my OTG cable to transfer a film from a memory stick.

    Im now looking for a new cable after reading on this thread the stock one is crap,

    does this one look ok, or is it going to be just as cheap?

    [​IMG]MICRO USB CABLE FOR ASUS GOOGLE NEXUS 7 | eBay
  18. nhlfoda

    nhlfoda New Member

    Had same issues after my son allowed the battery to run down completely. Using a stop watch and holding the power button; it took almost exactly 20 seconds for it to power up.

    Thanks for the suggestion.
  19. di4b0liko

    di4b0liko New Member

    I have the same problem.
    I have now connected the device to the wall and it works fine, but the loading rate remains steady at zero. :(:(:(
  20. jwillis50

    jwillis50 New Member

    I'm in a spot of bother here gents, which is why I've signed up to take on some of your knowledge.

    Basically, I bought my nexus off ebay. I'm not blaming the seller as he's got 100% feedback from lots of customers before me and I know many other people have had battery problems before.

    My battery is charging so slowly. I've had it on since midnight last night (so around 18 hours) and it's gone up from 20% to 50%. The worst part is it dropped 1% when I used it for a few minutes while it was on charge in that time.

    I've tried holding down the power button for 30 seconds but that only turns it off and on (or just on in the case that it was off already).

    I guess it's good that it's charging, but I'd prefer not to wait two days every time it runs low.

    Basically, I glanced at google's replacement thing and they needed an order number which suggests I won't be able to sort it out under warranty even though it should still be under warranty. Fact is the last guy would have returned/replaced it anyway had he had this problem so google/asus aren't losing anything surely?

    Any help or tips would be hugely appreciated. I don't have the money to just chuck it.
  21. lancsman

    lancsman New Member

    Llike mnay others here I have had the dredded 'Nexus 7 die' problems.

    Bought this two weeks ago - all fine etc until last week when total failure - whilst doing nothing more strenuous than reading a book. Battery was not low. 30 sec reboot did not work - and tablet would not charge.

    Contacted retailer on my return home this morning - they had me try the 30 sec re-set again - no success - then immediately offered a collect / replace service - with delivery tomorrow (within 24 hours).
    I am impressed with their service.

    My only question ?
    Will I have problems recovering apps / books etc that were loaded to the 'old' Nexus 7 - or should all magically re-appear when I set my new Nexus 7 to my Google account etc ????

    I still have some of my Google Play voucher to use up - Will that also be auto updated to the new tablet ???

    Regards
    John
  22. Fred G. Vader

    Fred G. Vader Well-Known Member

    In my unprofessional-average-guy opinion, this sounds very much like the problem a lot of us have experienced with our ASUS Transformers which leads me to believe that it's something caused in ASUS manufacturing/engineering process. Sad to say but if I had to do it all over again I would never have gotten the Transformer. Would probably go with a Samsung model or even the tablet-that-must-not-be-named. But never again with ASUS, I've learned my lesson.
  23. Teknologic

    Teknologic Well-Known Member

    Sounds like you're charging at the speed of usb. When it's charging, check your battery stats: does it say charging (AC). If it says usb, while you're using your charger, the charger is most likely the issue. It's actually the most likely issue in any case. Try finding an usb charger with 2A output and use it with your original cable.
    As long as you didn't disable backups or background data and have had a network connection recently, everything should be backed up and magically pop back up when you log back in, it'll take a few minutes tho, depending on how many apps and your connection speed. Same with your credit, it's linked to your Google account.
  24. 1969bob

    1969bob Member

    Hello Users: I just sold my android tablet and was thinking to buy

    a NEXUS 7 BUT with all the problems of the battery should I ??

    BUT with all of you users around I have support no?

    If you all had to do over would it be NEXUS 7?

    Bob
  25. madesina

    madesina New Member

    You just need to long press the power button. You need to do it for like 20-30 seconds and it'll just turn on. I did it while on charge. Was really scared, coz mine had been working so perfectly up until then! *phew!*

Share This Page