Nexus 7 wifi dropping after sleep and not reconnectingGeneral

Last Updated:

  1. Sheshnag

    Sheshnag Well-Known Member

    I use Orange router and have updated my Nexus 7 to 4.2. Since the update every time I put the device to sleep it does not connect to the router on wake. I have to manually turn the WiFi off and back on again. It seems to work fine after this. I am using a magnetic case. Searching the net this does not seem to be a common problem. Is anyone else having this problem? Is there any solution?

  2. PowerBomb

    PowerBomb Well-Known Member

    Used to happen to me sometimes. I just decided to set the Wifi to not turn off during sleep and found that the battery does not suffer much. My Nexus is sitting in my bedroom going on 7 days of being powered up and Wifi turned on and it's still going.

    Edit: Scratch that. It's at 8 days 11 hours. Wifi signal was strong as soon as I turned the screen on.
  3. GeoUSA

    GeoUSA Well-Known Member

    I was experiencing this after the 4.2 upgrade as well. Learned that running the Juice Defender app was part of the problem with 4.2. Disabling Juice Defender solved the issue for me.
  4. Sheshnag

    Sheshnag Well-Known Member

    Not using juice defender so I am sure that is not the problem. I will try the WIFI not off during sleep option but I am not sure it will solve my problem completely. I have the issue when I take the Nexus 7 out of my home. It struggles to connect to my home wifi when I am back.

    Thank you for your suggestions. This is the problem I have with Google products. When you need help their customer service is non existent. i have to rely on help from kind souls like you.

Share This Page