Nexus 7 won't chargeSupport


  1. paulinho

    paulinho New Member

    First time poster here and i can't see a previous thread that has the same problem as i have.

    My Nexus 7 is about 2 months old and not had a single problem. Until yesterday. It powered down (battery was low) and i couldn't turn it back on. Tried the power down and volume button tip, but nothing.

    This evening i plugged it into the mains charger for a couple of hours, then held down the power button for 20seconds or so and it booted up as normal.

    It appears to work as normal, BUT the battery charge indicator reads 0 % and as i type it's been plugged into the mains power for over 4 hrs and it still reads 0 %.

    It's working exactly as it should do, but just won't charge.

    Any advise or tips?

    Thanks.

    Advertisement
    :
  2. Metroid Prime

    Metroid Prime Oil Can!!! Oil Can!!! VIP Member

    I was reading though a thread similar to this and have read you should never run the battery down all the way. Try a different USB power source and see if it's drawing power. And if you check the USB device in the device manager you can see how much current the port is drawing.
  3. lucky013

    lucky013 Well-Known Member

    Might be time for reset.
  4. The12thDoctor

    The12thDoctor Well-Known Member

    This has happened to me before. Just keep switching it on and letting it shut down. Eventually it will display the charging symbol. Usually only takes 2 or 3 goes.
  5. paulinho

    paulinho New Member

    sorted it. Tried 3 different charging devices all to no avail.

    Did a bit of net surfing, and took the back off and found the battery push in terminals weren't fully pushed in. When i pushed it back in, and turned it back on i found the battery was indeed fully charged (not a surprise after all the time it's been plugged in).

    I've let it discharge to 95% and then charged up again, so all works fine.

    Thanks.
Loading...

Share This Page