Nexus S: Wifi problem (WPA2, AES, PEAP)Support


  1. RatZ85

    RatZ85 New Member

    Hi all,

    I'm new to this forum, so sorry if this question is already answered somewhere else.

    I recently bought a Samsung Nexus S phone but I'm having troubles connecting to the wireless network at work.
    - Security type: WPA2-Enterprise
    - Encryption type: AES
    - Authentication Method (PEAP), with EAP-MSCHAP v2 authentication method

    Can't seem to find how to bring all these settings together on my phone, already tried the available options, it always says i'm connected, and i receive an ip addres. But it's not working and i'm not able to connect to the internet.

    Kind regards,

    Advertisement
    :
  2. mingo-jones

    mingo-jones New Member

  3. RatZ85

    RatZ85 New Member

    Anyone ? :)
  4. bfksc

    bfksc Well-Known Member

    I have bad news and good news.

    The bad news is by default it doesn't use WPA2-Enterprise, just Personal and some other configurations.

    The good news is you can probably enable it by turning on Secure storage. Go into Settings, Location & Security, scroll down and set a password for credential storage - any 8 character password you can remember will do for now. Once enabled, try connecting to the WiFi network again and it should download the certificate you need automatically. That should be it, and just fill in the settings as needed.

    If not, you can enable it by using a secure certificate from the network and transfering it to your USB storage. You will need to get the certificate from your work IT staff since it contains settings info for your phone's WiFi software. You then go into the Location & security settings, Install from USB storage, then you can enable the secure credentials feature and enable/adjust more settings. Just call the IT staff and explain that you need your Android phone to connect to the network and they should know what you need. If not, explain about the secure certificate and they should get it then.
    :)
  5. slapy

    slapy New Member

    Hi... I need help on the procedure to install the certificate, it is a .cer file and I don't know how to install it in my Nexus S phone. When I connect the phone to the computer using the USB cable I have the option to enable USB storage, using that option I copied the file under the root of my SD Card, exactly at /mnt/sdcard. When I go to the Location & security settings, Install from USB storage it says that there is no certificate in the USB storage... Need HELP :confused:
  6. shad0wboss

    shad0wboss Well-Known Member

    i have a similar problem. My internet is WPA based but it is not shown in the list at all...i have tried connecting to it manually...but it is not working as well please help me out in this one
Loading...

Share This Page