Nexus S wont mount to my PC!Support


Last Updated: 2012-08-07 12:45:18
  1. Qasim2143214

    Qasim2143214 Member

    Hello, I'm Qasim. My nexus S used to mount perfectly but now I plug it in to my computer and it doesnt have the icons in the notifications bar, the computer isn't identifying it, and I am really getting iritated. Does anyone know the problem? USB Debugging = enabled, Ive restarted multiple times in result of nothing.

    Advertisement
  2. Qasim2143214

    Qasim2143214 Member

    Just figured out that when I restarted, it shows in the notification "USB" and it says "Checking for errors." Nothing happens when clicked. It is there for like 5 seconds then it goes away
  3. bfksc

    bfksc Well-Known Member

    FYI - You don't need USB Debugging enabled, that's for developers. By default the Nexus S will pop up a window whenever it's connected to a computer asking if you want to enable USB. If that doesn't pop up, then it's not recognizing the presence of a computer on the other end of the cable.

    Do you have another USB cable to check to make sure it's not a defective cable?
  4. Qasim2143214

    Qasim2143214 Member

    When its plugged it, the android says it is charging, can it still be defective. I only have the blackberry chargers, I know those will fit but is it okay if I use them?
  5. bfksc

    bfksc Well-Known Member

    Yes, because USB support and charging are on separate pins in the port.
    Yes, you can use them to charge the device. But you may not be able to use them for data connections to the computer.

    Where is the cable that came with the phone?

    :confused: :confused: :confused:
  6. Qasim2143214

    Qasim2143214 Member

    That is the one that wont work, the one that came with my phone is the one im using to charge my phone and attempting to mount.
  7. Qasim2143214

    Qasim2143214 Member

    After further research, the front USB ports on my PC seem to be defective. I'm going to have to open it up and rewire with new usb ports.
  8. Dan1113

    Dan1113 Well-Known Member

    This happens to be quite often...but eventually on the 20th or 30th plug in it recognises it. :\
  9. quantumrand

    quantumrand Well-Known Member

    That sounds like a defective USB cable or port. See if you can't try using a different cable and/or different ports on your PC. If that doesn't work, it's likely the port on your phone. Be careful plugging and unplugging it over and over, as this will damage it further, eventually to the point that it will no longer even charge.
  10. F22_RaptoR

    F22_RaptoR Active Member

    It seems to take mine a second once I unlock the screen to 'notice' its plugged in, FYI I use the same USB as my motorola Xoom. Then the option for USB storage comes up.

    ETA

    Oops, forgot to add: Try another cable maybe? Micro USB's are not all that uncommon these days. You can also maybe try another USB on your computer?
  11. larryg

    larryg New Member

    My Nexus S 4g has been working properly with my work PC (Windows 7)...until last Thursday. I've been using CompanionLink to sync, but the PC delivers an error message when I connect my phone, saying "USB Device Not Recognized." I've switched cables, and I've tried connecting to two Windows 7 PCs at home...same problem. The phone will charge, but it isn't available as a USB drive and I can't sync. Could this be related to the Google upgrade that rolled out about this time last week? I've done all the obvious things...rebooted the PC, removed the battery from the phone, replaced the battery with a new one. Our IT manager is puzzled...first time I've ever seen him stumped. I can't sync with Outlook using Exchange...can't do that with a personal phone due to corporate security, so that option is out. I don't want to wipe my phone, but will do as a last resort if someone knows that will work.
  12. quantumrand

    quantumrand Well-Known Member


    Have you tried a different cable? Mine did this exact same thing. It turned out to be a defective USB port on the phone and I had to warrenty it off to Samsung because it took about a month before it started acting up. It eventually got to the point that it didn't even charge anymore.
  13. larryg

    larryg New Member

    Took my phone to Sprint this morning and the tech rep used some denatured alcohol to clean the USB port. Phone mounted properly so I'm anxious to try it Monday on my work PC.
  14. hi-tech34

    hi-tech34 Active Member

    Let me know if that worked. I have a nexux s 4g and have the same issue. I did the reset yesterday and it did not solve the problem. Now I don't know what to do next. Sprint Tech support could not fix it and wanted me to do a reset forst and then will exchange the phone??

    I just cleaned mine and it did not help?
  15. larryg

    larryg New Member

    Cleaning the USB port didn't solve the problem permanently so Sprint replaced the phone yesterday. Tech rep decided the port was defective and I had insurance...for the first time.
  16. hi-tech34

    hi-tech34 Active Member

    That is what they wanted to do to mine but they wouldn't guarantee it would not happen again as the ytold me this is a known issue and they do not have a fix for it yet. Di you get a new phone or a refurb? I was told I would get a refurb.
  17. larryg

    larryg New Member

    I got a new phone...maybe due in having insurance, maybe due to being a very long-time Sprint customer and knowing the people in the store near my home. I would not have accepted a refurb.
  18. RavenFox

    RavenFox VIP Member VIP Member

    My new Nexus S for AT&T mounted perfectly and instantly on Windows 7 64bit without a hitch. Not using Kies. Maybe something was updated in the firmware of the phone on this model.
  19. lackscr8ivity

    lackscr8ivity New Member

    "Seems that the driver didn't automagically install the first time I plugged the phone in."

    Phone: Nexus S 4G
    Carrier: Sprint
    Computer Make: Asus
    Model: UL30A Series
    Type: 64-bit Operating system
    OS: Windows 7, SP1

    1. When I plugged in the USB to my computer, the phone would charge, and the notification bar would briefly show the USB icon and then it would disappear.
    2. Phone didn't prompt me to turn on USB storage, but I could turn on tethering and would have network access. The phone did not appear as a storage device on my PC.
    3. I plugged it into another laptop and it worked perfectly.
    4. Plugged it back into my PC, tried all the different USB ports with no luck.
    5. Checked Start > Devices & Printers. The Nexus S appeared as a generic device at the bottom. Right click icon and select "Properties" and the info was mostly greyed out. Select "Hardware" tab and then "Properties".
    6. In new Properties window, selected "Driver" and then "Update Driver" and then "Search automatically..."
    7. It found the driver, updated, and then the phone's USB storage mounted correctly. Seems that the driver didn't automagically install the first time I plugged the phone in.

    HTH
  20. frillyozz

    frillyozz Member

    I used to have a Nexus S 4G, but none the less I have had this same problem with my current G2x. I have to basically re-enable to the USB Mass Storage option on my settings to get it to work. This Android video demonstrates how to do this.

    Good luck mate!
    dmanlee likes this.
  21. hi-tech34

    hi-tech34 Active Member

    There is not that option in the video on the nexux s in the settings
  22. TD/TS-2479

    TD/TS-2479 Member

    will my Nexus S work with my Mac computer when I plug in it's USB lead?
  23. edread

    edread Member

    I try to search automatically and it says it can not find the drivers. Where can I find the driver? Just need my phone to plug and play into my computer and got a new Nexus S from Sprint and still having same issues. Please help.
  24. hi-tech34

    hi-tech34 Active Member

    I solved my problem the other day. Look in the USB port on the phone and there is a flat part that should be in the middle so it goes inside the usb plug. Mine was bent and was missing the plug but when I bent it back with a little pocket knife it has been working flawlessly ever since!!
  25. Xappy

    Xappy New Member

    Figured I'd register after google sent me to this thread - nothing worked, till I did this.. scary stuff!
    talk about a design flaw...

Share This Page