Nexus S won't recognize Telus sim

Discussion in 'Android Devices' started by ViceAvaritia, Sep 12, 2011.

  1. ViceAvaritia

    ViceAvaritia New Member
    5

    Sep 12, 2011
    1
    0
    5
    Hey Forum,

    I just bought a Nexus S yesterday and was totally stoked to use it. Unfortunately when I popped my Telus Sim card in it didn't recognize it and stayed on Emergency Only mode. My Nexus S SHOULD function on Telus' network as it is a I9020A model. When I go to the Settings>Wireless and network settings>Mobile networks>Network operators I unfortunately do not see Telus as an option I only see Rogers and 302610(Bell). Oddly enough I do see telus' MNC (302220) as an option but when i tap it it says it can't connect. I tried popping in my friends Bell sim card and it worked fine, a rogers sim card worked as well. I tried putting my sisters sim card in my phone and it didn't read it either, yet my sim seemed to work in her phone. I have no idea whats wrong with this phone. Am I doing something wrong?

    Thanks a lot,

    Vice.
     

    Advertisement
  2. quantumrand

    quantumrand Well-Known Member
    143

    Sep 2, 2009
    1,237
    198
    143
    It's possible your SIM card is too old. Has it been a while since you've gotten a new SIM? Try getting a hold of Telus and asking for a new one (it should be free).
     
  3. vikingisson

    vikingisson Well-Known Member
    73

    You might need to manually enter the APN one time. Worked for me.
     
  4. RavenFox

    RavenFox VIP Member
    VIP Member
    43

    Jul 30, 2010
    342
    30
    43
    I.T
    Westchester, NY
    Are you saying your sister also owns a Nexus S?
     
Tags:

Share This Page

Loading...