NH: Wireless Issues. Android 2.2 on SmartQ7


Last Updated:

  1. JozeyBeenz

    JozeyBeenz New Member This Topic's Starter

    Joined:
    Jul 16, 2010
    Messages:
    2
    Likes Received:
    0
    Hi all.

    Just recently flashed my SmartQ with Android 2.2, and it's perfect.

    Well almost.

    Im having some major issues getting a stable wireless connection. I have tried every concieveable configuration, through software and hardware, with no luck. Testing has been done on my network at home, on two seperate networks. I am yet to try external networks or hotspots.

    The device will find a network, but has a hard time creating a connection. If the connection is not made, it will try again. Sometimes it wont, and just hangs in scan mode. More often than not, it will lose sight of the network altogether.

    I have only had a few successful connections, but they all dropped out, ranging from 30 seconds to half an hour connection time.

    This has to be something to do with Android, as the device itself runs perfect wireless connections with the factory firmware, and all other devices in my home connect/operate with no fuss.

    I have searched high and low for a definative answer on this issue, but couldnt find anything conclusive. I have found many threads regarding wireless issues on handsets, but nothing specific to the 2.2 release or this particular device.

    Ill keep searching, but in the meantime, if anyone can shed some light on this, it would be an enormous help.

    Cheers. Joe.
     

    Advertisement
  2. JozeyBeenz

    JozeyBeenz New Member This Topic's Starter

    Joined:
    Jul 16, 2010
    Messages:
    2
    Likes Received:
    0
    I ended up solving this solution myself.

    I reset my router to factory default and made 2 changes that I havent tried.

    First, I changed the wireless channel from the default 6, to 10.
    I figured that it may be getting some cross-talk from the other router in my house, or my nieghbours router, therefore confusing the SmartQ.

    I left the security as default (non-secured) but activated MAC filtering. I denied network access from any MAC except for the one on my SmartQ and my computer. The idea was to avoid using security measures like PSK's in case the SmartQ/Android had compatibilty issues with these policies.

    I rebooted the router and tried. It worked flawlessly, every time.
    Problem solved [​IMG]

    I have since just turned off MAC filtering and re-instated WPA-PSK.
    It still works perfectly.

    It seems it must of just been interferance from another router.

    Hopefully this bit of info can help anyone with the same situation.
     
  3. dmaxo

    dmaxo New Member

    Joined:
    Aug 22, 2010
    Messages:
    1
    Likes Received:
    0
    does anyone know where to download android 2.2 for smartQ7? Thanks.
     

Share This Page

Loading...