Nightly crashes on Nexus S


  1. rhapsodyindrew

    rhapsodyindrew New Member

    Hi all,

    My Sprint Nexus S 4G has been crashing frequently for the past 2+ weeks. The phone crashes consistently if left on overnight - alarms don't work and when I wake up the screen is usually blank (but still on) and the capacitive buttons below the screen are glowing. Nothing is responsive and I have to remove the battery to reboot, at which point a second crash often occurs, including the "dead android with red triangle" sign being displayed on the screen. (Occasionally the overnight crash will show a dim version of my home screen, instead of being completely blank.) Also, the phone sometimes goes abruptly to the dead android screen during the day.

    I performed a factory data reset via the Settings menu, but that didn't help with the problem. I also recently had Sprint factory-flash the phone, also to no avail. I didn't install any new apps or take any other action around the time that the crashes began, so I don't know what could have happened. The only thing I've noticed is that crashes tend to take place after longer periods of inactivity (like being left on overnight).

    Does anyone know what is going on? Any ideas on how to fix this? I don't carry insurance on my phone, and I can't currently afford to be without a phone for the 3 weeks Samsung says it may take to get it back. (I could always go to Samsung later, but I thought I should ask the geniuses here first.)

    Many thanks for any advice! My relevant phone details are below.

    Best,
    - Drew

    Model number:
    Nexus S 4G

    Android version:
    4.0.4

    Baseband version:
    D720SPRLC1

    Kernel version:
    3.0.8-g6656123
    android-build@vpbs1 #1
    Thu Feb 2 16:56:02 PST 2012

    Build number:
    IMM76D

    Advertisement
  2. CrisKenyon

    CrisKenyon Member

    I've been having the exact same problem...and in the exact same timeframe. I'm bumping this in hopes that someone can help.

    Edit. I have a Nexus S now. haven't been on these forums in a while.
  3. taylorford82

    taylorford82 New Member

    Ladies and Gentleman,
    My wife and I both have the Nexus S. Her phone recently started having the EXACT same issue with her phone! Same way, same time, same!! Did anyone find a resolution to this problem??

    Thanks!
  4. rhapsodyindrew

    rhapsodyindrew New Member

    I worked hard on this for more than a month, and here's what I found. Following the directions on "How to Unroot Nexus S 4G!" from nexusshacks.com, I flashed the original, stock 2.3.4 Android ROMs back onto the phone. I found that everything worked fine under 2.3.4, but as soon as I installed the OTA 4.0.4 update, all the previous problems returned.

    I went through the stock flash-update apps-OTA OS update process carefully, three times, over the course of many days, and pinpointed the OTA update as the point where everything screwed up.

    After running 2.3.4 for a couple weeks, and dismissing the popup asking me to update to 4.0.4 repeatedly, I decided I was unwilling to live as effectively a second-class citizen, and arranged to return my phone to Samsung for repair. (I updated to 4.0.4, experienced the crashes, called Samsung and walked through the hard reset process, and when that didn't work, they issued an RMA.)

    Samsung still has my phone, so I'll update when I get it back and see if they've fixed the problem. I don't know what it could possibly be, given that 2.3.4 works perfectly, but a friend suggested that maybe there is some RAM issue and 4.0.4 addresses RAM differently? I don't know. Fingers crossed on the repair though. D

Share This Page