1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Nmap for android


Last Updated:

  1. pasxal

    pasxal Well-Known Member This Topic's Starter

    Joined:
    Nov 2, 2009
    Messages:
    47
    Likes Received:
    0
    Yesterday i was trying to make nmap work in my galaxy. I forgot my laptop at home so i to make some research from my phone. I found a how to here but i have an issue after trying to use it. It says

    unable to find nmap-services! Resorting to /etc/services

    unable to open /etc/services for reading service information

    Any experience on that thing?

    Here is the link

    http://androidforums.com/android-applications/46499-nmap-android-cross-compile-arm.html
     

    Advertisement
  2. Andronix

    Andronix Well-Known Member

    Joined:
    Aug 31, 2009
    Messages:
    676
    Likes Received:
    16
    Tried copying 'services' file from any linux distro?
     
  3. pasxal

    pasxal Well-Known Member This Topic's Starter

    Joined:
    Nov 2, 2009
    Messages:
    47
    Likes Received:
    0
    Yes i tried and didn't worked. Then I thought it was a permission problem and tried to change permissions but didn't work either.
     
  4. Andronix

    Andronix Well-Known Member

    Joined:
    Aug 31, 2009
    Messages:
    676
    Likes Received:
    16
  5. pozer69

    pozer69 New Member

    Joined:
    Apr 23, 2010
    Messages:
    3
    Likes Received:
    0
    I hate to bring up an old post but I am trying to do this on my Incredible and I am receiving the same errors.

    Did you ever get this to work?
     
  6. velnaykkar

    velnaykkar Member

    Joined:
    Jun 25, 2010
    Messages:
    13
    Likes Received:
    1
    nmap from the above mentioned link works fine for me (Galaxy running GAOSP-Froyo nightly build).
    Here is what i did:
    Download nmap: http://rmccurdy.com/stuff/G1/BINS/NMAP/NMAP.zip
    connect phone to pc
    adb remount
    adb push nmap.zip /sdcard/nmap.zip
    adb shell (following on shell)
    su
    cd /data/local
    mkdir bin
    cd bin
    cp /sdcard/nmap.zip .
    unzip nmap.zip
    chmod 755 *

    after that run nmap. (nmap -v -iR 5 -PN -p 80 -n)

    nmap-services is available in the zip file. I guess we have to be in the directory that has nmap binary and nmap-services file.
     
  7. Fatman_UK

    Fatman_UK New Member

    Joined:
    Aug 6, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks velnaykkar!

    Or you could remount the filesystem as read-write:

    Code (Text):
    1. # mount -o remount,rw /dev/block/mtdblock3
    2. # mount | grep mtdblock3
    3. /dev/block/mtdblock3 on /system type yaffs2 (rw,relatime)
    Copy the file to /etc/services:

    Code (Text):
    1. # cp /data/local/bin/nmap-services /etc/services
    And happily use nmap from any dir. :)

    Code (Text):
    1. # pwd
    2. /
    3. # nmap 127.0.0.1
    4.  
    5. Starting Nmap 4.01 ( http://www.insecure.org/nmap/ ) at 2010-08-06 12:49 UTC
    6. Unable to find nmap-services!  Resorting to /etc/services
    7. All 1672 scanned ports on localhost (127.0.0.1) are: closed
    8.  
    9. Nmap finished: 1 IP address (1 host up) scanned in 4.569 seconds
    Don't forget to remount as read-only. Just in case a nasty comes along.
     
  8. operat0r

    operat0r Member

    Joined:
    Sep 21, 2009
    Messages:
    9
    Likes Received:
    0
  9. operat0r

    operat0r Member

    Joined:
    Sep 21, 2009
    Messages:
    9
    Likes Received:
    0
    Index of /nmap/src I was first I know of to get nmap working on android but hes all bout it now ... my next step is MSF3 / autopwn on android :)
     
  10. Jamie Jackson

    Jamie Jackson New Member

    Joined:
    Aug 25, 2011
    Messages:
    1
    Likes Received:
    0
    Hi operat0r,

    I'm confused about the above. If I run the wget/bash sequence above, will I get your outmoded version, or WJ Holden's "Nmap for Android."

    If the sequence gives provides your deprecated version, would you mind explaining how to install the good one via what's available in Index of /nmap/src?

    Thanks,
    Jamie
     

Share This Page

Loading...