Root No ADB after flashing CyanogenMOD 7

Discussion in 'Android Devices' started by NetSpeedZ, Jun 13, 2012.

  1. NetSpeedZ

    NetSpeedZ Well-Known Member
    Contributor
    43

    Apr 3, 2012
    440
    31
    43
    Male
    IT Engineer
    Southwest
    After flashing CyanogenMod 7 on a Huawei Ascend M860, I'm unable to use ADB. Before flashing, everything was good (rooted as well). Now when performing an 'ADB devices', ADB reports back that the device is 'offline'.

    Any assistance would be appreciated.
     

    Advertisement
  2. reggjoo

    reggjoo Well-Known Member
    38

    Jan 25, 2011
    229
    19
    38
    Male
    Pgh
    Same problem, is it playfulgod's cm7.2 rom, or another one? I had cm6 running, and it worked perfectly(SDK, Eclipse,command promp), switched to cm7.2, now every time I plug my phone up, my computer wants to install my phone?? Nothing was changed with my computer setup, and the regular mounting works, no adb interface, just android mobile adapter(with yellow ? mark), and Android Adapter USB Interface, in the disk drives section. Downloaded every Usb driver I could find, deleted all, but one, rinse , repeat, no luck. Changed usb files, put the huawei id"s in, damm, no luck. Went into the build_prop file, added info, damm. I'm using XP32 bit, if the rom didn't make my phone run so good, I would have reverted back to cm6.
     
  3. reggjoo

    reggjoo Well-Known Member
    38

    Jan 25, 2011
    229
    19
    38
    Male
    Pgh
    The only thing I did diffrently, was to open the rom up, remove ADWlauncher, replace it with with GoLauncher, before I installed it. I used winzip, and QtADB(GUI) to perform that. THE rom installed fine, and everything works.
     
  4. reggjoo

    reggjoo Well-Known Member
    38

    Jan 25, 2011
    229
    19
    38
    Male
    Pgh
    I noticed that after switching to ubuntu, that there's something missing, some identifier, that tells the comp's os, that it can't recognize the phone. In recovery, adb recognizes it as "recovery" , but adb works, as long as system, data, usb storage, and cache are mounted. I thought it was the usb driver, in windows, but that's not the case.
     
  5. reggjoo

    reggjoo Well-Known Member
    38

    Jan 25, 2011
    229
    19
    38
    Male
    Pgh
    Well whatever the reason, the problem was fixed in Ubuntu. Created a file in root, 51 android rules, and it's all working, except it still doesn't see the serial number, or bootloader, but can access all again.
     

Share This Page

Loading...