No caller ID shown on phoneSupport


  1. clairem82

    clairem82 New Member

    When a caller who is not in my contacts phones, the phone displays unknown.
    I am unable then to trace back who has actually phoned me.
    Is there any way that I can activate caller Id on my phone so that all incoming calls display the number of the caller.

    Advertisement
  2. socrates0

    socrates0 Well-Known Member

    Go to Settings->Call Settings->Additional Settings->Caller Id & select Network Default you should get the incoming number displayed, if not then check with service provider else could be a phone problem.
  3. GrahamF

    GrahamF Well-Known Member

    Hi, the ACE does display the caller ID, if yours isn't then it is a service provider matter. Or the caller is actually blocking their number!! Make sure your provider has enabled the caller ID service if it isn't standard. Obvious question - Have you tried calling your phone from a number you know isn't blocked to see if it shows up? Hope this helps. Graham - London :hmmmm2:

Share This Page