General NO connection to internet when connected to wifi?

Discussion in 'Android Devices' started by bmwhartgeM3, Apr 18, 2010.

  1. bmwhartgeM3

    bmwhartgeM3 Active Member
    18

    Mar 10, 2010
    39
    10
    18
    I have 3bars of service for wifi strengh and when I try to go to the market place, or even the internet, I cant connect? I've tried switching with mobile data on and off and same thing happens. I have no problem getting on line with digital coverage tho.
     

    Advertisement
  2. graphitedv

    graphitedv Well-Known Member
    18

    Dec 5, 2009
    88
    24
    18
    Chicago
    Sounds like the router may be the issue. Delete the connection and try to add it again.
     
  3. smacky

    0

    Jan 11, 2010
    2,844
    299
    0
    Do you own a Hartge M3 or is it your dream car or something?
     
  4. erisuser1

    erisuser1 Well-Known Member
    223

    Nov 11, 2009
    1,644
    759
    223
    Yes, you should be able to connect to the internet - something is wrong (assuming that the wireless router itself is correctly configured and is itself "connected to the internet")

    This may be a bit of a long shot, but I'll throw it out there because the router in question is very common:

    If you are using a Linksys WRT54G router with older firmware, and you have it configured for WPA PSK(AES), your Eris will give exactly the symptoms you describe: it can connect to the router, but nothing more.

    See this Google bug report

    I recently ran into this, and updating to the most recent release of firmware resolved the problem (Note: do not, under any circumstance, use Safari to apply firmware updates to Linksys routers - if you have a Mac, download and use Firefox for this, or read up on how to use "TFTP" on a Mac to do the same job.)

    It is possible that this doesn't apply to you - you didn't supply any specific details of the setup which is giving you problems.

    eu1
     

Share This Page

Loading...