Support No data - UK Vodafone N1

Discussion in 'Android Devices' started by hunta, Jun 30, 2010.

  1. hunta

    hunta Well-Known Member
    36

    Jan 20, 2010
    104
    5
    36
    My N1's been working perfectly since I bought it from Google in January... until today.

    I have a good signal and can make / receive voice calls and texts. However, I'm not getting any data and no 3G / 2G etc. icon is showing on the bar next to the signal strength icon. I've tried going in and out of airplane mode, going to 2G only, rebooting, removing battery and reseating the SIM and SD cards.

    Vodafone have confirmed there's no issue on their side (other Vodafone users nearby have aren't having problems) and have even swapped my SIM with no effect. I phoned the HTC help line (very quick and helpful BTW), who tried setting up a new manually defined APN. Nothing's worked.

    Next step is to try a factory reset, but before I do, any suggestions? (This is under 2.1, ERE27.)
     

    Advertisement

  2. Rusty

    Rusty Well-Known Member
    143

    Jan 21, 2010
    1,635
    192
    143
    Pompey, UK
    As you're on ERE27, give FRF85B a try, can't hurt.

    You've not done anything silly like installed APNDroid and accidentally disabled data have you?
     
  3. justdoit

    justdoit Well-Known Member
    16

    Feb 8, 2010
    82
    5
    16
    Try hitting reset to default in Access point Names by going into it and pressing the menu hard key on the bottom of the screen, this worked for me on o2.
     
    hunta likes this.
  4. hunta

    hunta Well-Known Member
    36

    Jan 20, 2010
    104
    5
    36
    Thanks for the responses.

    I decided not to upgrade manually to FroYo. I wanted to keep the number of variables as low as possible, plus if it was going to come down to sending the phone to HTC I didn't want any question marks at all over the warranty.

    A factory reset cured the problem. Unfortunately though I didn't see justdoit's tip before I did it!
     
Tags:

Share This Page

Loading...