No ear-speaker sound


Last Updated:

  1. Armadill

    Armadill New Member This Topic's Starter

    Joined:
    Feb 16, 2010
    Messages:
    3
    Likes Received:
    0
    I'm having problems with the ear-speaker of my HTC Hero. It has been working great for near 4 months now then out of nowhere the ear-speaker stopped working yesterday. Whenever I try to make or receive a call I cannot hear the other person speaking. If I switch to speaker or headset then I can hear them just fine, but if I try to use the ear-speaker there's nothing.

    Anyone got any bright ideas on what's wrong/how to fix it?

    I have the newest firmware (2.73) and it's not rooted or anything else.
     

    Advertisement
  2. jimeller

    jimeller Well-Known Member

    Joined:
    Aug 6, 2009
    Messages:
    409
    Likes Received:
    23
    Have you tried adjusting the volume when speaking on the phone. It's the same button, but different function than ringer volume.
     
  3. Armadill

    Armadill New Member This Topic's Starter

    Joined:
    Feb 16, 2010
    Messages:
    3
    Likes Received:
    0
    Yes, I've tried that and it didn't do anything.

    There's a small update though.

    The sound just came back on miraculously a moment ago. Strange thing is the phone did the exact same thing yesterday. I tried calling a number several times and couldn't hear a thing, put down my Hero, called from my girlfriends phone to check nothing was wrong with the number I was calling to, took my Hero and tried again and this time there was sound without me apparently doing anything.

    Same thing just happened. I have been trying to get the sound working for about an hour and then after I gave up and were backing up my settings to do a reset it started working without me doing anything since I last checked there were no sound... this is weird!

    So it seems it's solved for now, but if anyone have any ideas of what it could and how to handle it be please give it a go as I will no doubt run into it again soon.
     
  4. Armadill

    Armadill New Member This Topic's Starter

    Joined:
    Feb 16, 2010
    Messages:
    3
    Likes Received:
    0
    Small update:

    Sound gone again on the ear-speaker. Contacted HTC support and they suggested a factory reset. Tried it and it didn't bring the sound back. Might be a loose connection in the ear-speaker?

    When the sound was on there was no noise or anything implying the speaker was broken or about to (if that is indeed what has happened).
     
  5. cespen

    cespen New Member

    Joined:
    Mar 15, 2010
    Messages:
    1
    Likes Received:
    0
    I have the exact same problem. Sometimes the ear speaker works but most of the time it doesn't. Restarting the phone or doing a factory reset sometimes gets the speaker to work but mostly it stops working again after an hour or so. I guess there's nothing left to try but to send it in under warranty. Have you solved the problem in any other way?
     
  6. daveybaby

    daveybaby Well-Known Member

    Joined:
    Sep 21, 2009
    Messages:
    919
    Likes Received:
    105
    Hmmmm.... there have been people with the opposite problem: cant get headphones to work - sound remains routed through speaker when phones are plugged in. Basically the audio routing is done via software and sometimes this fails (or the hardware that detects the headphones are inserted has failed).

    There is an app on the market which fixes this: i.e. a toggle that forces audio out of either the headphones or the speaker. There's a paid one here (couldve sworn there was a free one somewhere too, but you could always get a refund on this if it doesnt work).

    Try that app, see if you can force it to route audio through the speaker.
     
  7. teddypepper52

    teddypepper52 New Member

    Joined:
    Apr 2, 2010
    Messages:
    2
    Likes Received:
    0
    I am also having this problem.

    Randomly all sound will stop working, and apparently my mic to, and the only way I've found to fix it is a power cycle. And this only works half the time, and the problem usually comes back within the hour.

    basically...
    My phone will be on loud and someone will call, and it wont ring, just vibrate, then when I pick it up I hear nothing. Or I could call someone, and it connects, but I never even hear it ring, just silence until I hang up or they do.Testing it out with another phone I found that the person on the other end hears nothing from me, indicating the mic stops working too.

    If it matters, I have a Sprint "w/ google" Hero, rooted, running DamageControl v2.05 from XDA, and while I have experienced this intermittently (about once a week) for a while, It is not until the last 24 hours that it has gotten like this. No one else on the ROM is reporting issues like this. And i tried ToggleHeadset, didnt work.

    Any information would be appreciated.
     
  8. teddypepper52

    teddypepper52 New Member

    Joined:
    Apr 2, 2010
    Messages:
    2
    Likes Received:
    0
  9. codestripper

    codestripper New Member

    Joined:
    Jan 18, 2011
    Messages:
    1
    Likes Received:
    0
  10. SrinivasanK

    SrinivasanK New Member

    Joined:
    Oct 5, 2011
    Messages:
    1
    Likes Received:
    0
    Hi,

    I am using SE Xperia Arc for last 6 months, me too experiencing the same problem for last 2 days.
    Seems like android platform have this issue. (gonna install toggleheadset2 hope it will works)

    Thanks,
    SriniK
     

Share This Page

Loading...