No ETA on Root for Hydro


  1. J6Remy

    J6Remy Well-Known Member

    After extensive research and consulting with some Devs, it seems that the hydro does not have any hope for root as of now, nor is there any kind of expected time when or if we will be able to achieve it. shabby said, "its sig checking kernel and recovery at boot aka until you bypass it you arent getting a custom kernel or recovery. no fastboot, no root, nada. Until the next big android exploit comes out (think rageagainstthecage, or gingerbreak, or even zergrush...) there is not going to be much in the root department."

    Just posting as a forewarning to potential buyers about the rooting situation.

    Advertisement
    :
  2. LEVERage

    LEVERage Well-Known Member

    Well that's a bummer, but man made it, man can hack it, I've got faith in these guys.

    But in the meantime, to potential buyers, don't let the lack of root (at the moment) deter you from buying this awesome phone. It's still a great deal, root would just be icing on the cake for this thing
  3. J6Remy

    J6Remy Well-Known Member

    Exactly, not having root is big deal for me, but It's not stopping me from keeping the phone. It will come eventually. I'm sure its a great phone! like I said, I'm keeping it! :D
  4. stingrays

    stingrays Well-Known Member

    It will happen. Just not sure when. Waiting on more of when Kyocera provides the source code.
  5. LEVERage

    LEVERage Well-Known Member

    I have a gut feeling that they will release it in the near future. I mean this phone runs FLAWLESS ( have any of you guys experienced problems with your devices)?

    Kyocera intended for this phone to be a hit, $130- phone with ICS c'mon, lol. I'm sure that they wanted to keep the source on lock for a while to see how big of a hit the device was and if any glitches were seen, and when everything is a-go, the flood gates will open and they will let the community have at it and improve on this platform.

    I swear I feel like I have a touchscreen Blackberry that runs Android. I don't know, maybe I'm just blowing smoke out of my ass here, but I have high hopes for this phone :)

    That is all
  6. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    perhaps my wording was unclear?

    1) kyocera never provides full source, its a broken crapfest that needs to spend a good bit of time fixing (look at the prevail/warp for ideas on how long)
    2) while the phone is booting it compares an MD5 hash in its bootloader to the boot kernel and recovery kernel, if it fails it doesnt boot. that means taking the stock stuff and unpacking it and repacking it will make your phone break let alone compiling from source.

    i dont mean to be cruel and break your dreams and hopes of this becoming the next awesome dev phone to have... its for the best you get used to how your phone works now cuz thats the way its staying

    also it doesnt matter how big of a hit it is or not, kernel source code is legally required at the launch of phone.. you can see how well that gets held up tho :/
    Lordvincent 90 likes this.
  7. stingrays

    stingrays Well-Known Member

    Broken hearted now Shabby..... I had alot of problems with loosing calls or the other person cant here me. Only issue ive had. Needles to say i reactivated my warp and stuck this hydro in my desk for a back up.
  8. Pappy62

    Pappy62 Well-Known Member

    I just tried to get the source code from Kyocera... all they gave me was a link to the code for ICS. lol
    Ah well... I hope our devs consider this a challenge. ;)
    After all - look at the iPhone...

    Devs - this is a great phone...please consider?
  9. jmz

    jmz Well-Known Member

    ladlr23, J6Remy and Pappy62 like this.
  10. Pappy62

    Pappy62 Well-Known Member

    Thank you jmz!
    Confirmed working on the Kyocera Hydro. I just did it successfully.
    I take no credit for this - all thanks to jmz above, and Bin4ry, kamistral, Team FreeXperia, et al @XDA for making this happen!

    Root for the Hydro -

    ** I AM NOT RESPONSIBLE FOR ANYTHING THAT MAY GO WRONG WITH YOUR PHONE AS A RESULT OF USING THIS. YOU ARE RESPONSIBLE FOR ANY ROOT-RELATED ACTIVITIES YOU DO TO YOUR PHONE
    It worked fine for me, but your mileage may vary, so - USE AT YOUR OWN RISK!**


    http://forum.xda-developers.com/attachment.php?attachmentid=1328668&d=1347724800

    *Download the file above.

    *Connect phone to computer, and select "Media Transfer" on the phone (go to "System", "Developer Options" and make sure "USB Debugging" is checked)

    *Run the "RunMe" file in the "Root_with_Restore_by_Bin4ry_v2_win-linux" file you just downloaded, and select "3> Other" in the on-screen prompts.

    *The phone will ask you to enter an encryption password... hit "restore my data" on the bottom of the screen on your phone.

    *Follow any further on-screen prompts, your phone will reboot, and you're Rooted!

    *NOTE*
    (Still working on a Recovery atm... I will check back and report when I have it working - BUT UNTIL THEN, BE CAUTIOUS ABOUT WHAT YOU DELETE/CHANGE - WE HAVE NO RECOVERY AS OF YET)

    Be careful, and enjoy!

    *Edit* ~
    It's probably best to wait - as stated above, we have no working recovery yet. If you add or delete something, and your phone goes nuts or you loose service, you'll be forced to do a factory reset and start from scratch all over again - IF you don't brick it altogether. Until we have a working recovery, rooting this phone should only be done by Devs and those that fully understand the risks involved, and are willing to take them while we work on getting a functional recovery.
  11. J6Remy

    J6Remy Well-Known Member

    Sweet! i feel lik im wining today
  12. jmz

    jmz Well-Known Member

    I would highly suggest not modifying /recovery or /boot. I have already tried to flash a unsecure boot.img on rise and ended up in bootloop with no way to recover. I think there may be some type of a signature check. Just thought I would put that out there. I already found the partition layout. PM me if you need any help
    J6Remy and Pappy62 like this.
  13. stgray78

    stgray78 New Member

    please send me some help im looking for a jellybean rom for my kyocera rise ive already rooted it and my galaxy nexus i put twrp's jellybean 4.1.1 on it and need one for the rise any help would be awesome
  14. Pappy62

    Pappy62 Well-Known Member

    Agreed. Without a system pull or source to work with, it's a very high probability of brickville.
  15. jmz

    jmz Well-Known Member

    Well its already happened. Lol. I pulled all partitions from device so I'm looking through it all looking for why it won't boot with a modified ramdisk. There has to be some sort of checksum. It would really help if we could find out how to get to fastboot
    Pappy62 likes this.
  16. vitokes

    vitokes Well-Known Member

    well i was trying to do this but it wont connect to my phone and it just says searching for destination. weird... maybe im doing it wrong

    edit: never mind i had to have all the files unzipped to same folder and now its working i think. im going to find out once im done.

    edit: wow it worked. i got root so now onto deleting other apps i dont like.
  17. Pappy62

    Pappy62 Well-Known Member

    Since we don't have a Recovery at the moment, I would suggest freezing apps instead of deleting them just yet. It's safer - if freezing an app makes the phone act weird, you can always defrost it... but you can't restore an app after its deleted without a recovery. ;)
    (with some phones you can re-install certain apps, but idk about the Hydro just yet)

    I'd hate to see anyone mess up their phone... Better safe than sorry!
  18. J6Remy

    J6Remy Well-Known Member

    Here's a system pull for the hydro

    Hydro system

    unfortunately, i cannot seem to connect to ADB, media transfer and debugging is enabled. Either it tells me to connect with adb debugging or is says it connont find the specific path. :( boo
  19. J6Remy

    J6Remy Well-Known Member

    let me know if you need any help, I will surely lend my helping hand to any assistance needed.

    -J6
  20. jmz

    jmz Well-Known Member

    Do you have the correct Google drivers installed?
  21. J6Remy

    J6Remy Well-Known Member

    oh my goodness.. lol totally forgot about the drivers.

    Cooking ATM. lol Yea that was the problem, I am now rooted. Thanks Bro. I caught myself downloading the drivers, but forgot to install them. I figured I shouldn't have been doing it half-asleep anyways. lolz

    Here's the drivers if anyone doesn't already have them.
    Hydro drivers!
    Pappy62 likes this.
  22. jmz

    jmz Well-Known Member

    Let me know if anybody figures out how to access fastboot
  23. J6Remy

    J6Remy Well-Known Member

    To get into stock recovery, Volume down and power button. If you didn't already know, trying fast boot now.
  24. Pappy62

    Pappy62 Well-Known Member

    I tried that already... all it did on mine was take a screenshot. lol
  25. J6Remy

    J6Remy Well-Known Member

    LOL me too, I thought. have you tried it with the phone being off?
Loading...

Share This Page