No ICS on SGH-I777Support

Last Updated:

  1. type_writer

    type_writer New Member

    I looked through the forums here and googled the issue, but so far nothing, so hoping to get some help from fellow android users.

    I have a stock, never rooted GS2 SGH-I777 ATT w firmware I777UCKK6, running Android 2.3.6 and Kernel

    I received a txt on June 27 notifying me that ICS upgrade is available for my phone. Today I downloaded Kies and when I plugged in the phone it says "Your device does not support software upgrade via Kies."

    When I do the software update check on the phone, it says it's up to date. So I am not sure what's going on since it's running factory firmware. I'd really appreciate any help with upgrading to ICS.

  2. maxmaxter

    maxmaxter Well-Known Member

    are you sure you got the latest version of Kies? did you try a factory reset before updating to ICS? In any case, if any of these work, DO a factory reset after installing ICS (it stabilized battery usage and apps).
  3. nonie

    nonie Active Member

    I have the same setup on my i77 from att. I never got tx or anything about ICS. I do have kies loaded on my PC, but haven't checked to see what it says. :)
    But from what most are saying about things not working good after update, not sure I want to update to it.
    I would be interested in how your phone works after or if you update.

    What is the latest kies software?
  4. dragula2012

    dragula2012 Well-Known Member

    the latest kies version is I just got it yesterday and it says " this is the latest firmware
  5. type_writer

    type_writer New Member

    hey dragula, what firmware are you running, is it same as mine?

    May be ATT pulled the ICS for the time being?
  6. dragula2012

    dragula2012 Well-Known Member

    I am running I777UCKH7 firmware. kernel .
  7. maxmaxter

    maxmaxter Well-Known Member

    you might want to go to ATT and ask... if you got the latest everything, it seems weird. (did you try updating from another computer?)
  8. dragula2012

    dragula2012 Well-Known Member

  9. steffes

    steffes Member

    hi, i'm new to this forum and wanted to add additional info to go along with dragula2012 comment on upgrading i777 to ics, but can't post links yet since i'm new. basically, there is an additional step that i had to do before i could get kies to allow me to upgrade to ics 4.0.3, the latest version available for gs2 at&t (i777).

    the link i am trying to share restores gs2 to unrooted KH7 stock version 2.3.4, but i did NOT upgrade OTA to KK6 (2.3.6) as 'jack man' did. i will post that additional link once my restriction has been lifted since others may need to do upgrade to LE5 from the KH7 version as i did.
  10. steffes

    steffes Member

    ok, i'm back .. here's the link that you can use to not only restore your gs2 phone to original KH7 (2.3.4) version, but also allows you to read your flash counter to verify that it reads '0' (and how to change back to zero if it doesn't show 0):

    [GUIDE] How to Prepare Your Phone to Return to the Store or for Warranty Replacement - xda-developers

    incidentally, these steps also prepares your phone to be returned to store or for warranty replacement.

    ok, so as i said in my last post, i went directly from this stock KH7 version to perform the ics upgrade using the link that dragula2012 references:

    I just got the official ICS Upgrade From AT&T - Page 9 - xda-developers

    hopefully if you have trouble upgrading from the KK6 (2.3.6) version, as i did, this will help you out by first restoring back to 2.3.4 (KH7) then upgrading to ics (4.0.3)

    good luck!
    type_writer and dragula2012 like this.
  11. type_writer

    type_writer New Member

    It worked! This is 3 months later, but I finally got around to trying the steps referenced by steffes in the second URL. The trick was to initialize the firmware upgrade before connecting the phone to the PC. Thank you steffes, dragula and all who helped out - I finally have ICS!
  12. WhatMyEye

    WhatMyEye Member

    try using diff comp without kies just leave usb in for 1 min
  13. Doc_Palin21

    Doc_Palin21 Member

    Im also having issues, but before i go and update how is it running for you?
  14. GeekGoddess615

    GeekGoddess615 New Member

    This worked perfectly! Thank you!!

Share This Page