No internet access when using wifiSupport


  1. JLeslie

    JLeslie Well-Known Member

    I work for a company that does IT support for small businesses. One client just purchased some new Andoid phones and while they work fine on the mobile network, when they connect them to the company wifi, they can't get out to the internet. I've looked at the WAP's and they are set to hand out DNS server addresses along with an IP address. And company laptops on wireless don't have a problem with internet access.

    So I'm trying to figure out why these phones can't get to the internet when on the company wireless network. Any thoughts?

    JL

    Advertisement
    :
  2. ColtsWalker

    ColtsWalker Well-Known Member

    I've been a network engineer since 1989, and just recently purchased this Commando phone. I think I might be able to help you out.

    Are you concerned it might be a DNS related issue? If so, this is very easy to test. Without DNS, you still have Internet access, you just have to use IP address. For example, try to go to a web site with the browser by IP address rather than the www name.

    This trick is just for testing purposes. It won't work with every web site, because many nowdays use virtual hosting.

    try: 173.192.24.228 (just enter that in the web browser URL bar)

    If that gets you google on the phone, then you have verified you have TCP IP Internet traffic, but no working DNS resolution. Report back and we will take it from there.
  3. bestaudioguy

    bestaudioguy Well-Known Member

    I have a similar problem in that I can connect to wifi and do certain things, but all I was able to previously. For example I can pull up the browser and surf the internet, but cannot connect to things like the Facebook app or even the verizon app which can connect and used to, either way.
    I originally thought it was my router at home and checked all the settings and could not find anything that would have changed.
    I also use Square to process cc sales and it requires both GPS and WIFI to operate and it also cannot connect to the server to make the transaction.
    Could it be a bum phone? Its rooted and running M080
  4. bestaudioguy

    bestaudioguy Well-Known Member

    I tried the ip you listed and the browser automatically adds the HTTP:// and takes you to a default website page, not google
  5. JLeslie

    JLeslie Well-Known Member

    We found a workaround solution. Instead of connecting to the wifi network by selecting the SSID from the list of networks found, we add it manually, i.e. typing in the SSID and passkey, and selecting the type of security. That has worked on every Android phone we've tried. I don't know why it works and the "automated" method doesn't, but I'm not going to try to figure it out, I'm just accepting it works.
  6. skpshah

    skpshah Member

    Hello, Could you help me with my problem - posted at
    http://androidforums.com/sony-xperi...nects-but-no-internet-access.html#post5554424
  7. diysteve

    diysteve New Member

    I had the same problem as JLeslie. I found after quite a bit of looking that I had a static ip address set. Removing the tick out of the use static ip address box fixed all my problems.

    All my own fault. I set it when we were having problems with our wireless at work. :D

    I managed to fix the problem at work too. We were having problems with some computers accessing the wireless (apples in particular but also android phones). The fix was to move the wireless access point away from the steel work in our building.

    SD
Loading...

Share This Page