No luck with Goldcard Method. Still see "Validation error: backup CID is missing"


  1. Jmobie

    Jmobie Member

    Hey guys. I am trying to root my DI using Unrevoked 3.3.2, and I cannot get past the error, "Validation error: backup CID is missing." I received this error both before and after creating a goldcard. I read that Kingston sd cards work well as goldcards, so I bought one of those, and still no luck. I used the Goldcard Helper app on the marketplace, formatted the Kingston card as FAT32, tried both mmc's (mmc1 and mmc2), and requested goldcard image files via e-mail. Neither worked after pasting each onto the sd card.

    I then tried using only Gold Card Tool to both get the CID and patch the sd card. This method didn't work either.

    What else could be causing this error? Please correct me if I'm wrong, but I thought these errors disappear by creating a goldcard. Is it possible for this error to go away once my stock phone is upgraded to Gingerbread? I did install the Froyo RUU leak file last fall rather than waiting for the OTA update. Could this be the reason in that something may have become corrupted during that installation? I would like to eventually have a rooted phone so I can run GingerSense. Below is my software information, if that explains anything. Thanks in advance.


    Android version 2.2
    Baseband version 2.15.00.07.28
    Kernel version 2.6.32.17-g9a2fc16
    htc-kernel@u18000-Build-149 #1
    Build number 3.26.605.1 CL264707 release-keys
    Software number 3.26.605.1
    Browser version WebKit 3.1
    PRI Version 1.28_002
    PRL Version 52297
    ERI Version 5

    INCREDIBLEC XC SHIP S-ON
    HBOOT-0.92.0000
    MICROP-0417
    TOUCH PANEL-ATMEL224_16ab
    RADIO-2.15.00.07.28

    Advertisement
    :
  2. iowabowtech

    iowabowtech root@android:/ # Moderator

    I've never heard of an Inc user needing a Goldcard. Have you tried reloading the full stock image first? Try if you want, the phone will be reset to bare stock though so be aware of that. This is the same version you are currently running but my hope is that it fixes the Misc/CID issue that may have occured when installing the update.zip.

    Place this file on the root of the SD card:
    PB31IMG.zip

    MD5 = 31BB1611A0FA8197D447C0438426717E

    With phone off, hold volume down while pressing power button to enter hboot. Wait until the file is recognized, should be prompted to load using volume up button. Wait patiently until done then reboot to stock 2.2. Remove the PB31IMG file from the SD card, then try rooting again.
  3. Jmobie

    Jmobie Member

    Thanks, iowabowtech, for your help. I was hopeful, but unfortunately, rebooting to stock 2.2 using the image file above didn't work. I still receive the error, "Validation error: backup CID is missing." :( :confused:
  4. iowabowtech

    iowabowtech root@android:/ # Moderator

    Ok. Have you tried to gain temporary root with Z4? Might run into the same issue but it's worth a shot. Maybe then you could load a custom recovery while rooted.

    [APP] z4root - xda-developers
  5. sdrawkcab25

    sdrawkcab25 Guides Guide

    Someone a while back was having the cid issue and could only get the phone rooted using z4 then loading a custom recovery.

    From what I understand, the cid issue was a big problem for evo users.
  6. doug piston

    doug piston Well-Known Member

    You could try z4root then download rom manager and flash a recovery then flash s-off. Or another way is to use z4 then manually flash a misc.img. From there it will allow you to downgrade the software and use an older version of unrevoked the does not check the CID.

    Please keep in miind they did put that warning in for a reason.
  7. Jmobie

    Jmobie Member

    Thanks for all your responses. As you might expect, I was able to do a temporary root using z4root.

    I am fairly new to the rooting world. Are you guys referring to the free version of ROM Manager by ClockworkMod for flashing a recovery? I download this and select Flash ClockwordMod Recovery?

    Then I would need to run Unrevoked Forever, right, to get S-off?

    Thanks, again.
  8. Jmobie

    Jmobie Member

    So, I was able to flash a ClockworkMod recovery, and now I've just downloaded unrevoked-forever.zip to my computer. Do I place this .zip on the root of my phone's sd card? Do I need to rename to update.zip? I've read that this .zip must be loaded from recovery. Could someone please explain this? Thanks.

    EDIT: Well, I was able to flash a recovery, but was unable to reboot into it. It seems this is one of the limitations of temporary root with z4root.
  9. iowabowtech

    iowabowtech root@android:/ # Moderator

    What you need to do is get temporary root with the Z4 app. Then go to the market and download Rom Manager AND download the app Superuser. Now use the top option in Rom Manager titled "Flash ClockworkMod Recovery". Once that is complete, you need to go here and get Unrevoked Forever (S-Off):
    public:forever [RootWiki]

    Place it on your SD card, then try using Rom Manager to load the file. Even though it's not a Rom, you should still be able to load it like it is. So in Rom Manager do the following...Install Rom fron SD Card > Scroll through the list until you find the UnrevokedForever.zip > Proceed with install. If you are given the option to wipe data and/or cache do not do so in this instance. Also, along the way, answer yes to any Superuser requests for the operation of Rom Manger.

    If you've made it this far, you can go ahead and turn off the phone. Then hold the volume down key while pressing the power button to enter hboot. At the top of the screen, it should say S-Off, this means the Unrevoked Forever load was successful and you can now go about flashing unsigned zips. So get out of hboot by choosing the option to reboot to system or similar. This step was just a verification that things worked.

    Now, you have lost root as you noted, but you can get it back permanently due to being S-Off. So, download the following file and place on your SD card, being aware that your card MUST be formatted to FAT32 (by way of the PC, use the full format option) in order for the rest of this to work. Obviously you will lose all card contents so store your stuff on the PC desktop until the format is complete, then I would start out by moving only the PB31IMG.zip file onto the card to ease confusion:
    http://downloads.unrevoked.com/forever/recovery/clockworkmod/PB31IMG.ZIP

    Ok, now the down and dirty. With said file on your Fat32 formatted SD card, turn off the phone again. Hold volume down while pressing the power button once again and once back in hboot don't touch anything. The file should be auto recognized in hboot after several seconds and should prompt you to load. Press the volume up key when prompted and then sit back and don't touch a thing until it's done. You will see a progress bar going up the right side of the screen just like when you loaded stock 2.2 earlier. When complete, you will be prompted to reboot by pressing the volume up key a final time. Once you are rebooted, when you access recovery, it should open ClockworkMod since it has now replaced the stock recovery. You can now proceed with root activities.

    Let's hope this all works. Sounds good on paper. :D
  10. Jmobie

    Jmobie Member

    I really appreciate all your help, iowabowtech, but I've repeated the steps in your first two paragraphs a number of times, but I still end up with the no recovery screen with the red exclamation point and triangle. I will try this a few more times, but no luck yet.

    Is there a way the Droid Incredible on 2.2 can be manually rooted? There are pretty good youtube videos on how to manually root the DI on 2.1.

    Should I try flashing an Amon_RA recovery rather than the ClockworkMod one?
  11. iowabowtech

    iowabowtech root@android:/ # Moderator

    Both are supported by Unrevoked Forever. Give it a shot.
  12. linwiz

    linwiz Member

    i am in the same boat. the only thing that has worked, was z4root temp. looking for help too.
    please. i've rooted before, but its not working now. i have a SLCD so i am hesitant to try older unrevoked versions without precise insructions.

    android 2.2
    baseband 2.15.00.07.28
    kernel 2.6.32.17-g9a2fc16
    htc-kernel@u18000-Build-149 #1
    build 3.26.605.1 CL264707 release-keys
    software 3.26.605.1
    browser wk 3.1
    pri 1.70_002
    prl 58006
    eri 5

    edit: i just used the unrevoked 3.22 with custom recovery. it worked great on the first shot.
Loading...

Share This Page