No More Internet

Last Updated:

  1. gwardnz

    gwardnz Member


    a fresh new problem for my CECT Prodigy phone running Android. About a week ago, I got the internet connectivity (via cellular network, not Wifi) up and running, by simply generating an APN with the name Internet! Seemed a bit dubious to me, however this was enough to make the phone connect to the internet via my cell carrier. when at home, it automatically connects to my Wifi and vice versa when I leave. Thus far, no problems and this is the way I would expect the phone to operate.

    However 2 days ago, I had the opportunity to try connecting (via bluetooth) to someone else's phone. This did not work (saw their phone, asked for a password, paired but not connected. Who comes up with this jargon and these redundant steps? Why would I only want to "pair" but not actually connect for heavens sake!!). The bluetooth problem is not my concern here. My problem is that ever since (and it may only be coincidence) My internet access has ceased to work! I can still connect via WiFi, however connectivity through my carrier (2 Degrees, New Zealand) is no longer possible. It is not the carrier, as I know other people who connect through them without a problem. I have attempted to enable/disable the bluetooth radio several times (though why this should make a difference is anybody's guess) and tried editing the APN (another seemingly redundant step)

    Before anybody asks why I suspect a link between Bluetooth and Internet connectivity, I have tried this as I have read of several people having issues with the bluetooth radio temporarily disabling GPS capability. Two apparently very different modules, yet Android seems to confuse the two. GPS inoperability continues to also be a problem for this phone for me, however at least i had Internet access before!

    Any ideas as to what may be causing Android to falter here?

  2. gwardnz

    gwardnz Member

    I have since recovered my Internet Access, through power cycling. Shutting down the phone and then restarting it caused the phone to resume its ability to have internet access.

    Why is this necessary? I tried changing settings and enabling/disabling various options without success before power cycling and successfully recovering. I am running a slightly older version of Android (Version 1.6). Could this be the reason, IE older and therefore more bugs?

    Still have no GPS capability...
  3. Carouno

    Carouno New Member

    I bought a cect a818 and cant connect to the internet thru dodo ( read optus) here in Australia at all? Very frustrating - I think the a818 onepad is a copy of the htc phone but not sure? regards Tony Chinese Crap!!!

Share This Page