No option to sync google calendarSupport


  1. Alstann

    Alstann New Member

    When I try to access my Calendar app, it tells me that I have not set up a calendar to sync. After going to the accounts page, and going to my google account, there are only options to sync my gmail and sync my contacts, but not my calendars. How do I fix this?

    Advertisement
  2. deemedic

    deemedic Active Member

    My hubby is having the same problem with his X he just got today. I have had mine since August and as soon as I did the thing with the calendar mobile set up I had the option to sync my google calendar. That was prior to 2.2 update though, and I still have that option. We've been here for 2 hours reading threads and trying everything and the option to sync or even add the google calendar that he has is not there. WTF somebody must know something!
  3. apg28

    apg28 New Member

    I'm having the same exact problem...
  4. Animal Mother

    Animal Mother Member

    Have you went into the calendar settings on the droid?

    Go to the apps page, select the calendar, hit the button on the far left (don't know the name?), select "MORE", select "Calendar".

    From there you should see a sync setting below the address.

    It works just fine for me.
    mxsjw likes this.
  5. Btros

    Btros Well-Known Member

    Try going into your gmail account on your computer browser and go into calendar. Then go into Settings > Calendar Settings > Mobile Setup and enter your phone number to be validated.
  6. deemedic

    deemedic Active Member

    Yeah I know we did all that, phone is registered in the google calendar settings and everything. Like I said my set up on my X was easy and worked fine just following the regular directions.

    For whatever reasons folks with the Droid 2 or X after the froyo update are having this problem so fear not you are not alone. I did find a great thread on the google site that gave a work around that did the job for the hubby last night. It is kinda hokey to have to do this but it works.

    There are actually two ways to go about it on this thread, the first way you can delete the dummy account you make, this method didn't work for my husband...The second way is described by a poster named RobDroid2, he is the OP but later he explains how he worked around it but if you scroll much down the thread he really explains the solution in detail, this method worked for the hubby on his phone last night. He doesn't really care about having the dummy account still there, but you never see it anyway.

    Here is the link

    I really think it may have to do with Froyo on these out of the box phones, even though so many folks here seem to think the issue was fixed in Froyo. As I mentioned, I never had the issue because I sync'ed to my google calendar under 2.1 with no issues then upgraded and still have no issues. I am hoping there is a more logical solution to the issue than this coming eventually.
    CarrollGrp likes this.
  7. 2horses

    2horses Well-Known Member

    I didn't start using the google calendar until after I upgraded, but I'm using a third party calendar app and it synched just fine. It's Pure Grid Calendar, you can buy it on app brain.

    Eta-I just checked the stock calendar and my google synch worked there too. One thing I did notice that I don't think is so great is that instead of a color change to indicate an event, the numbers are just barely bolded.

Share This Page