No Red Exclamation Mark Shown When Installing Custom ROM!

Last Updated:

  1. OhShizzl3

    OhShizzl3 Member

    Okay, Hi :)

    I just rooted my Desire a couple of days ago using the Unrevoked method which was all straight forward and I assume I done it correctly as the SuperUser Ninja thingy is on my apps list.
    The problem is that whenever I try to install a custom ROM on my desire I go through all the steps correctly but when in recovery mode no "red exclamation mark" as ever shown on my device and it goes straight to Clockwork Recovery Mode.
    This has happened a couple of times and I have still tried to open the "recovery-windows" file in my C: Drive but this just makes the phone show two different screens which keeps changing with each other. I still tried to install the ROM by using the ClockWork Recovery Mode by wiping the data then the cache then installing it and rebooting it but this made my HTC reload with a black screen with white lines on either side. So then I restored the backup I made and got it back to how it was when I first rooted it but I really want to know what the problem is (if there is one) or if I'm being a complete noob! :confused:

    I'm sorry if I am but everytime I look at a tutorial or a video on YouTube describing this, everyone receives the red exclamation mark whilst I receive a totally different screen.

    Thanks for reading and I hope I haven't wasted your time :)

  2. EddyOS

    EddyOS Well-Known Member

    That's completely normal, the red ! is the stock recovery...unrEVOked replaces this with a permanent CWM so just use that
  3. SUroot

    SUroot Well-Known Member Developer

    Sounds like you are using ancient guides and ancient roms.

    What rom and version of the rom are you installing? has it definitely got full SLCD support?

    What are you using "recovery-windows" for?

    Please try and walk me though what you are doing step by step
  4. OhShizzl3

    OhShizzl3 Member

    Lol, I think I am :p
    I did carry on with the ClockWork Recovery Mode screen and flashed a Modaco ROM (if link is needed I will find it)
    I kinda just wanna check if this other ROM I found will work because I don't wanna wipe my phone just to return it to its original state

    ROM - [ROM][newSense][04/01]DHD Rom Port by baadnwz v1.7b STABLE|SUPER FAST|1.72 Base - xda-developers

    And as I believe I am a complete noob how would I get Apps2SD working when downloading it within a ROM?

    Thanks again :)
  5. SUroot

    SUroot Well-Known Member Developer

    See the faq in my sig for that, and yes. That rom works well. Flash in clockwork.
  6. OhShizzl3

    OhShizzl3 Member

    Hey thanks for that but now when I was flashing the ROM it comes up with

    "E: Can't mount /dev/block/mmcblk0p2 (File exists)
    E: Can't mount SDEXT:
    E: Failure at line 10:
    copy_dir PACKAGE: data SDEXT:
    Installation aborted." :confused:

    I have found some forums which say that they had to re-root their phones but when doing so they bricked their phones.
    Is there any other way around this

    Thanks for any advice
  7. OhShizzl3

    OhShizzl3 Member

  8. SUroot

    SUroot Well-Known Member Developer

    Have you partitioned your card yet? If so, looks like it didn't work..what method did you use?
    OhShizzl3 likes this.
  9. Eris Ed

    Eris Ed Well-Known Member

    Sounds like the rooting worked, but there's no EXT3 partition for A2SD+ on your card. The card needs the EXT3 partition before you flash any ROM with A2SD+ capabilities.
  10. OhShizzl3

    OhShizzl3 Member

    Okay, I partitioned it again and the ROM is flashed :)

    Thanks for all the help guys!
  11. Eris Ed

    Eris Ed Well-Known Member

    Good to hear :)
    OhShizzl3 likes this.
  12. Borat38

    Borat38 Well-Known Member

    Still on the topic of partitioning: do I understand correctly that Oxygen is the only custom ROM that doesn't require partitioning?
  13. EddyOS

    EddyOS Well-Known Member

    Most custom ROMs don't need it, it's just for installing more apps
  14. SUroot

    SUroot Well-Known Member Developer

    Someroms come with it bundled in, in which case, they may not boot without a partition.

    However, you can modify the rom zip file to remove the apps2sd+ script.

    to do this, just open the zip (not extract it) in say, winrar

    Navigate to System/etc/init.d and delete the appropriate file before flashing

    Aurax uses 03stuff2sd
    MIUI uses 04apps2sd
    Oxygen uses 10apps2sd
    Defrost & Leedroid uses40a2sd

    (courtesey of iinga)
    shauny13 likes this.

Share This Page