No Service Signal most of the times in Galaxy AceSupport

Last Updated:

  1. sureshmidde

    sureshmidde New Member


    I have recently purchased Samsung Galaxy Ace s5830i smart phone a month ago, and I have noticed a couple of problems, which are very much annoying.

    1. Suddenly the phone gets a vibration and loses the network signal with a crossed zero in the right top side and I see 'media sd card scanning.. completed', though I am in a area where there is no problem with the network signal. I have checked with the other phone, which is having same mobile service connection.

    2. And some times, the phone does not come out from unlock status even pressing the home button,(Middle icon in the bottom side), no sign of the first and last button blinking. I need to hold the power key to make it go to switch off and switch it on again to move into unlock state.

    3. The other problem is, some times after restarting the phone, even the signal comes up, I could not make call, as the attempt fails giving an error message 'No network connection'

    All of these problems have made really a very annoying and I had took this to the nearest samsung service center, they have upgraded the software and still the same problem persists.

    And I have not installed any of the softwares/apps till now on to this mobile.

    Please let me know, if this is a purely a hardware defect (If yes, how to go for replacement for a good piece) or any suggestion to get me free from this problem.

    I have not tried connecting to internet still, as the basic functionality is not working.

    Suresh Midde

  2. galaxyace152

    galaxyace152 Well-Known Member

    Do you have bsnl?
  3. Mackinon

    Mackinon Well-Known Member

    i also get the same problem mentioned as in first point but worse.. when ever this happens my phone automatically switches to 3g where i have set GSM as my network mode
  4. ayush29k

    ayush29k Well-Known Member

    Have you tried another network operator??, maybe its a problem with your sim card.
    If they have upgraded the software and the problem still persists, then its highly unlikely that the problem is with the software.
  5. Jesuslovesyou

    Jesuslovesyou New Member

    I faced the same problem with my Samsung Ace S5830 that it keeps losing the network signal. I updated the firmware and formatted the phone and still the same problem. I took the phone to the Samsung store and they opened the phone and cleaned it with some solution and i tried to use the phone for sometime and still the same. I was very frustrated and unhappy with my phone as it is not even a month and it kept on losing the signal and sometimes would restart and would lose the battery charge. I tried doing this step( Settings>Wireless and Networks>Mobile Networks>Network Mode>Select either GSM or CDMA(Depends on the provider) By default, it would be selected as GSM/WCDMA(Auto Mode)
    From Network Operators select the desired network and then restart the phone. Hope this would fix the problem.
    Revert for clarifications
  6. pm5544

    pm5544 Well-Known Member

    I've been having similar issues recently in that my reception bars fluctuate alot from having no bars at all then suddenly it will show 3 then back to one and none again, I have also had the phone switch itself off completely twice since I got it, and just the other night it rebooted on it's own.

    I even called it from my land-line when it had no bars showing and it went straight to voice mail.

    The carrier are sending me a new sim card, and I can't remember if this was to try fix the issue for the reception issue or the phone turning itself off and or re-booting on it's own.

    When I am outside I have all 4 bars showing but when I am in the house I normally either have zero bars or 3 showing.
  7. ayush29k

    ayush29k Well-Known Member

    Random rebooting is a phone problem, but the network problem could be your network reception inside the house.
    There could be an app that is causing instability in the system causing random reboots, take a look and see if you can spot any, it could also be a defect in the software that you are running and might be solved by a factory reset or complete reinstallation of the software.

Share This Page