No sound at all - Help Please!Support


Last Updated:

  1. Mr.DNA

    Mr.DNA Well-Known Member

    My phone started exhibiting some strange behavior today regarding sound and mic - neither are working (most of the time). If I am receiving a call, the phone will sound the ring, but when I answer it the speaker and mic go dead. If I hit the volume button while the phone is ringing, the speaker also goes dead. When I try to play music, no sound is produced (although if I plug in headphones I find that it is playing). The problem persists after multiple reboots, and the Samsung "song" does play during boot. I'm not sure exactly when this started as it was working fine yesterday.

    Advertisement
  2. damuffinman

    damuffinman Well-Known Member

    Have you tried reflashing the firmware, or restoring from a nandroid backup?

    I usually just end up reinstalling Windows if I can't find the source of the problem :)
  3. Mr.DNA

    Mr.DNA Well-Known Member

    I'll try the nandroid backup when I get home. I only just rooted, so I have not yet attempted restoring a backup.
  4. Mr.DNA

    Mr.DNA Well-Known Member

    Ok, nandroid backup restored. The problem persists.

    All this time I've been looking for ways to increase the functionality beyond "just a phone", and now it has plenty except it has lost the phone ability.



    edit: Found a bunch of other people with similar problems on other Samsung phones. Seems to be related to the headphone jack and the phone getting stuck in headphone mode. Some rougher than normal plugging of the jack and my phone is back to normal. Lame.
  5. amithoward

    amithoward Member

    While playing a game today, my Samsung Galaxy (20days old) just stopped the output of ANY sound at all that comes out of the main speaker. While the game was still on, the sound would fluctuate for a second when I moved the phone. After exiting the game I tried to play a movie and realised that there was no sound output there either. I tried every sound related application - but nothing. No ringtones, Alarms, Music, Speaker phone NOTHING.
    I rebooted a few times - even the Samsung "song" did not play - just the little animated splash screen.

    Finally I plugged in my head phone and heard the sound of EVERYTHING. Which means to me that there is a problem with the loudspeaker of the phone.

    The question I have is that could this be a hardware problem or maybe a third party application (which I do install) causing it? My reasoning is that if it would be software issue then there would be no sound output at all - not even from the headphone jack. Calls sound perfect... but the phone doesn't ring. SO again - NO SOUND FROM THE LOUD SPEAKER!

    Any other views and suggestions?? I would love to fix it myself if this a software problem. But if it is hardware then I have to send it to Samsung Service Center.
  6. informale

    informale Well-Known Member

    I doubt it is software. To find out I guess you have to do a factory reset.
  7. amithoward

    amithoward Member

    Yeah, I could try that but I don't wanna loose all the date from my calendar, my contact information and other info I've stored on it. I can always install the applications back on... but entering all the info back is a pain. I have Ubuntu Karmic Koala and the pc sync cd doesn't work on it.
  8. informale

    informale Well-Known Member

    Well you have Google Sync... And if it is hardware fault, you'd better do the reset anyway )
  9. amithoward

    amithoward Member

    Alright I will check it out. Thanks.
  10. Mr.DNA

    Mr.DNA Well-Known Member

    This sounds silly, but try violently plugging and unplugging your headphone plug into the jack a few times. It seems to be a hardware problem across Samsung phones where the switching of sound from headphone-mode to normal-mode is not triggered properly, and the problem will persist through reboots.
  11. ryko

    ryko Well-Known Member

    There seems to be a lot of people posting with this problem , perhaps the latest batch of phones from Samsung have been badly put together, a shame as this hardware fault has been around from the start,one would have thought it should have been fixed.
    It might be an idea for a moderator to add the fix to the FAQ
  12. amithoward

    amithoward Member


    I tried doing that... and yes it did feel silly to do that too. :D Oh well... still no luck. Today the sound came back on for like a 15 seconds and then started fluctuating again and was dead. Sounded to me that the connection to the speaker (however it is done) is not proper.
    Anyway, going to the official service centre tomorrow. Found this guy in the inside (friend of a friend) and hopefully he will tell me more about it.

    Well - another question.
    Is anyone able to run the Pc Suite on Ubuntu (Karmic)?
  13. Mr.DNA

    Mr.DNA Well-Known Member

    There is another recent thread (and another older thread buried somewhere) on the topic of using the phone with linux. I use adb to move files, install apps, and flash recovery, but you cannot make use of NPS or odin even in virtual windows because of limits with the usb drivers (although the recent thread does suggest a workaround, but I have given up trying to get them to work on my ubuntu machine at home and instead find an available pc at work to use whenever I need to flash a new firmware).

    Best of luck with the sound issue.
  14. amithoward

    amithoward Member

    Alright I found out what was wrong about the sound. The speaker seems to be having the problem and they said that changing to a new one will do it. I still wonder if there was something in the phone that triggered the issue or was it just a faulty speaker.

    Anyway, I will look out for the older threads on linux connectivity.
  15. muitommy

    muitommy Active Member

    thanks to this thread.
    i tried to plugin the ipod touch's headphone inside ytd, after all, my phone's sound is gone or just make some cracking noise occasionally(i dunno it's the prob. of that headphone). Now i plug it and rub that hole a bit, now is fine.
  16. fleents

    fleents New Member

    I encountered the same problem with my xperia mini pro. I guess its a software problem. The last app I played was the tunein radio.
    I plugged the headphone while playing the music and plugged it out and its all ok now. Wierd..
  17. fleents

    fleents New Member

    I encountered the same problem with my xperia mini pro. I guess its a software problem. The last app I played was the tunein radio.
    I plugged the headphone while playing the music and plugged it out and its all ok now. Wierd..
  18. maurinet

    maurinet Well-Known Member

    I just experienced this same problem, and I have to say, it's freaking scary and annoying. I tried everything, violently and gently connecting and disconnecting the earphones, connect/disconnect earphones with charger plugged in, reboot, restore nandroid backup, etc., etc., etc., etc., etc... nothing worked.

    I then installed GAOSP and when the phone booted it showed me the headphones icon on the lock screen, indicating that the headphones were connected, even though they were not. I then connected and disconnected the earphones and the icon disappeared, everything is back to normal. I then restored my nandroid backup to go back to Galaxo 1.6.3.4

    It was a long and scary process, but GAOSP seemed to detect correctly when the headphones were unplugged, so it could be a software problem, maybe I just got lucky.

    Either way, you can try this out and see if it works for you.
    Good luck!
  19. rajm11

    rajm11 Member

    okay I dont know if u have solved this or not, It was the same problem with me
    connect the headset,hear songs, remove it and no sound at all.
    The solution is simple, revive the speakers and receiver with the code *#*#0673#*#* and press speaker on, then reciever on and then again speaker on. in an instant every sound is back.
    Alex6_s likes this.
  20. maurinet

    maurinet Well-Known Member

    Unfortunately for us Galaxo users, Drakaz has disabled all those codes :'(
  21. Kamala

    Kamala Well-Known Member

    ok, I need help, this is going nuts.
    Have same problem, it happens once in 10 days. When I answer the call, I hear weird sound (something like sound when you put volume to max), cant hear person who called me and my mic is dead. It repeats over and over again till next reboot. I can confirm that this happened to both of my galaxys. Have installed 1.6.3.4 with Darksense theme.
    Any solution?
  22. maurinet

    maurinet Well-Known Member

    Sometimes when I receive a call I can't hear anything, but the person on the other side can hear me. What I do is press the menu key, then click on speaker. Then I can hear the person calling me on the speaker. I then click on speaker again and the call works normally.
    That's a small workaround that works for me, but I'm with you, it's VERY annoying!
  23. Kamala

    Kamala Well-Known Member

    Thanks for the tip. Will try it.
  24. rumtchovski

    rumtchovski New Member


    this was it! This totally solved it!!! Thank you!:):)
  25. r3dpuma

    r3dpuma Well-Known Member

    Or clean the jack ;)

Share This Page