No USB Mass Storage After ICS UpdateSupport


  1. mdonova33

    mdonova33 Well-Known Member

    After the ICS update I got this morning, I can no longer mount my phone to my computer to exchange files. Does anyone know if the location of the setting was changed, or whether there is a work around?

    Advertisement
  2. davis.rob

    davis.rob Well-Known Member

    Doesn't appear to be any support for UMS in ICS. At the moment you need a computer that supports MTP. You might consider FTP over WiFi if MTP support is a problem (you didn't say what type of computer you have).
  3. mdonova33

    mdonova33 Well-Known Member

    Windows 7. Are they going to roll out an update to fix this?

    Also, how would I do FTP over WiFi?
  4. davis.rob

    davis.rob Well-Known Member

    So Windows 7 should support MTP (which is a lot like UMS but actually better). I'm running Windows 7 and ICS on my E4GT ... when i plug in my phone I get a pop-up for an "SPH-D710" device and options to open a folder. Then I see folders for "Card" and "Phone". I'm not sure why it wouldn't work for you or what to suggest.

    As for FTP, you need a server on your phone (I use FTPServer from the Market) and a client on your PC (I use FileZilla). You make a WiFi connection (from the client to the server) and can transfer files either direction.
    HeadBlade911 likes this.
  5. allod

    allod New Member

    I had the same experience. Windows XP recognizes only the camera and I can no longer access the external SD card. I will try it on a Windows 7 computer and see that works. I suppose I could take out the external SD card, make any changes using a card reader, and then reinstall it. But that's pretty clunky - even if it works.
  6. davis.rob

    davis.rob Well-Known Member

    You might try googling "Windows XP and MTP". There seems to be some question about what's supported. I found this:

    Windows XP supports MTP if Windows Media Player 10 or later is installed. Windows Vista natively implements MTP.
  7. wordnerd

    wordnerd Member

  8. Bryanba

    Bryanba New Member

    This is my 1st post and I'm trying to find some solutions or workarounds to the problems MTP has created for me. I disagree completely with davis.rob that MTP is better than USB mode.. MTP is a disaster that is ill-conceived, poorly tested, and pathetically supported. Android in general is also patheticaly supported. Nothing that I used to do works any longer. I'm considering switching back to Gingerbread or rooting my phone soley due to the regression in functionality I've experienced with MTP and the overall problems that ICS has created for me.

    1) I can no longer use Picassa to import photos from the SD card on the phone. Picassa doesn't see the card at all. It only sees the built-in "Phone" memory. You can browse to the card in the import dialog but it sees no files.

    2) Within Windows 7 Explorer I can no longer see thumbnails for photos in the Phone or Card locations so I can't see which photos are which unless I copy them to the computer and look at them there.

    3) I sync FLAC music files with my phone on a 32GB SD card. The product I use is JRiver's Media Center. Before ICS and MTP this worked flawlessly.. Now I get errors when it syncs and many of the songs will fail to copy. It makes a mess of the folder structure too when attempting to sync. The phone switches in and out of sync mode when it's syncing. It may be the the phone's media scanner is interfering with this process.. I've tried different cables and different USB ports on the computer.. It's not the hardware, it's the idiot MTP protocol stumbling.

    Overall I absolutely detest this OS upgrade and MTP overall. It is a complete failure for me and I've spent countless hours trying to get something to work.. Currently I have to turn the idiot phone off and remove the SD card and insert it into my computer to properly sync it.. If MTP is the future of Android then I may very well switch platforms. I just don't have the time or patience to chase these problems. I need something that "just works" and I'm afraid that Android fails at this basic concept.

    Bryan
  9. egkor

    egkor Well-Known Member

    I am having the same issue.

    W/ Win 7, I could connect my Sprint GS2E4GT to my computer via USB and it would connect and I could access folders on the phone via the computer.

    Now when I connect the phone to my computer USB, the phone recognizes it is connected via USB but the computer does not detect the USB device (phone storage) as before. Just sits there un-impressed.

    What to do now? I have tried re-installing the Samsung USB drivers, but that did not change anything.

    Thanks,
    -Gary K

    Edit: In W7 "Safley Remove (USB) Hardware", it shows it detects a Samsung_Android USB device, but it can't find the driver software for it. (??)
  10. egkor

    egkor Well-Known Member

    More info, after the ICS update ...

    When IU connect my GS2E4GT to my Windows Vista machine via USB cable, the phone (SPH-D710) is recognized and I can use Windows Explorer to see the Phone and Card directories on the phone and external micro-SD card. This is just the behavior I want and expect.

    When IU connect my GS2E4GT to my Windows 7 machine via USB cable, the phone is not recognized.

    So until I can find out why MS Win 7 has this behavior I will use my MS Win Vista machine to access the files/directories on the phone.

    This did cause me to try Kies Air for the first time.
  11. egkor

    egkor Well-Known Member

    My MS Win 7 box now recognizes my phone storage via USB after ICS update (MTP).

    I don't know what happened, its a different day than when it was failing, but now it works. I don't have to use only a MS Vista machine and I don't have to use Kies.
  12. ScandaLeX

    ScandaLeX Wasn't Me Guide

    This is exactly how mine appears in Win 7. On my Mac it's a total disaster. My Mac doesnt even recognize the phone is plugged in. Worked flawlessly before ICS. And android file transfer doesn't even work. It's never worked and I dont know why people even suggest for Mac users use it.
  13. Umbradomo

    Umbradomo New Member

    Without hacking my phone is there any hope of going back to the old view and functionality while at work on Win XP? Im stuck with it at work but have win 7 at home and the phone works fine there.
  14. davis.rob

    davis.rob Well-Known Member

    I googled "mtp windows xp" and found this:

    "Windows XP supports MTP if Windows Media Player 10 or later is installed"

    Hope that helps.
  15. Umbradomo

    Umbradomo New Member

    Thanks Ill try that
  16. twilighter

    twilighter Well-Known Member

    Since ICS, I can no longer connect my phone to my laptop. I have a Toshiba Satellite w/ windows 7. I really need my to connect my phone to transfer files.
  17. WiredNovacane

    WiredNovacane New Member

    The USB Mass Storage Driver Update function for PC is obviously different and less user friendly than Gingerbread. On Ice Cream Sandwhich you now have to change the USB Connection Type in Connectivity > System Settings to Media Sync (MTP). Selecting this while the USB connector is plugged into you computer device will not trigger the driver update on your computer device like the previous Gingerbread conveniently did for us. You have to select MTP with the connector unplugged, then connect it and your computer device will read the USB Connection from your phone and update it's driver to accommodate a connectivity for your phone matching the MTP connection instead of any other connection previously selected (i.e, Charge). Yes you can manually update your computer's driver as mentioned in other thread posts but automatic update remains available. It seems traditional convenience isn't a consistent service with every new OS being provided every now and then. Something new is always something different now.

Share This Page