Noob question: rooting phone

Last Updated:

  1. zopper

    zopper Well-Known Member

    Dear all,

    I have noticed that this is not really the right site for noob questions, but cannot find a site that can really help me, so apologies for posting here.
    I have tried to root my Galaxy S using these steps:-
    I downloaded the (from the 3G connection - I really don't know why people go to the trouble of d/ling to a PC and using a USB cable) and saving it onto my /sdcard directory.

    Next, I tried to reboot into 'recovery' mode, by
    1: turning off the 'phone. (Held down power and selecting power off.)
    2: Power off the phone, and turn back on whilst holding the Volume Up & Home, and then (at the same time) the power button.

    I have tried step 2 about seven times, and each time it boots the 'phone as usual. I do not know how to do this.

    I have flashed plenty of bootloaders and Angstom kernels on my old hx4700 using far more daunting methods, yet his one, as simple as it sounds, has eluded me. Is it possible that the recent versions of Galaxy S do not allow this?

    Best regards, A complete NIB.

  2. jollygoon

    jollygoon Well-Known Member

    I've heard that with the new batch of phones you can't go into recovery mode with the three button pressy thing you mentioned. Have you tried rooting using the one click lag fix app? You can find it on the market.
    zopper likes this.
  3. zopper

    zopper Well-Known Member

    Oh, am I wishing I had bought an HTC? /me deep sigh.

    No, I have not tried the one click lag fix. I have read too many threads about the internal flash eventually corrupting itself, and ending up with a bricked 'phone. The 'phone cost me 550 euros, and I do not want to break it. I would rather make do with the lag, and have a working 'phone, verses a faster 'phone yet prone to breaking. I cannot post it back to the dealer (on-line Internet company in the Netherlands) if its broken unless I actually go to the place, and this is far away in Den Haag. *
    Can we still use adb with this batch of 'phone, or did they disable this as well? In the meantime I have downloaded the Keis updater, and shall see what this will do. *I notice that the NPS asks which country one is in, as programmes providers are country dependant. *Is this related to language settings are actual programmes? Hmm.
  4. zopper

    zopper Well-Known Member

    I can confirm that neither Home+VolumeUP+Power, nor Home+VolumeDOWN+Power work anymore. Thus recovery and download menus are unavailable. I wish I had bought an HTC.
  5. psychedelic'd

    psychedelic'd Member

  6. zopper

    zopper Well-Known Member

    Cheers. I shall look into this.
  7. jollygoon

    jollygoon Well-Known Member

  8. jollygoon

    jollygoon Well-Known Member

    what I actually meant was that you could root using the one click lag fix app that's in the market without having to apply the lag fix itself. Then you could just download clockwork mod to flash in a recovery.
    zopper likes this.
  9. zopper

    zopper Well-Known Member

    Perfect. I shall take this path. Once I have rooted the 'phone, then I have to flash clockwork (whatever this is. I presume its another kernel, but think I'll find out soon. ;) Cheers.
  10. jollygoon

    jollygoon Well-Known Member

    It's not a kernel, it's an app that helps you flash custom roms on your phone. It also allows you to have a recovery mode if you are so inclined. It also helps you make nandroid backups, it's a must have if you wanna mod your phone. Well either this o amon ra recovery. Check it out and tell me how it goes.

    Hey zopper, have you checked out the 3 button fix thing? You might wanna be sure you can get into recovery mode before you do too much to your phone. Because at least then if anything happens you can flash in a new rom.

    Mod well and prosper.

  11. zopper

    zopper Well-Known Member

    the first thing I shall do is reflash back the abilty to use the recovery mode. I have to be able to use this other I won't risk bricking my SGS.

    So far, I have only written about doing this. i have not even tried the one click root through fear of bricking it.

Share This Page