Not connecting via USB, only chargingSupport


  1. Ragex

    Ragex New Member

    When connecting my phone to the computer via USB I get no indication of it being connected other than that it starts charging. Usually when I connect it shows the USB icon in the status bar and either goes into USB mass storage or debugging depending what I used when it was connected last and shows the status of the USB connection in the notification area.

    I have read through multiple posts on multiple forums with problems like this and I have tried:
    - rebooting the phone (including taking out the battery)
    - restarting my PC
    - updating Kies (drivers are up to date)
    - unmounting SD card
    - checking and unchecking USB debugging and connecting it both with debugging off and on
    - using other cables and other ports (even though my original cable and front ports worked fine a few days ago)
    I have a hunch that it might be when I connected it a few days ago I disabled USB debugging as I just wanted the phone to charge, I usually don't charge the phone on the PC but I couldn't find my charger at the time. The debugging icon did indeed show up the last time I plugged it in before I turned it debugging off.

    Now I want to do something that requires debugging enabled.To clarify, I do NOT want help with ROOTing or an alternative way to access my mass storage (I know how to do this), I'm just trying to get my phone to change from charging to debugging in USB mode.

    My phone is not ROOTed and is running Froyo (2.2.1). I have read in 2 separate forum posts that the settings to change the default USB connection can be found under 'Wireless and Networks', but all I can find is 'USB Tethering' under 'Tethering and Portable Hotspot'.I avoid asking questions if I can get my problems solved by reading up answers to similar problems myself, so I'm hoping to get some useful answers with the information I've given. (apparently I can't post screenshots or links so this will have to do)

    tl;dr:
    I need to change my USB connection state from 'charge only' to 'debugging' mode where there is nothing in the status bar and nothing I can find in settings. It used to work, I don't know why it's not working now.

    Is there something I need to change to change it or is there an app which would allow me to toggle between usb dubugging, mass storage and charging that would work for this?

    Advertisement
  2. sayyy

    sayyy New Member

    Same problem here! have you found any way to fix this? i don't understand why nobody tried to reply to your question. I need to find a solution to this too. I'm getting frustrated cos of this problem. Used to work fine but now it won't work same as yours.
  3. spaceman

    spaceman New Member

    this keeps causing me grief too but found the answer
    go to manage applications then development & deselect usb debugging
    you might find that you have to deselect it then plug in your usb & if you dont turn on the mass storage device in your pull down menu have to repeat the above process.
    with a bit of patience you will get there.
  4. DerDoktor

    DerDoktor Member

    this does not work for me on my samsung galaxy precedent, this is the only thread I've found on this problem
Loading...

Share This Page