not getting 4g on new s3?Support


Last Updated:

  1. bc_co

    bc_co Member

    unboxed the new S3 today (got it yesterday)

    I can't connect to 4G - only runs at 3G. I took a coworkers Galaxy Nexus phone to a 'good 4G zone" at work and his read full bars where as mine only said 3G. It does not appear that the GS3 has a setting to turn on/off 4G. I live in a solidly 4G area - urban Denver.

    My [unsuccessful] troubleshooting steps
    - toggle between airplane mode and regular - to try to re-pick up local 4G signal
    - did a factory reset of the phone (with verizon support 'helping')
    - enabled all roaming (even though I should be solidly in-network)

    Verizon said that the phone could be hosed and they'll replace it if I can't fix this myself. I'm sure there is a stockpile of S3s out there for immediate replacement - or not :)

    mega bonus points if anyone can help me out here.

    Thanks in advance

    Advertisement
  2. Krunk83

    Krunk83 Well-Known Member

    Do you have a 4g LTE capable SIM card?

    Edit: Nevermind. You're on VZ.
  3. kingoftetris

    kingoftetris Member

    Did you try Settings>More Settings>Mobile Networks>Network Mode>LTE/CDMA?
  4. thocar1

    thocar1 New Member

    I am having the same issue. Coverage is spotty in area, so I didn't realize it until coming to work and my co-workers all have 4g here. Hope somebody has a fix because I would really like not too have to set up a new phone.
  5. rjm12rjm12

    rjm12rjm12 Member

    I activated two phones last night, one came up in 4G the other 3G. I called Verizon and the tech told me to take the battery and the sim card out for two minutes. When I put them back in I had 4G. He said that it could have been in 4G, but just showing 3G. He said there would be a software fix coming in September. Not sure if I believe what he said, but it did seem to work.

Share This Page