Not getting all Google Calendars


Last Updated:

  1. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    My wife and I both use Google Calendar. I only get mine. I've found four other threads on this topic, but for other phones and the solutions (only 2 had solutions) were not for this phone: different menu options, etc.

    When I go to the Settings/Calendars, only my personal ones show. Well, not even all of my personal ones. And my wife's doesn't show either.

    Any ideas?
     

    Advertisement
  2. pinbak

    pinbak Well-Known Member

    Joined:
    Jun 9, 2010
    Messages:
    127
    Likes Received:
    5
    Did you try to open the calendar, then hit settings, then more then calendars and make sure they are all checked. I know some calendars will NOT ever synch and its a google calendar thing, such as the sports calendars, those do not synch at all. Also when you are on the google.com/calendar page, make sure all the calendars show there, if they are not the sports ones, under other calendars make sure they show there and I believe under settings at google.com/calendars I think you have to make sure they are checked there. good luck!! :D
     
  3. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    That's just it. Not all of them are there to check. I have 3 calendars, and onlly 2 of them are there. And my wife's shared calendar is not there either. And I have done all the other things you suggest.

    Many thanks though.

    I wonder about deleting then re-adding teh account may do it. But I fear duplicating all the entries or something.
     
  4. lordmaxx

    lordmaxx Well-Known Member

    Joined:
    Dec 28, 2009
    Messages:
    379
    Likes Received:
    24
  5. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    Thanks. I'll check them out. I also plan to check out Pure Calendar.

    I didn't think about the calendar app itself being the problem.:eek:

    [EDIT]
    Well, I installed Jorge. It has its own calendar which does not synch to Google, or you can have it use Google Calendar. When I did that, I think it just used the data that is on my phone, because it was identical.

    I need to drag my butt to bed. Frustrating that I can't get this calendar thing to work.

    [EDIT2]
    Well not having any luck. I tried adding another account (my wife's), but that won't work. Because there is no selection to synch calendar only. You must sync email. Don't want her email.

    Looks like I need to hard reset the phone:( So, my next order of business is to figure out how to backup everything, so I don't have to do all the config again. Of course, what I don't know is if the restore will just bring the problem back, assumint the hard rest fixes my isse. I'll create a new post on backup topic.
     
  6. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    Guess what. I tried our dear friend, Google.

    Here is the answer:

    1. Press your device's < Home > button, then press < Menu >.
    2. Select Settings and then Applications.
    3. Select Manage applications.
    4. Press < Menu >, the select "Filter."
    5. Select "Running."
    6. Select Calendar Storage.
    7. Press "Clear data."
    8. Wait for everything to re-sync.
    Hope this helps someone else.
     
  7. peteypoo

    peteypoo New Member

    Joined:
    Jul 22, 2010
    Messages:
    1
    Likes Received:
    0
    Thanks, I needed that. I appreciate your posting your find, too--it's so easy to get an answer and stay away from the forum until your next problem.

    Thanks again.

    P
     
  8. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    Glad to help. I get a lot out of this forum, and its good to be able to contribute.
     
  9. maverick999

    maverick999 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    35
    Likes Received:
    1
    I'm currently able to see all of my personal Google calendars using my Google account, so I've tried adding my Google apps account as an Exchange account so that I can sync those calendars also. No luck. Is anyone else doing this?
     
  10. chuckhubbert

    chuckhubbert Member

    Joined:
    Aug 15, 2010
    Messages:
    5
    Likes Received:
    1
    Here's something else that may help someone. The steps by ewingr were a HUGE help to me, but things weren't quite right yet. It turns out that there needs to be an event on each calendar for today in order for them to sync.

    Finally, I have all three of my calendars in my google account available on the Captivate.

    Thanks ewingr for the boost!
     
    RebL likes this.
  11. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    Wow! That's interesting. Thanks for the tip. I must have been lucky and that was the case when I did it.
     
  12. NorCal Einstein

    NorCal Einstein Well-Known Member

    Joined:
    Jul 31, 2010
    Messages:
    298
    Likes Received:
    42
    I'm wondering if anyone has any tips for me. I'm having the same issue not being able to see my shared calendars, but these are shared calendars to my Google Apps Premier account. I've tried to do ewingr's fix to no success.

    This is really going to be a deal breaker for me if I can't view my shared calendars :(, I hope there's a way to make it work!
     
  13. maverick999

    maverick999 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    35
    Likes Received:
    1
    When you share the calendar with your Google account, you have to make sure that they have Administrator access to the calendar (AKA: Change events and sharing). If your shared calendars don't show up in the "My Calendars" section, then they won't show up on your phone.

    Depending on your Google Apps Domain security settings, your administrator might not allow this. Make sure that "Share all information, and outsiders can change calendars" is enabled in the Calendar settings for your domain. That should do the trick!
     
  14. NorCal Einstein

    NorCal Einstein Well-Known Member

    Joined:
    Jul 31, 2010
    Messages:
    298
    Likes Received:
    42
    Maverick, first off I want to say thank you for answering my questions...I'm a little frantic right now and there just isn't too much info out there about Google Apps Premier integration.

    In my Premier account, all my shared calendars SHOW up under the "My Calendars" section. I happen to have administrative access, so I've gone ahead and changed sharing options to "Share all info, and outsiders can change calendars". This was done about 30 minutes ago.

    I'm still not able to view those shared calendars on the phone. I'm wondering if I need to delete the Premier account from my phone, and set it up again maybe?

    EDIT: Re-adding the account didn't change anything.
     
  15. FrankAtlanta

    FrankAtlanta Member

    Joined:
    Aug 19, 2010
    Messages:
    5
    Likes Received:
    0
    On a related now, how do I get the "My calendar" on the phone to sync with Google Calendar - is that possible?

    I find that my phone is defaulting to the "My calendar" option when I set an appointment; however, these appointments don't sync with Google Calendar (whereas my other calendars will sync).

    Questions:
    1. Is it possible to have the default "My calendar" on the Captivate sync to Google Calendar? I set-up a new "My calendar" on Google Calendar, but that just appeared as another calendar and didn't pick-up the entries from my phone.

    2. Is it possible to change the defaults on the Captivate so it will default to the "<email>@gmail.com" calendar / is it possible to change any of the default Calendar settings on the Captivate?

    thanks!
    Frank
     
  16. NorCal Einstein

    NorCal Einstein Well-Known Member

    Joined:
    Jul 31, 2010
    Messages:
    298
    Likes Received:
    42
    I believe I've read this a few times before in other places:
    With the built-in calendar, you cannot change your default calendar from the "My calendar" to your Google Calendar. I also don't believe events from "My calendar" can sync to your Google Calendar. You'll have to run a 3rd party calendar application which will allow you to change the default calendar, once you do that, you shouldn't need to use "My calendar" anymore.
     
    FrankAtlanta likes this.
  17. sremick

    sremick Well-Known Member

    Joined:
    Jun 18, 2010
    Messages:
    2,521
    Likes Received:
    356
    I'm experimenting with Gemini and Jorte, but neither seems to have the solid polish of the stock calendar. :(

    I too want to completely ignore the on-the-phone-only "My Calendar". I want everything in my Google calendar, which I also have synced nicely with Mozilla Thunderbird.
     
  18. chuckhubbert

    chuckhubbert Member

    Joined:
    Aug 15, 2010
    Messages:
    5
    Likes Received:
    1
    Do you have an event for today in each calendar? That's what I needed to do to get them all to sync.
     
  19. maverick999

    maverick999 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    35
    Likes Received:
    1
    Did you go into your calendar settings->Calendars and it's still not showing there?
     
  20. NorCal Einstein

    NorCal Einstein Well-Known Member

    Joined:
    Jul 31, 2010
    Messages:
    298
    Likes Received:
    42
    I have an event in each day. I'm thinking the problem might be with the way android handles Premier accounts (setting them up as exchange). I can see shared calendars with my regular Gmail but not with my Premier account. I really wish there was more sport especially from Google for its paying users.
     
  21. maverick999

    maverick999 Active Member

    Joined:
    Jul 18, 2010
    Messages:
    35
    Likes Received:
    1
    I have all of my premier calendars shared through my personal Google account and it works just fine. I then added my premier e-mail as a Google account for e-mail.
     
  22. FrankAtlanta

    FrankAtlanta Member

    Joined:
    Aug 19, 2010
    Messages:
    5
    Likes Received:
    0
    NorCal - thanks for the explanation!

     
  23. ewingr

    ewingr Well-Known Member This Topic's Starter

    Joined:
    Apr 30, 2010
    Messages:
    579
    Likes Received:
    30
    Another thing that needs to happen in order to see all cals on your phone: When online, looking at the Google Calendar, all shared calendars (that you want to synch to) must be shown on your Google Calendar. You can click on them to have them disappear, or reappear, wiht different colors. If they do not show when looking at them in Google, I don't think they will synch.

    I wish I could turn them on and off on the phone view too, but I don't see a way to do it.

    On the question about My Calendar, it is correct that you cannot have it synch to Google, nor can you change the default in the calendars on the phone w/o using a third party calendar.

    The fact is, the calendar has some maturing to do.
     
  24. onepoint

    onepoint Member

    Joined:
    Jul 16, 2010
    Messages:
    24
    Likes Received:
    5
    This is a disappointment. I would like to completely disregard the "My Calendar" and stick with my Google Calender option in all aspects. I've already created a few entries and mistakenly saved them to "My Calendar" because I forgot to change the option when creating the entry. I guess I'm just going to have to break the habit.
     
  25. NorCal Einstein

    NorCal Einstein Well-Known Member

    Joined:
    Jul 31, 2010
    Messages:
    298
    Likes Received:
    42
    This is what I ended up having to go to get things to work. It's not ideal for me since I really wanted to keep personal/business separate. I hope, but doubt there will be better integration for Premier as time goes by.

    On another note, I have my calendar set to a week view, but it only shows events from 12PM and later. If I want to see events before 12PM, I have to scroll up. Is there any way to change the time setting so that by default I can see events that occur before 12?

    Thanks!
     

Share This Page

Loading...