Not sure if T589R is just bricked...or worse? [SOLVED]Support

Last Updated:

  1. iChinadian

    iChinadian Member

    I apologize if this topic has been covered, and the length of my message.

    Phone: Samsung SGH-T589R (known here as the Galaxy Q) from Fido (part of Rogers Wireless) with original USB cable from Samsung
    Android version: 2.2 Froyo
    PC O/S: Windows 7 Ultimate x64
    Software and drivers installed: Samsung Kies, Samsung USB Driver for Mobile Phones, Odin Multi Downloader v.4.43 (run as administrator), CheckFusDownloader v2.1, Android SDK Tools 20.0.3.

    Background: I wanted to hack the rooted and unlocked phone to enable 1700 MHz/2100 MHz UMTS AWS so I could use it with another carrier. Seeing that that was not possible, I then used CheckFusDownloader to download two firmware files and used WinRAR to extract T589UVKF1-T589UVKF1-T589UVKF1-HOME.tar.md5 (T-Mobile) and T589RUXKG2_HOME_BINARY.tar (Rogers).

    I first tried to use Odin3 1.85 but got stuck at "Setup Connection". I was able to remove the phone and used "T"-<power button> to get into recovery mode to do a reset without any problems. I then tried a version 4.x Odin and the phone got stuck at "AMSS Download". I removed the phone and my phone has been stuck in the "Emergency Download Mode" AKA BSOD, i.e. the phone-warning sign-PC screen ever since when I try to turn it on. In fact, I can't even get into recovery mode anymore. I can still get into download mode, but neither Kies nor ADB can detect the phone when it is in download mode.

    I have spent many, MANY hours trying different variations including removing the SIM card, the SD card, and the battery. I have also tried using a different USB cable and a different computer, all without any luck. I have even extracted the contents of the firmware files into a folder and flashing them individually, and modifying the original OPS file by deleting "amss" from the 4th line so Odin wouldn't try to flash the file. Using these methods Odin always says the flashings passed, but the phone still wouldn't boot. Also, I have noticed that Odin reports FAIL if I check "Debug Only" and all the five boxes. Does this mean Odin never really flashed the firmware?

    The OPS file:


    In Odin I have had every box checked, and also only with "Protect OPS checked". As mentioned, I have tried using adb but it doesn't show the phone even though the Google device driver is installed. I refuse to believe that the phone is dead, seeing that it can still enter download mode. However, what I don't understand is why it shows the BSOD when I try to enter recovery mode. Have I corrupted the bootloader? Is the partition table fried? The phone is not popular so it has been very difficult to find any technical information. I could bring the phone to Fido and make up some kind of BS to try to avoid paying repair charge, but I think they will find out the phone was rooted. Besides, I'd really like to try to learn something by fixing this myself.

    Thanks in advance for any help!


    Problem solved and I feel like an idiot, though a relieved idiot. It turns out that all along all I needed was to use Odin 4.40.

  2. TehDewster

    TehDewster Member

  3. iChinadian

    iChinadian Member

    *** solved ***

Share This Page