1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Nothing at all unless plugged into computer!


  1. My Lucid does not turn on, that I know if, when plugged into the computer via USB the lights flash & the computer keeps making the sound it makes when you plug in a USB device then one second later it makes the sound that it makes when you remove the device, the first time I plugged it into the computer, the computer popped up a bubble saying "USB Human Interface Device successfully installed & ready to use" & in My Computer nothing comes up, not that it has enough time scan for it, but to no avail nothing comes up on the phone's screen at any point, I was thinking of just throwing it away but just the fact that there's anything at all going on, being the lights, gives me at least a little hope that I can save it.
    I've tried recovery mode & download mode but nothing at all, Verizon Software Upgrade Assistant doesn't have enough time to detect it, since the computer mounts it & removes it right after over & over again, to actually update & fix it, I am at a loss.
    Any ideas?

    Advertisement
    :
  2. ozzy8160

    ozzy8160 Member

    what have u done to the phone where u trying to root or rom it? change any system file? or did it one day just stop working, have u tried the lg support software when i soft bricked my phone without a nandroid it saved my life
  3. I tried to use Mobile Odin Pro, not knowing before using it that it wasn't compatible, to install a rom, it just turned off &, again, never came back on, or maybe it is on, just nothing on the screen, unless, as I said, its plugged into the computer via USB but thats still just the lights flashing & computer mounting & unmounting it 1 second later, LG Support Software is not detecting it and it comes up as a USB Human Interface Device, is that supposed to happen?
  4. mrryanthai

    mrryanthai Well-Known Member

    Does your phone turn on at all plugged into the computer or do you just have a black screen with flashing lights?Try downloading the LG Tool from LG and flash it back to stock.If not,I hope you have warranty cause there's a high chance of your phone being completely bricked.Another thing,don't try to flash a rom for the Lucid,none work.You'll get a system error.Just call Verizon and say you dropped it in water if they ask you any questions.Good luck,PM if you need any help.
  5. airtioteclint

    airtioteclint Well-Known Member

    As far as I know there are no roms for the Lucid except stock. And nothing that is odin flashable. :/

    I wonder if the problem could be low battery as that is the symtom of a completely dead battery. Leave the charger plugged in for about an hour and see if it helps. If you aren't able to get it into recovery or download mode then it might be hopeless.
  6. mrryanthai

    mrryanthai Well-Known Member

    No there aren't any ROMs yet.Hopefully he has warranty.I bricked my first Lucid because of that lol.
Loading...

Share This Page