NV Flash -Full factory resetSupport


Last Updated: 2015-04-08 10:07:48
  1. Jerrbear585

    Jerrbear585 New Member

    Hi there, I am brand new to androids. I just got my G-tab yesterday and today i was playing around with it and after I turned it off. When I went to turn it back on, it wouldn't go past the vegan tab screen and would just turn off. I should probably state that I bought it pre-rooted since I wanted to avoid some of the technical stuff. But today I tried fixing it by doing it a few ways and I think I only messed it up. Now when I press and hold the power plus the vloume it just gives me an error triangle and tries to reboot. But I when I did the NVflash, I didn't do it right for sure. I got the drivers installed but couldn't figure out the directions from there. I'm not even sure I "extracted" the files properly. I know I sound like a moron, but I am really not good with computers. I thought I was avoiding this whole thing buying it pre-hacked. Can anyone help me? I am freaking out! I need everything explained to me like I am a child, which I am sure is annoying to some. Please help me!

    Advertisement
  2. luvduchovny

    luvduchovny Well-Known Member

    What happens when you press the power and the Volume Up key? You should see the Viewsonic Birds and at the top left you should see the words Recovery Mode. Once it says that let it go. The screen should go black with green type. If is says something like Clockwork Mod at the top it was modded using that program. From there you might try wipe data/wipe cache, then restart the tablet again. Since you probably haven't put your settings in you won't be losing much.
    xmr405o likes this.
  3. xmr405o

    xmr405o Well-Known Member

    Do what luvduchovny said? Don't try NVflash unless you absolutely need to. If you can get into Clockwork mod recovery, looks something like the image below, then you can probably just reload your ROM.




    [​IMG]
  4. SkyDragon8

    SkyDragon8 Member

    Hi,

    I'm very new to the Andriod, and need help with my G-Tablet. I had flash a custom ROM (Vegan Tab 7), then when I try to format my external SD card, that's when trouble began. I must have made mistake and it it to the Internal SD Card istead (maybe?? not even sure). Anyway, everytime I boot up I would get only to the bootup screen, and it looks like it reboots and cycle thru the boot up again and again.. won't stop.

    So I now NVflash it, and it looks like it work, because now the boot up logo is back to the "G Tablet" and the the 3 viewsonic birds, and it would loop thru this as well. I try to go into recovery (with the + vloume) and it detects it and comes up with a traingle with "!" inside and then reboots into the loop again. I'm freaking out and don't know what to do..

    Please please please help... :(:confused:
  5. xmr405o

    xmr405o Well-Known Member

    Hi skydragon

    Welcome to the forums!

    When you Nvflashed, you flashed the stock recovery again. That exclamation mark means it is looking for an update but can't find one.

    Anyways, you can try installing clockwork mod again by using the external sd card method. We can then try to reinstall vegan gb again.

    First step

    Download and extract the update.zip and recovery folder to your pc. Here's the file...

    http://forum.xda-developers.com/attachment.php?attachmentid=478614&d=1293950861

    -Take those files and put them on your sdcard.
    -Take sd card and put it in your gtablet.
    -Power on while holding the volume up. Hopefully it'll begin installing the update file.
    -After that, turn off the gtablet and power on again holding the volume up
    It should take you to clockwork mod. If you get that on your gtablet, then you can save your gtablet.

    Since you can't boot up to mount usb storage, you'll have to do it in Clockwork. This way you can download Vegan GB or any other ROM and put them in your internal SD card so Clockwork can recognize it.

    Hopefully you have the Vegan ROM zip file, if you don't you can download it here if you want to install Vegan GB. Download this file on your PC.

    http://vegantab.gojimi.com/download/VEGAn-GE-7.0.0-RC1-Harmony-signed.zip

    To get that zip file on your gtablet,

    -Boot into Clockwork recovery,
    -Connect your gtablet into your computer
    -scroll down to Mounts and Storage
    -scroll down to Mount USB Mass Storage (enter)
    -You should now see your gtablet connected to your computer.
    -Place the Vegan Zip into the root of your internal memory
    -Then unmount the USB
    -Press back until you get to the main menu of clockwork.
    -Wipe data/factory reset - let it finish
    -Wipe cache- let it finish
    -Install zip from sdcard
    -choose zip from sd card
    - Find the Vegan RC1 zip
    -Let it install, then go back to the main menu of clockwork then reboot system now.

    Hopefully it'll be out of boot loop.

    Edit: Almost forgot, when you reformatted your SD card, what did you set it up to 2048 and 0?
  6. SkyDragon8

    SkyDragon8 Member

    Hi xmr405o,

    Thanks for the advice.. I could not wait yesterday so I did more research and this is what I did..

    1. Since I nvflash it with stock (1.0), I lost CWM recovery and could not repartion.
    2. I found directions on how to include cwm in the nvflash files. (told recovery.img from cwm and rename it to part9.img and replace it in nvflash diretory).
    3. Rerun the nvflash and it work great. boot into cwm recovery and repartion 2048 and 0.
    4. now, over air update stock of 1.1-5388 was found but could not install because cwm was installed on g tab. So I sideload and install thru cwm as update.zip and it work and booted ok and back to stock now.

    Now have to decide with Rom to go with.. I enjoy vegan harmony and had no problem, but want to try other ROM.. I want something with overclock build in..

    Any suggustion is greatlly appricated.

    Thanks again
  7. Ruggerman

    Ruggerman New Member

    Good Morning fellow Gtabers - Need some help/ advice. - I have been having some difficult times with my gtab lately. I have been trying to install Clockmod v8-gtab for the past few days and have had no luck. I called viewsonic to see if they could assist in finding a work around on getting Google Market installe on the tablet and they would not help at all. - Told me I would be out of warranty if I did it. After trying a couple of times, I ended up bricking my system (I think). Everytime I try to power on it will get to the TapnTap booting part on the screen and start to flash for a few seconds and then power off. I did some searching and came to this site where it gave great step by step directions on Nvflash and fresh re-install. I thought it worked - I get a screen now that has a triangle with an exclamation point in the middle and shuts down again.
    Am I doing something wrong - Can anyone help with my situation. I would greatly appreciate it.
    Thanks
  8. Margo_dd

    Margo_dd New Member

    Hey all need your help on the flip side of this issue. I have downloaded and used the USB drivers and I assume I should see my gtablet as a hard drive... but I'm seeing nothing. I see the NVidia USB driver loaded in my system.. just not seeing anything in my explorer. Anyone else have this problem?

    EDIT: Played with it a bit & sawy it load up the Nvidia Recovery USB drivers when I loaded it in, figured I didnt have it in APX mode... but I still wasn't able to see it in explorer... should I be able too?
  9. PGP_Protector

    PGP_Protector Well-Known Member

    Thank you Thank you & thank you.
    I had done a bad flash & had soft bricked my tablet :eek: and was having a mess of a time trying to get nvflash to work.
    All the threads I read just talked about plug in the USB Cable , and install APX Drivers when asked, but none of them (or I just kept missing it) stated to use volume DOWN at power up.

    I'm back up and booting now
  10. luigitheman

    luigitheman New Member

    I followed each step by step and watched the video on youtube about it as well. I have not been successful in restoring my g tablet. It constantly flashes the start screen over and over again. I have tried several times to flash it and reinstall the software but no luck what could I be doing wrong?
  11. xmr405o

    xmr405o Well-Known Member

    Hi Luigi

    Can you tell me which steps you have completed? Most of the time, NVflash doesn't work because the drivers aren't installed or the wrong nvflash files are being used. So if you can let me know what you have done, I'll try to troubleshoot it for you. It might help others along the way.

    Thanks!

    Edit: Also, let me know what bootloader you are on.
  12. myzoo

    myzoo Member

    HELP!! I have a GTAB and I am stuck in APX mode. I have downloaded all the files but my windows laptop, but my laptop is not seeing the usb connection. How do I get past this so that can continue on. Thanking all in advance Jaye
  13. xmr405o

    xmr405o Well-Known Member

    Did you install the necessary drivers? Does your laptop at least recognize it as new hardware?
    myzoo likes this.
  14. myzoo

    myzoo Member

    No it does not see it as new hardware, if I unplug it the device manager flashs on/off so it appears it is seeing something
  15. xmr405o

    xmr405o Well-Known Member

    I'm running Windows XP, when I first tried to NVflash, a setup wizard pop up would appear. Make sure to download the drivers.

    This is a total guess but try clicking on device manager and see if there's an option to install new hardware or drivers. Or maybe a set up wizard.
  16. ReplicateThis

    ReplicateThis New Member

    I realize this is am old thread, but after searching Google and forums for a few hours I need moral support if nothing else... I have a new gTab and I am preparing NVflash to prepared for a new ROM, just in case it needs warranty work done in future.

    I have downloaded the files indicated at the beginning of the thread, and after switching the tablet to APX mode and hooking up the wire, my Windows 7 64bit PC popped up the message about the driver. So, following the instructions, in the Device Manager I attempted to install the driver I downloaded from the link from bekit's image as mentioned above, but my computer does not recognize them.

    Just to mention, I did unzip the files, and have tried both the amd64 version, as well as i386, but none work. Are there updated APX driver files, or an alternate I can try?

    Thanks for your help, all!
  17. xmr405o

    xmr405o Well-Known Member

    Have you tried the first link on the first post. I believe there are links to the correct drivers for your PC. It'll take you to a site called Gtablet for dummies. It's a pretty good resource too.
    ReplicateThis likes this.
  18. ReplicateThis

    ReplicateThis New Member

    It seems it was a Windows oddity. When I attempted to point the Device Manager specifically at the amd64 or i386 folders, the process failed. When I re-downloaded the files from the gTab for Dummies dite, I told Device Manager to simply go to any subfolders of the unzipped folder and it worked. So either Windows hiccup, corrupted download earlier, or ineptitude of the user were responsible... :eek:

    Thank you for your help, and quick response!!
  19. Caramellanne

    Caramellanne New Member

    Hey, so I have had my gtab for a few months now...Did some playing around and put a vegan - gingerbread thing on it (forgive me, totally new to this) and it worked fine up until recently where it would force close everytime I tried to type anything into the internet browser....Now, all of the sudden, my gtab will not boot up...At first it was stuck in CWM in a (bootloop?!?) and I tried everything, repartitioning the SD card, etc....NOW the scree stays completely black, and the light that comes on when plugged in stays red, it's like it won't charge. So now I am in the same boat with the other people who cannot get windows 7 to recognize the device, I tried all of the steps of trying the NVFlash however my computer doesn't give me the option to select a file to open when I plug the tablet in, most of the time it just makes the beep sound and doesn't do anything...I am in need of serious help here guys! Eek!
  20. treybraid

    treybraid Member

    Can someone please help me with mine... I tried to run clockmod and now it wont load the bootloader...

    Gets stuck with this:

    Recovery Key Detected - Booting recovery Kernel image...

    I tried what was explained in the above post and nothing...I really want to root this devide and load Honeycomb or ICS on it eventually...

    I can boot it up normally...
    Please advise--- total newbie here..

    Trey
  21. timmspinn

    timmspinn New Member

    I'm stuck. I have already done NVFlash once successfully, so I know the procedure. I tried to do it again on the same computer, and on a different one, and I load the windows driver, but when I run the .bat file, it says "Unknown device found".

    Not sure what to do next. I need to return this thing to stock to return it to Viewsonic for a screen repair.

    Anyone know what I can do to get it detect my device? Please help.
  22. rmckwatts

    rmckwatts New Member

    Where is the best place to find the ES Explorer nd th G Tablet.zip?
  23. SolidOrange

    SolidOrange Well-Known Member

  24. rishi0528

    rishi0528 New Member

    Hi i know this is old but i am having alot of trouble.. i followed every step here and no matter what rom i load.. when it rebooted or i have to turn it back on .. it will go to the black screen.. i just want this thing to factory default just the way it came out of the box.. if i need too..
  25. xmr405o

    xmr405o Well-Known Member

    So currently you are not able to get into your tablet? Did you see the first link on post #1?
    I would follow those instructions for NVflash because it has newer files.

Share This Page