Odd camera issueSupport

Last Updated:

  1. Murf1

    Murf1 Well-Known Member

    UPDATE: My phone is rooted now, but stock ROM.

    I turn on the camera and it starts up with all the normal settings on the screen, but no picture. Just black background. If I click the shutter button nothing happens or I get a "Force close" message.

    If I turn the phone off/on. Then the camera works normal again. I've had this happen 3 times now. "Rebooting" the phone fixes it at the point in time.

    Anyone ever here of this?

    I wonder if another app is affecting it. I have Android Assistant (18 features) and it has an "Auto Boost" feature I have set for every 3 hours. I just turned that off to see if that is the culprit.


  2. sneaky_1

    sneaky_1 Well-Known Member

    If you try another camera app it may tell you if it is a hardware issue or app issue, also. I suggest camera ics.
  3. Artine

    Artine Well-Known Member Contributor

    Camera360 is my personal favorite.
  4. Murf1

    Murf1 Well-Known Member

    The odd thing is the apps GhostCam, PicsArt, and Paper Camera all work fine. Then I installed UCam and and CameraICS which work fine. I like ICS because it doesn't have all the extra "bloat" (which is why I like the stock one). So when stock fails, I go to ICS.

    But that is odd. How can the stock camera app "go bad"?!? It works sometimes, but not others. Random throughout the day. One time I let it set on the "black", then after a minute or less the view thru the camera lense finally appeared. It is like it is "waiting" on something to show the camera view or is bogged down getting to it. But only happens on stock camera (and never use to).
  5. Murf1

    Murf1 Well-Known Member

    I think some setting got hosed and it was stuck in some in between state because I started camcorder app then slid the slider to camera and that worked. Then when I started the camera after that it is working now. We'll see...
  6. snorge

    snorge Well-Known Member

    maybe your finger is over the lens.
  7. Murf1

    Murf1 Well-Known Member

    Sounds reasonable, but that's not it or I would be 8 months I've had the phone. The program lags and/or freezes on showing the camera view (sometimes).
  8. Artine

    Artine Well-Known Member Contributor

    If it is rare (once a.... fortnight?) it's not likely really an issue, but could just be due to simple lag. The stock apps, in addition to having only minimal features (not really a downside), are enormously laggy. Take the stock messaging app for example; it bothers me to no end how laggy that thing is compared to, say, Handcent or GO SMS - on Sleipnir it's the same case too. Then again, it's only really bothersome if you're trying to multitask or send multiple different messages quickly to different people - a one-off message is just fine.

    In other words, it's not that the app necessarily goes "bad," it's that the stock apps are very old, and outdated, and their performance (especially the stock messaging app -.-* ) should be expected to be lesser than that of their more-modern brethren. And I'm sure you could find a camera/camcorder app that doesn't have too many bells and whistles :) It's just the nature of programming and the advances of programming - with a long enough time span old programs are just old, and don't perform on-par with similar programs that are being currently maintained and updated if those old programs are no longer being updated themselves.
  9. Murf1

    Murf1 Well-Known Member

    Does anyone know if I got (and where I would get it) another stock camera app from a different model LG phone and replaced mine with it, would it work?

    (Or maybe one from a new version of Android, like for ICS.)

  10. Artine

    Artine Well-Known Member Contributor

    You'll need to do a lot of modifying of the app in question if you mean to take one from a higher version of Android and put it on a lower-version phone. Try Googling "backporting," to get you started. Otherwise, unless it's from the same version of Android I'd bet it probably won't work at all without some tweaking on your end, but it's always worth a shot anyway.
  11. miediev

    miediev Well-Known Member

  12. Murf1

    Murf1 Well-Known Member

    Sounds like for me I need to stick with same Android version. Thanks.
  13. Murf1

    Murf1 Well-Known Member


    I presume my phones stock ROM is Gingerbread?

    So I should be able to rename my stock camera app something else and then copy this new one to the same location and then rename it to what my original camera app was named? (So the same stock icon will work for it.)
    Or is there a better/different way?

  14. miediev

    miediev Well-Known Member

  15. Murf1

    Murf1 Well-Known Member

    I don't know what I was thinking. I guess thinking it was a special app just because it was in root. I don't care what the icon looks like. I was confusing myself. :confused:

    I also got to looking at the Camera-ICS link you sent. I have tried that one before and like it except for you cannot click on screen to tell it what to focus on. I emailed the developer on it and he said "unfortunately on Android 2.3.x touch to focus requiere to use private APIs and it's not easy to implement on a compatible way. On Android 4.0 this should work".
    So for the random times the stock app decides it doesn't want to work, I'm using "Camera360" app that lets me touch to focus. (The thing I don't like about it is that space it takes up.)

    I still think something on my phone is "blocking" the stock app from running the times it doesn't, but unable to determine what is doing it. I've tried killing all kinds of tasks when it does it to try and determine, but that hasn't worked yet.

  16. miediev

    miediev Well-Known Member

    Have you tried wiping data and cache on the camera? Maybe after that rebooting and wiping the phone cache and dalvik cache as well.

    Edit: Also, try clearing data/cache on gallery and media storage
  17. Murf1

    Murf1 Well-Known Member

    I did the "clear data" on the Camera and Gallery apps to no avail.

    My phone is rooted, but I use stock ROM and no CWM. To wipe phone cache and dalvik cache, don't you need CWM for that?
    Also, would that remove my user installed apps, saved data, contacts, etc?

  18. miediev

    miediev Well-Known Member

    You can do it through the terminal:

    cd data/dalvik-cache
    rm *
    cd cache
    rm *

    On a side note, installing CWM is as simple as pushing a button in an app and allows you to make system backups that can save your phone if you mess something up.
  19. Murf1

    Murf1 Well-Known Member

    Would that (cache clearing) remove my user installed apps, saved data, contacts, etc?
  20. miediev

    miediev Well-Known Member

    No it doesn't affect your data in any way. The cache is just a place where temporary files are created and stored while other programs are running. The Dalvik-cache is slightly more complicated, but basically it is used to cache program dependencies so that apps start up faster. It is built when the phone boots up, so deleting the dalvik cache forces the phone to rebuild it, thus correcting any errors or old data that may be causing problems.
    Murf1 likes this.
  21. Murf1

    Murf1 Well-Known Member

    So I take it I need to download a terminal app?
    Then are these commands like DOS/Windows CMD where you enter the first one, press Enter, enter the second one, press Enter... Or do they need placed in some sort of (.bat) batch type file and then executed (and what is the command to execute bat file).

    Sorry, I'm very familiar with writing DOS bat files, but not with linux or it's syntax.
  22. miediev

    miediev Well-Known Member

    Yeah, I'm much better with DOS than with Linux myself, but they operate in a very similar fashion. To answer your questions:

    Yes you need to download a terminal app, I suggest this one: https://play.google.com/store/apps/details?id=jackpal.androidterm

    Once that's installed and running, you enter the commands just like you suggested; one line at a time. The last line, as the command suggests, reboots your phone. You can do that using whatever method you like, I just use the reboot command since you're there anyway.
  23. Murf1

    Murf1 Well-Known Member

    I believe the issue has been resolved. The camera use to fail to work 75% of the time. I stopped using Holo Launcher (and Holo Locker) and started using Launcher8. The camera has not failed a single time since then. So I believe it was an issue with Holo Launcher. :)

Share This Page